Вход | Регистрация

1С:Предприятие ::

Метки: 

УНФ 1.6 Контроль остатков при проведении

Я
   I_learn_1c
 
31.01.18 - 11:58
Доброе утро,

есть проблема. подкиньте идей пожалуйста.

нужно чтобы для пользователей с полными правами не выполнялся контроль остатков при проведении, а для остальных выполнялся.

добавить при старте пользователя кусок типа
Если РольДоступна("ПолныеПрава") Тогда
Константы.КонтролироватьОстаткиПриПроведении.Установить(Ложь);
Иначе
Константы.КонтролироватьОстаткиПриПроведении.Установить(Истина);
КонецЕсли;

не вариант, так как пользователи одновременно работают, заходят, выходят.. будет скакать значение константы тогда.

как его бы установить отдельно для каждого?
 
 
   Джо-джо
 
1 - 31.01.18 - 12:00
>>Контроль остатков при проведении
>>добавить при старте 
2 по логике
   arsik
 
2 - 31.01.18 - 12:01
(0) Найди где эта константа проверяется.
   arsik
 
3 - 31.01.18 - 12:05
Посмотрел. Да. Криво они там сделали. При проведении проверяется константа, хотя есть метод для проверки
ОбщийМодуль.УправлениеНебольшойФирмойСервер.ВыполнитьКонтрольОстатков()
   arsik
 
4 - 31.01.18 - 12:08
Поменять в модулях менеджереров документов в процедуре "выполнитьКонтроль" вот этот кусок
    Если НЕ Константы.КонтролироватьОстаткиПриПроведении.Получить() Тогда
        Возврат;
    КонецЕсли;

на это
    Если НЕ ОбщийМодуль.УправлениеНебольшойФирмойСервер.ВыполнитьКонтрольОстатков() Тогда
        Возврат;
    КонецЕсли;


и чуть поправить функцию 
ОбщийМодуль.УправлениеНебольшойФирмойСервер.ВыполнитьКонтрольОстатков()
   Джо-джо
 
5 - 31.01.18 - 12:09
(4) Почему бы не проверить роль?
   arsik
 
6 - 31.01.18 - 12:11
(5) Ну проверить роль но только в одном месте, вот тут
ОбщийМодуль.УправлениеНебольшойФирмойСервер.ВыполнитьКонтрольОстатков()

   arsik
 
7 - 31.01.18 - 12:12
* (4) Ошибка
правильно так
    Если НЕ УправлениеНебольшойФирмойСервер.ВыполнитьКонтрольОстатков() Тогда
        Возврат;
    КонецЕсли;

   I_learn_1c
 
8 - 31.01.18 - 12:30
(7) я тоже нашла эту функцию но не так быстро.
то есть если подправлю ее вот так, то норм же?
Функция ВыполнитьКонтрольОстатков() Экспорт
    
    Если РольДоступна("ПолныеПрава")Тогда
        Возврат Ложь;
    Иначе    
        Возврат Константы.КонтролироватьОстаткиПриПроведении.Получить();
    КонецЕсли;
КонецФункции// ВыполнитьКонтрольОстатков()
   arsik
 
9 - 31.01.18 - 12:34
(8) Нет не  норм. Это только часть.
Кроме нее еще нужно исправить модули менеджеров документов, где встречается вызов "Константы.КонтролироватьОстаткиПриПроведении.Получить()"
и заменить на "УправлениеНебольшойФирмойСервер.ВыполнитьКонтрольОстатков()"
   I_learn_1c
 
10 - 31.01.18 - 12:35
(8)
и плюс в каждом документе поменять тоже? правильно поняла?

это
в процедуре "выполнитьКонтроль" вот этот кусок 
    Если НЕ Константы.КонтролироватьОстаткиПриПроведении.Получить() Тогда
        Возврат;
    КонецЕсли;

на это 
    Если НЕ УправлениеНебольшойФирмойСервер.ВыполнитьКонтрольОстатков() Тогда
        Возврат;
    КонецЕсли;
 
 Рекламное место пустует
   I_learn_1c
 
11 - 31.01.18 - 12:36
(9) спасибо большое) сейчас попробую
   arsik
 
12 - 31.01.18 - 12:38
(11) Вообще сделай полный поиск по конфигурации "Константы.КонтролироватьОстаткиПриПроведении.Получить()" увидишь все места где нужно поправить
   I_learn_1c
 
13 - 31.01.18 - 12:40
(12) а позже при обновлении релиза эти поправки могут затереться же?
   arsik
 
14 - 31.01.18 - 12:41
(13) Ну конечно. На вашем месте, я бы это сделал через расширение.
   I_learn_1c
 
15 - 31.01.18 - 12:55
(14) почитала про расширения. вроде штука полезная,но не до конца понятная, пойду с ними разбираться.. спасибо большое еще раз:)


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует