Вход | Регистрация

1С:Предприятие ::

Метки: 

Вопрос по полям поиска при переносе из 1с7 в 1с8

Я
   URAL
 
30.01.18 - 16:29
Всем привет.
Подскажите работают ли поля поиска при переносе данных из версии1с7 в 1с8?

Пробую осуществлять поиск, и не пойму почему не ищет...

Если СвойстваПоиска["ЭтоГруппа"] Тогда
    Если НомерВариантаПоиска = 1 тогда
        СтрокаИменСвойствПоиска = "Код, Наименование, Родитель, ЭтоГруппа";
    ИначеЕсли НомерВариантаПоиска = 2 тогда
        СтрокаИменСвойствПоиска = "Наименование, Родитель, ЭтоГруппа";
    КонецЕсли;
Иначе
    Если ЗначениеЗаполнено(СвойстваПоиска["Артикул"]) Тогда
        Если НомерВариантаПоиска = 3 тогда
            СтрокаИменСвойствПоиска = "Артикул, Код,  Наименование, Родитель, ЭтоГруппа";
        ИначеЕсли НомерВариантаПоиска = 4 тогда
            СтрокаИменСвойствПоиска = "Артикул, Наименование, Родитель, ЭтоГруппа";
        ИначеЕсли НомерВариантаПоиска = 5 тогда
            СтрокаИменСвойствПоиска = "Код, Наименование, Родитель, ЭтоГруппа";
        Иначе
            СтрокаИменСвойствПоиска = "Наименование, Родитель, ЭтоГруппа";
        КонецЕсли;
    Иначе
        Если НомерВариантаПоиска = 6 тогда
            СтрокаИменСвойствПоиска = "Код, Наименование, Родитель, ЭтоГруппа";
        ИначеЕсли НомерВариантаПоиска = 7 тогда
            СтрокаИменСвойствПоиска = "Наименование, Родитель, ЭтоГруппа";
        КонецЕсли;
    КонецЕсли;
КонецЕсли;


В КД написано:
Условия возникновения события
Только для платформы V8.
Событие выполняется при поиске элемента ссылочного типа. Если установлен поиск по уникальнму идентификатору и программа нашла элемент, то поиск прекращается. Если поиск по уникальному идентификатору не дал положительного результата и указано, что нужно продолжить поиск в этом случае или поиск по уникальному идентификатору не проводился, то программа пытается найти элементы по свойствам поиска. В обработчике нужно установить список полей через запятую по которым нужно проводить поиск. Если очередная попытка дала положительный результат, то поиск прекращается.
Поиск возможен только по тем полям у которых на этапе выгрузка был установлен флаг поиска данных.
 
  Рекламное место пустует
   URAL
 
1 - 30.01.18 - 16:29
Приемник версия 1С8
   Defender aka LINN
 
2 - 30.01.18 - 16:30
"Если поиск по уникальному идентификатору не дал положительного результата *и указано, что нужно продолжить поиск в этом случае*"
   URAL
 
3 - 30.01.18 - 16:31
(3)использование поиска по УИ не активно в данном случае, но поля поиска активны
   Йохохо
 
4 - 30.01.18 - 16:38
ошибка в нумерации ветвлений Если, не надо инкрементировать если не этогруппа
   tesseract
 
5 - 30.01.18 - 16:48
Есть нюанс - поиск по уникальному идентификатору происходит ТОЛЬКО в режиме загрузки данных. Если загружать в обычном режиме - поиск по GUID не происходит.
   URAL
 
6 - 30.01.18 - 16:53
(5) и в итоге работает поиск или нет когда с семерки в восьмерку?
   tesseract
 
7 - 30.01.18 - 18:49
(6) По полям работает. Откуда выгружено значения не имеет.
   Smile 8D
 
8 - 31.01.18 - 09:33
(6) в (4) же уже ответили, что неверно нумеруешь варианты поиска. В "Иначе" для проверки группы опять нумерация должна начинаться с 1. И в "иначе" для Артикула так же.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует