Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Отчет движение основных средств

v7: Отчет движение основных средств
Я
   aktmx
 
29.01.18 - 09:19
(1С 7.7) В Отчете движение ОС выходят поступления и списания основных средств, а также сидит и внутреннее перемещение(то есть во время отпуска определенного сотрудника ответственность за основные средства возлагаются на другого сотрудника и с помощью документа Внутреннее Перемещение передаются на этого другого сотрудника).Так вот вопрос заключается в том что, как можно сделать так чтобы в отчете отображались только поступления и списания, а внутренне перемещение не было??? Надеюсь смог объяснить, заранее спасибо!!!
 
 
   Darych
 
1 - 29.01.18 - 09:22
При формировании отчета не учитывать этот документ
   aktmx
 
2 - 30.01.18 - 09:01
а как это сделать?
   cw014
 
3 - 30.01.18 - 09:02
(2) в конфигураторе?
   aktmx
 
4 - 30.01.18 - 09:10
как прописать код в отчете чтоб исключал документ внутреннее перемещение?
   cw014
 
5 - 30.01.18 - 09:11
Не помню синтаксис 1С. Посмотри в других отчетах запросы
   aktmx
 
6 - 30.01.18 - 09:34
вот процедура в отчете может кто поможет что и куда надо написать ???
Процедура Сформировать()       

    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.Рассчитать(Дата1,Дата2);  
    
    П0101 = Ит.СНД("01.10");    П0102 = Ит.ДО("01.10");        П0103 = Ит.КО("01.10");        П0104 = Ит.СКД("01.10");
    П0105 = 0;                    П0106 = 0;                    П0107 = 0;                    П0108 = 0;
    

    
    П0201 = Ит.СНД("01.11");    П0202 = Ит.ДО("01.11");        П0203 = Ит.КО("01.11");        П0204 = Ит.СКД("01.11");
    П0205 = Ит.СНК("02.11");    П0206 = Ит.КО("02.11");        П0207 = Ит.ДО("02.11");        П0208 = Ит.СКК("02.11");

    П0301 = Ит.СНД("01.12");    П0302 = Ит.ДО("01.12");        П0303 = Ит.КО("01.12");        П0304 = Ит.СКД("01.12");
    П0305 = Ит.СНК("02.12");    П0306 = Ит.КО("02.12");        П0307 = Ит.ДО("02.12");     П0308 = Ит.СКК("02.12");

 
    П0401 = Ит.СНД("01.20.1")+Ит.СНД("01.20.0");            П0402 = Ит.ДО("01.20.1")+Ит.ДО("01.20.0");    
     П0403 = Ит.КО("01.20.1")+Ит.КО("01.20.0");                П0404 = Ит.СКД("01.20.1")+Ит.СКД("01.20.0");
    П0405 = Ит.СНК("02.20.1")+Ит.СНК("02.20.0");              П0406 = Ит.КО("02.20.1")+Ит.КО("02.20.0");    
    П0407 = Ит.ДО("02.20.1")+Ит.ДО("02.20.0");                П0408 = Ит.СКК("02.20.1")+Ит.СКК("02.20.0");

    П0501 = Ит.СНД("01.20.2");    П0502 = Ит.ДО("01.20.2");    П0503 = Ит.КО("01.20.2");    П0504 = Ит.СКД("01.20.2");
    П0505 = Ит.СНК("02.20.2");  П0506 = Ит.КО("02.20.2");    П0507 = Ит.ДО("02.20.2");    П0508 = Ит.СКК("02.20.2");

    П0601 = Ит.СНД("01.20.3");    П0602 = Ит.ДО("01.20.3");    П0603 = Ит.КО("01.20.3");    П0604 = Ит.СКД("01.20.3");
    П0605 = Ит.СНК("02.20.3");  П0606 = Ит.КО("02.20.3");   П0607 = Ит.ДО("02.20.3");    П0608 = Ит.СКК("02.20.3");
   
    П0701 = Ит.СНД("01.30")+Ит.СНД("01.42");                П0702 = Ит.ДО("01.30") +Ит.ДО("01.42");        
    П0703 = Ит.КО("01.30") +Ит.КО("01.42");                    П0704 = Ит.СКД("01.30")+Ит.СКД("01.42");
    П0705 = Ит.СНК("02.30")+Ит.СНК("02.42");                П0706 = Ит.КО("02.30") +Ит.КО("02.42");        
    П0707 = Ит.ДО("02.30") +Ит.ДО("02.42");                    П0708 = Ит.СКК("02.30")+Ит.СКК("02.42");

    П0801 = Ит.СНД("01.61");    П0802 = Ит.ДО("01.61");        П0803 = Ит.КО("01.61");        П0804 = Ит.СКД("01.61");
    П0805 = Ит.СНК("02.61");    П0806 = Ит.КО("02.61");        П0807 = Ит.ДО("02.61");        П0808 = Ит.СКК("02.61");

    П0901 = Ит.СНД("01.51");    П0902 = Ит.ДО("01.51");        П0903 = Ит.КО("01.51");        П0904 = Ит.СКД("01.51");
    П0905 = Ит.СНК("02.51");    П0906 = Ит.КО("02.51");        П0907 = Ит.ДО("02.51");        П0908 = Ит.СКК("02.51");

    П1001 = Ит.СНД("01.60");    П1002 = Ит.ДО("01.60");        П1003 = Ит.КО("01.60");        П1004 = Ит.СКД("01.60");
    П1005 = Ит.СНК("02.60");    П1006 = Ит.КО("02.60");        П1007 = Ит.ДО("02.60");        П1008 = Ит.СКК("02.60");

    П1101 = Ит.СНД("01.70.1");    П1102 = Ит.ДО("01.70.1");    П1103 = Ит.КО("01.70.1");    П1104 = Ит.СКД("01.70.1");
    П1105 = Ит.СНК("02.70.1");    П1106 = Ит.КО("02.70.1");    П1107 = Ит.ДО("02.70.1");    П1108 = Ит.СКК("02.70.1");

    П1201 = Ит.СНД("01.70.2");    П1202 = Ит.ДО("01.70.2");    П1203 = Ит.КО("01.70.2");    П1204 = Ит.СКД("01.70.2");
    П1205 = Ит.СНК("02.70.2");    П1206 = Ит.КО("02.70.2");    П1207 = Ит.ДО("02.70.2");    П1208 = Ит.СКК("02.70.2");

    П1301 = Ит.СНД("01.80");    П1302 = Ит.ДО("01.80");        П1303 = Ит.КО("01.80");     П1304 = Ит.СКД("01.80");
    П1305 = Ит.СНК("02.80");    П1306 = Ит.КО("02.80");        П1307 = Ит.ДО("02.80");        П1308 = Ит.СКК("02.80");

    П1401 = Ит.СНД("01.90");    П1402 = Ит.ДО("01.90");        П1403 = Ит.КО("01.90");        П1404 = Ит.СКД("01.90");
    П1405 = Ит.СНК("02.90");    П1406 = Ит.КО("02.90");        П1407 = Ит.ДО("02.90");        П1408 = Ит.СКК("02.90");

    П1501 = Ит.СНД("01.99");    П1502 = Ит.ДО("01.99");        П1503 = Ит.КО("01.99");        П1504 = Ит.СКД("01.99");
    П1505 = Ит.СНК("02.99");    П1506 = Ит.КО("02.99");        П1507 = Ит.ДО("02.99");        П1508 = Ит.СКК("02.99");

    П1601 = 0//Ит.СНД("03");        

    П1602 = 0//Ит.ДО("03");        

    П1603 = 0//Ит.КО("03");        

    П1604 = 0//Ит.СКД("03");

    П1605 = 0;                    П1606 = 0;                    П1607 = 0;                    П1608 = 0;

    П1901 = Ит.СНД("08.10") ;
    П1902 = Ит.ДО("08.10") ;
    П1903 = Ит.КО("08.10") ;
    П1904 = Ит.СКД("08.10") ;

    Спр = СоздатьОбъект("Справочник.ОсновныеСредства");
    Сп1 = СоздатьОбъект("СписокЗначений");
    Сп2 = СоздатьОбъект("СписокЗначений");
    Сп3 = СоздатьОбъект("СписокЗначений");
    Сп4 = СоздатьОбъект("СписокЗначений");
    Сп5 = СоздатьОбъект("СписокЗначений");
     ДатаНачала =Дата1;
     ДатаКонца = Дата2;
    Спр.ВыбратьЭлементы();
       Пока Спр.ПолучитьЭлемент()=1 Цикл
           Если Спр.ЭтоГруппа()=1 Тогда
               Продолжить;
           КонецЕсли;    
           Если Спр.Производственное.Получить(ДатаКонца)=1 Тогда
               Сп1.ДобавитьЗначение(Спр.ТекущийЭлемент());
           Иначе
               Сп2.ДобавитьЗначение(Спр.ТекущийЭлемент());
           КонецЕсли;               
           Если Спр.ИсточникОС = Перечисление.ПриобретениеОС.СобственныеСредства Тогда
               Сп3.ДобавитьЗначение(Спр.ТекущийЭлемент());
           ИначеЕсли Спр.ИсточникОС = Перечисление.ПриобретениеОС.Кредиты Тогда
               Сп4.ДобавитьЗначение(Спр.ТекущийЭлемент());
           Иначе
               Сп5.ДобавитьЗначение(Спр.ТекущийЭлемент());
        КонецЕсли;
       КонецЦикла;    

    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Сп1, 2);
    Ит.ВыполнитьЗапрос(ДатаНачала, ДатаКонца, "01"); 
    П17101 = Ит.СНД();    П17102 = Ит.ДО();    П17103 = Ит.КО();    П17104 = Ит.СКД();
    Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Сп1, 2);
    Ит.ВыполнитьЗапрос(ДатаНачала, ДатаКонца, "02"); 
    П17105 = Ит.СНК();    П17106 = Ит.КО();    П17107 = Ит.ДО();    П17108 = Ит.СКК();

    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Сп2, 2);
    Ит.ВыполнитьЗапрос(ДатаНачала, ДатаКонца, "01"); 
    П17201 = Ит.СНД();    П17202 = Ит.ДО();    П17203 = Ит.КО();    П17204 = Ит.СКД();
    Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Сп2, 2);
    Ит.ВыполнитьЗапрос(ДатаНачала, ДатаКонца, "02"); 
    П17205 = Ит.СНК();    П17206 = Ит.КО();    П17207 = Ит.ДО();    П17208 = Ит.СКК();

    Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Сп3, 2);
    Ит.ВыполнитьЗапрос(ДатаНачала, ДатаКонца, "01"); 
    П18101 = Ит.СНД();    П18102 = Ит.ДО();    П18103 = Ит.КО();    П18104 = Ит.СКД();
    
    Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Сп4, 2);
    Ит.ВыполнитьЗапрос(ДатаНачала, ДатаКонца, "01"); 
    П18201 = Ит.СНД();    П18202 = Ит.ДО();    П18203 = Ит.КО();    П18204 = Ит.СКД();

    Ит.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства, Сп5, 2);
    Ит.ВыполнитьЗапрос(ДатаНачала, ДатаКонца, "01"); 
    П18301 = Ит.СНД();    П18302 = Ит.ДО();    П18303 = Ит.КО();    П18304 = Ит.СКД();

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Титул");   
    Таблица.Опции(0,0,0,0);            
    Таблица.ПараметрыСтраницы(2,,,,,,,,,1);
    Таб.ПараметрыСтраницы(1,,,,,,,,,1);
    Таб.Опции(0,0,0,0);            
    Таб.ТолькоПросмотр(1);
    Таб.Вывести();
    Таб.Показать("Титульный лист");
КонецПроцедуры
   cw014
 
7 - 30.01.18 - 09:38
Чет не верится, что это отчет по движениям ос
   aktmx
 
8 - 30.01.18 - 12:13
с этого отчета скопировал код, внешний отчет называется- MOVEOC.ERT

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует