Вход | Регистрация


1С:Предприятие ::

Метки: 

Автозаполнение реквизита ВПФ

Я
   AntonNoProfessional
 
26.01.18 - 14:15
Проблема с автозаполнением реквизита СсылкаНаОбъект ВПФ. Необходимо, чтобы при открытии формы внешней обработки этот реквизит был уже заполнен. Но ВладелецФормы = Неопределено. С какого края подступиться к решению? Помогите, если кто сталкивался. Спасибо.
 
 
   Tatitutu
 
1 - 26.01.18 - 14:26
Не важно название Планеты, ты хоть название Галактики намекни (с)
   Darych
 
2 - 26.01.18 - 14:27
ты кто?
   AntonNoProfessional
 
3 - 26.01.18 - 14:29
(1) Хмм...
   AntonNoProfessional
 
4 - 26.01.18 - 14:30
(2) В пальто
   Darych
 
5 - 26.01.18 - 14:32
(4) в пальто был я... а ты в манто
   AntonNoProfessional
 
6 - 26.01.18 - 14:34
(5) Вам по существу вопроса нечего сказать?
   Darych
 
7 - 26.01.18 - 14:34
код, конфа, версия бсп.. и т п (см 1)
   Гипервизор
 
8 - 26.01.18 - 14:37
Раз, два... Меркурий во втором доме... луна ушла... шесть – несчастье... вечер – семь... (с)
   AntonNoProfessional
 
9 - 26.01.18 - 14:40
(7) БП 3.0 Какой код? Как можно при открытии Формы внешней обработки ВПФ автоматически заполнить реквизит этой формы "СсылкаНаОбъект" (с типом документ.поступлениетоваровуслуг)?
   Darych
 
10 - 26.01.18 - 14:44
(9) бредишь? какая форма открывается у ВПФ?
 
 Рекламное место пустует
   AntonNoProfessional
 
11 - 26.01.18 - 14:46
(10) Во внешней обработке форма.
   AntonNoProfessional
 
12 - 26.01.18 - 14:47
(10) НоваяКоманда.Использование        = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
   Darych
 
13 - 26.01.18 - 14:50
(12) ты что-то совсем не то делаешь... что нужно?
   AntonNoProfessional
 
14 - 26.01.18 - 14:54
(13) Чтобы пользователь в форме обработки не выбирал вручную конкретный документ из списка(а сейчас в этом реквизите список всех документов "ПоступлениеТоваровУслуг"), а программно заполнялся реквизит "СсылкаНаОбъект" той ссылкой на документ из которого нажата кнопка "печать"
   Darych
 
15 - 26.01.18 - 14:56
(14) передавай в параметре
   AntonNoProfessional
 
16 - 26.01.18 - 14:56
(15) В каком?
   Tatitutu
 
17 - 26.01.18 - 15:02
ВПФ - это Внешняя Печатная Форма ?
вызывается из меню печать документа

вот и подсунь туда ссылку свою - в чем проблема ?
   ximik33rus
 
18 - 26.01.18 - 15:04
(14) понимаешь в чем дело... в ВПФ не должно быть формы, что бы СсылкуНаОбъект автоматом определить.

А если уж ты сделал форму и на ней такой реквизит СсылкуНаОбъект, то либо найди по коду конкретный документ и присвой к нему, либо ручками..
   AntonNoProfessional
 
19 - 26.01.18 - 15:05
(17) Проблема втом, что не могу выдернуть ссылку. Откуда ее подсунуть?
   AntonNoProfessional
 
20 - 26.01.18 - 15:05
(18) То есть автоматически не получится?
   ximik33rus
 
21 - 26.01.18 - 15:06
А вообще вот.
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "АктПриемПерадачаОборудования", "АКТ ПРИЕМА-ПЕРЕДАЧИ ОБОРУДОВАНИЯ", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));

КонецПроцедуры// Печать()


Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_АктПриемПерадачаОборудования";

МакетОбработки = ПолучитьМакет("Макет");

//заполняем шапку

ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
и так далее....


ну и все положенные потроха по сведеньям о внешней обработки и т.п....
   AntonNoProfessional
 
22 - 26.01.18 - 15:09
(21) Буду разбираться...
   ximik33rus
 
23 - 26.01.18 - 15:10
(20) Смотри какая штука. Что бы все было автоматом, ВПФ не должна иметь формы и реквизита СсылкаНаОбъект. Все функции описываются в модуле объекта, а СсылкаНаОбъект - это параметр в который помещается первый элемент массива объектов - тоесть тот самый документ из под которого запускается печать формы.
   ximik33rus
 
24 - 26.01.18 - 15:11
(22) Вот тебе в помощь, достаточно подробно. https://helpf.pro/faq83/view/1726.html
   ximik33rus
 
25 - 26.01.18 - 15:12
Вернее, лучше вот это: http://programmist1s.ru/vneshnie-pechatnyie-formyi-v-1s/
   AntonNoProfessional
 
26 - 26.01.18 - 15:12
(24) Спасибо. Буду извращаться дальше. Без формы обработки, походу, никак(
   ximik33rus
 
27 - 26.01.18 - 15:13
(26) А зачем тебе форма? Только что бы выбрать документ?
   Darych
 
28 - 26.01.18 - 15:13
ниче не понимаю... (цы)
   AntonNoProfessional
 
29 - 26.01.18 - 15:15
(27) Заполняюся в ней дополнительные реквизиты
   Tatitutu
 
30 - 26.01.18 - 15:16
(29) она как правило нужна для отладки
   Darych
 
31 - 26.01.18 - 15:17
(29) ну так сделай отдельную команду.. не используй впф
   hhhh
 
32 - 26.01.18 - 15:20
(29) как обычно на форме это делается. У формы ставишь галочку "сохранять значения" и "использовать список для сохранения". Находишь реквизит "СсылкаНаОбъект" напротив него ставишь галочку в колонке"Сохранять". всё.
   AntonNoProfessional
 
33 - 26.01.18 - 15:21
(31) Есть ВПФ ТТН по РТУ. Задача: переделать ее под ТТН по ПТУ(т.е. за поставщика, реквизиты заполняются зеркально). Плюс в ПТУ нет тех реквизитов, что есть в РТУ. В форме обработки я их добавил.
 
 
   ximik33rus
 
34 - 26.01.18 - 15:23
(29) поправь меня, если ошибусь.
Тебе нужно в документе по кнопке "Печать" запустить обработку, при запуске у нее открывается Форма, в которой заполняются еще какие то реквизиты, и должно автоматом заполнится ссылка на объект того документа из которого эта обработка вызывалась и уже когда все заполнено отправлять на печать?
   AntonNoProfessional
 
35 - 26.01.18 - 15:24
(34) Точно так
   Darych
 
36 - 26.01.18 - 15:26
автор путает впф и обработку печати
   AntonNoProfessional
 
37 - 26.01.18 - 15:28
(32) При таком сохранении заполняется предыдущим значением. И есть возможность у пользователя выбирать из списка документов
   Tatitutu
 
38 - 26.01.18 - 15:31
(37) скачай и посмотрю любую другую ВПФ готовую
и не придумывай велосипед

в обработку макет
Параметры_Авторегистрации
там прописать твой документ

в модуль обработки


Функция Печать() Экспорт      
    ТабДокумент = ПечатьДокумента();
    Возврат ТабДокумент;      
КонецФункции// Печать
   AntonNoProfessional
 
39 - 26.01.18 - 15:33
Всем спасибо большое. Если найду решение - отпишусь.
   AntonNoProfessional
 
40 - 05.02.18 - 14:01
Решение:
В модуле формы внешней обработки:

&НаСервере
Процедура УстановитьСсылкуНаОбъектНаСервере(Ссылка)
    Объект.СсылкаНаОбъект = Ссылка;
КонецПроцедуры    

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    Если (ЭтаФорма.ВладелецФормы <> Неопределено) И (ЭтаФорма.ВладелецФормы.Параметры.Свойство("Ключ")) Тогда
        УстановитьСсылкуНаОбъектНаСервере(ЭтаФорма.ВладелецФормы.Параметры.Ключ);
        ОбновитьСписокПечатныхФормОбъекта();
    КонецЕсли;    
    
КонецПроцедуры



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует