Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как сохранить значения табличной части на уф?

Как сохранить значения табличной части на уф?
Я
   МаленькийВопросик
 
26.01.18 - 12:12
Товарищи, как сохранить значения на уф в настройках?
 
 
   Darych
 
1 - 26.01.18 - 12:24
   МаленькийВопросик
 
2 - 26.01.18 - 13:26
&НаСервере
Процедура СохранитьНастройки()

КлючНастроек = "ОтчетВасиПупкина";
Настройки = Новый Соответствие;

Настройки.Вставить("ТЧКоторуюХотетьСохранить", Отчет.ТЧКоторуюХотетьСохранить.Выгрузить());

ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ОтчетВасиПупкина", КлючНастроек, Настройки);

КонецПроцедуры

&НаСервере
Процедура ВосстановитьНастройки()

КлючНастроек = "ОтчетВасиПупкина";
ЗначениеНастроек = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ОтчетВасиПупкина", КлючНастроек);
Если ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда
Отчет.ТЧКоторуюХотетьСохранить.Загрузить(ЗначениеНастроек.Получить("ТЧКоторуюХотетьСохранить"));
КонецЕсли;

КонецПроцедуры
   МаленькийВопросик
 
3 - 26.01.18 - 13:27
а куда привязать настройки?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует