Вход | Регистрация

1С:Предприятие ::

Метки: 

Не пропечатывается должность ответственного в УПД БП 2.0

Я
   ratnador
 
26.01.18 - 05:56
Самая новая на текущий момент версия БП 2.0.66.46

Если раньше в общих макетах - УниверсальныйПередаточныйДокумент - ПодвалНакладной строка 63 столбец 2 (Ответственный за правильность оформления факта хозяйственной жизни) не было никаких ссылок чтобы должность заполнялась автоматически, то в этой версии появился новый
УниверсальныйПередаточныйДокумент981, в котором в этом месте прописана ссылка <ДолжностьОтветственного>.  Так вот я ни как не могу найти откуда берется это значение. При этом рядом ФИООтветственного - прописывается
Если это же лицо выбрано в качестве кладовщика - ДолжностьКладовщика отображается верно!

Где мне нужно прописать <ДолжностьОтветственного> чтобы она автоматически прописывалась в печатной форме?
 
  Рекламное место пустует
   ratnador
 
1 - 26.01.18 - 11:55
В поисках решения попробовал применить вот это решение,
http://catalog.mista.ru/public/664451/

Однако при формировании УПД выдает

{ОбщийМодуль.ОбщегоНазначения.Модуль(7585)}: Поле объекта не обнаружено (УПД)
            ИначеЕсли Руководители.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.УПД Тогда

вот полностью функция

Функция ОтветственныеЛица(Организация, ДатаСреза, Подразделение = Неопределено) Экспорт
    
    СобиратьПоОрганизации = Истина;
    Результат = Новый Структура("Руководитель, РуководительДолжность, РуководительФИО, РуководительПредставление, 
                                |ГлавныйБухгалтер, ГлавныйБухгалтерДолжность, ГлавныйБухгалтерФИО, ГлавныйБухгалтерПредставление, 
                                |Кассир, КассирДолжность, КассирФИО, КассирПредставление, 
                                |УПД, УПДДолжность, УПДФИО, УПДПредставление,
                                |ОтветственныйЗаРегистры, ОтветственныйЗаРегистрыДолжность, ОтветственныйЗаРегистрыФИО, ОтветственныйЗаРегистрыПредставление");

    Если Организация <> Неопределено тогда

        ЗапросПоЛицам = Новый Запрос();
        ЗапросПоЛицам.УстановитьПараметр("ДатаСреза",   ДатаСреза);
        ЗапросПоЛицам.УстановитьПараметр("Организация", Организация);
        ЗапросПоЛицам.УстановитьПараметр("ПризнакФизЛица",   Перечисления.ЮрФизЛицо.ФизЛицо);
        
        ЗапросПоЛицам.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
                              |    ФИОФизЛицСрезПоследних.Фамилия,
                              |    ФИОФизЛицСрезПоследних.Имя,
                              |    ФИОФизЛицСрезПоследних.Отчество,
                              |    ФИОФизЛицСрезПоследних.ФизЛицо КАК ФизическоеЛицо
                              |ИЗ
                              |    РегистрСведений.ФИОФизЛиц.СрезПоследних(&ДатаСреза, ) КАК ФИОФизЛицСрезПоследних
                              |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Организации КАК Организации
                              |        ПО ФИОФизЛицСрезПоследних.ФизЛицо = Организации.ИндивидуальныйПредприниматель
                              |            И (Организации.Ссылка = &Организация)
                              |            И (Организации.ЮрФизЛицо = &ПризнакФизЛица)";
        
        Руководители = ЗапросПоЛицам.Выполнить().Выбрать();
        
        Пока Руководители.Следующий() Цикл
            
            ФИО = Новый Структура("Фамилия, Имя, Отчество, Представление");
            Если НЕ (НЕ ЗначениеЗаполнено(Руководители.Фамилия) или Руководители.Фамилия = NULL) Тогда
                ФИО.Фамилия = Руководители.Фамилия;
            КонецЕсли;
            Если НЕ (НЕ ЗначениеЗаполнено(Руководители.Имя) или Руководители.Имя = NULL) Тогда
                ФИО.Имя = Руководители.Имя;
            КонецЕсли;
            Если НЕ (НЕ ЗначениеЗаполнено(Руководители.Отчество) или Руководители.Отчество = NULL) Тогда
                ФИО.Отчество = Руководители.Отчество;
            КонецЕсли;
            Представление = ПолучитьФамилиюИмяОтчество(ФИО.Фамилия, ФИО.Имя, ФИО.Отчество);
            
            Результат.Руководитель               = Руководители.ФизическоеЛицо;
            Результат.РуководительДолжность      = "";
            Результат.РуководительФИО            = ФИО;
            Результат.РуководительПредставление  = Представление;
            
        КонецЦикла;
        
        Если СобиратьПоОрганизации Тогда
            
            ЗапросПоЛицам.Текст = 
            "ВЫБРАТЬ РАЗРЕШЕННЫЕ
            |    ОтветственныеЛицаОрганизацийСрезПоследних.ОтветственноеЛицо,
            |    ОтветственныеЛицаОрганизацийСрезПоследних.ФизическоеЛицо,
            |    ОтветственныеЛицаОрганизацийСрезПоследних.Должность,
            |    ФИОФизЛицСрезПоследних.Фамилия,
            |    ФИОФизЛицСрезПоследних.Имя,
            |    ФИОФизЛицСрезПоследних.Отчество
            |ИЗ
            |    РегистрСведений.ОтветственныеЛицаОрганизаций.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &Организация) КАК ОтветственныеЛицаОрганизацийСрезПоследних
            |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ФИОФизЛиц.СрезПоследних(&ДатаСреза, ФизЛицо ССЫЛКА Справочник.ФизическиеЛица) КАК ФИОФизЛицСрезПоследних
            |        ПО ОтветственныеЛицаОрганизацийСрезПоследних.ФизическоеЛицо = ФИОФизЛицСрезПоследних.ФизЛицо";
            Руководители = ЗапросПоЛицам.Выполнить().Выбрать();
        КонецЕсли;

        Пока Руководители.Следующий() Цикл

            ФИО = Новый Структура("Фамилия, Имя, Отчество, Представление");
            Если НЕ (НЕ ЗначениеЗаполнено(Руководители.Фамилия) или Руководители.Фамилия = NULL) Тогда
                ФИО.Фамилия = Руководители.Фамилия;
            КонецЕсли;
            Если НЕ (НЕ ЗначениеЗаполнено(Руководители.Имя) или Руководители.Имя = NULL) Тогда
                ФИО.Имя = Руководители.Имя;
            КонецЕсли;
            Если НЕ (НЕ ЗначениеЗаполнено(Руководители.Отчество) или Руководители.Отчество = NULL) Тогда
                ФИО.Отчество = Руководители.Отчество;
            КонецЕсли;
            Представление = ПолучитьФамилиюИмяОтчество(ФИО.Фамилия, ФИО.Имя, ФИО.Отчество);
            
            Если Руководители.ОтветственноеЛицо      = Перечисления.ОтветственныеЛицаОрганизаций.Руководитель Тогда
                Результат.Руководитель               = Руководители.ФизическоеЛицо;
                Результат.РуководительДолжность      = Руководители.Должность;
                Результат.РуководительФИО            = ФИО;
                Результат.РуководительПредставление  = Представление;

            ИначеЕсли Руководители.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.ГлавныйБухгалтер Тогда
                Результат.ГлавныйБухгалтер           = Руководители.ФизическоеЛицо;
                Результат.ГлавныйБухгалтерДолжность  = Руководители.Должность;
                Результат.ГлавныйБухгалтерФИО        = ФИО;
                Результат.ГлавныйБухгалтерПредставление  = Представление;
                
            ИначеЕсли Руководители.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.Кассир Тогда
                Результат.Кассир                     = Руководители.ФизическоеЛицо;
                Результат.КассирДолжность               = Руководители.Должность;
                Результат.КассирФИО                     = ФИО;
                Результат.КассирПредставление  = Представление;
                
            // Черенев Денис   {

            ИначеЕсли Руководители.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.УПД Тогда
                Результат.УПД                     = Руководители.ФизическоеЛицо;
                Результат.УПДДолжность               = Руководители.Должность;
                Результат.УПДФИО                     = ФИО;
                Результат.УПДПредставление  = Представление;
            //    Черенев Денис   }

            
            ИначеЕсли Руководители.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.ОтветственныйЗаНалоговыеРегистры Тогда
                Результат.ОтветственныйЗаРегистры    = Руководители.ФизическоеЛицо;
                Результат.ОтветственныйЗаРегистрыДолжность      = Руководители.Должность;
                Результат.ОтветственныйЗаРегистрыФИО = ФИО;
                Результат.ОтветственныйЗаРегистрыПредставление  = Представление;

            КонецЕсли;

        КонецЦикла;

    КонецЕсли;

    Возврат Результат;

КонецФункции


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует