Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Добавить строку. Добавляет строку с переносом.

v7: Добавить строку. Добавляет строку с переносом.
Я
   kostya_77
 
25.01.18 - 10:21
Добавляет строку с разделением на три строки. Хотя должно добавлять в одну строку.

Строка клиенты стрКлиенты = "15;Имя;Адрес"

    _текстКлиенты=СоздатьОбъект("Текст");

    _текстКлиенты.КодоваяСтраница(0); 
    
    _текстКлиенты.ДобавитьСтроку(_стрКлиенты); 
    
    Состояние("Идет запись 3");
    _текстКлиенты.Записать(мПутьВыгрузки+"clients.csv");
 
 
   kostya_77
 
1 - 25.01.18 - 10:22
В строке _стрКлиенты не одна запись. Все записывает нормально, кроме одной
   1Сергей
 
2 - 25.01.18 - 10:23
Что-то недоговариваешь
   1Сергей
 
3 - 25.01.18 - 10:24
(1) Что же в стрКлиенты?
   kostya_77
 
4 - 25.01.18 - 10:25
я же привет пример
   kostya_77
 
5 - 25.01.18 - 10:26
стрКлиенты = "15;Имя;Адрес"
   1Сергей
 
6 - 25.01.18 - 10:26
Для Идн = 1 по СтрЧислоСтрок(_стрКлиенты) Цикл
    _текстКлиенты.ДобавитьСтроку(СтрПолучитьСтроку(_стрКлиенты,Идн)); 
КонецЦикла;


под рукой семерки нет, пишу по памяти
   1Сергей
 
7 - 25.01.18 - 10:26
(5) и не добавляет?
   kostya_77
 
8 - 25.01.18 - 10:27
попробую
   АЛьФ
 
9 - 25.01.18 - 10:28
2(5) именно с таким значением переменной код из (0) дает три строки в файле?
   MWWRuza
 
10 - 25.01.18 - 10:55
Там в какой-то части строки "непечатаемый" символ перевода строки содержится. Где Вы берете "Имя", "Адрес" - ? Из какого-то справочника? Проверьте заполнение его полей на предмет "кривых" строк, с символом перевода строки внутри. Или просто удалите и перепишите вручную заново. Я когда-то писал обработку, которая в справочнике "Номенклатура" "Наименование" проверяла и исправляла. Не грузился товар в АРМ кассира из-за нарушения структуры файла выгрузки, строчка рвалась посередине и переносилась на новую. Но, сейчас не найду - делал у кого-то из клиентов и давно...
 
 Рекламное место пустует
   MWWRuza
 
11 - 25.01.18 - 11:15
Той универсальной обработки не нашел, но, вот нечто похожее:

Процедура Сформировать()
    Спр = СоздатьОбъект("Справочник.Единицы");
    Спр.ВыбратьЭлементы(0);
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
        ДопустСимволы = "0123456789 qwertyuiopasdfghjklzxcvbnmQWERTYUIOPASDFGHJKLZXCVBNM";
        Сч = 0;
        Штрихкод = Спр.Штрихкод;
        Для Сч = 1 По 13 Цикл
            ИскСимв = Сред(Штрихкод,Сч,1);
            Если Найти(ДопустСимволы,ИскСимв) = 0 Тогда
                Сообщить("Недопустимый символ """ + " " + ИскСимв +  " " + """ в штрихкоде у товара: " + Спр.Владелец);    
            КонецЕсли;
        КонецЦикла;    
    КонецЦикла;
КонецПроцедуры


Проверяет ШтрихКод в справочнике, и выводит в каком ошибка.
Вам надо нечто подобное для своих справочников сделать.
   MWWRuza
 
12 - 25.01.18 - 11:18
Вот эту строку из цикла вынесите, перед циклом поставьте:
ДопустСимволы = "0123456789 qwertyuiopasdfghjklzxcvbnmQWERTYUIOPASDFGHJKLZXCVBNM";

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует