Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Несоответствие типов (параметр номер '1')

Несоответствие типов (параметр номер '1')
Я
   Nst
 
24.01.18 - 15:44
здравствуйте!в отчете пишу:

&НаСервере
Процедура СформироватьНаСервере()
    
    Настройки = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
        
        Для Каждого ПараметрДанных Из Настройки.ПараметрыДанных.Элементы Цикл 
                
                Если ПараметрДанных.Параметр = Новый ПараметрКомпоновкиДанных("КонецПериода") Тогда 
                        
                        ПараметрДанных.Использование = Истина;
                        ПараметрДанных.Значение = КонецМесяца(Отчет.Период);
                        
                КонецЕсли;
                
                Если ПараметрДанных.Параметр = Новый ПараметрКомпоновкиДанных("НачалоПериода") Тогда 
                        
                        ПараметрДанных.Использование = Истина;
                        ПараметрДанных.Значение = НачалоМесяца(Отчет.Период);
                        
                КонецЕсли;
                
                Если ПараметрДанных.Параметр = Новый ПараметрКомпоновкиДанных("Оклад") Тогда 
                        
                        ПараметрДанных.Использование = Истина;
                        ПараметрДанных.Значение = Константы.Начисление_Оклад.Получить();
                        
                КонецЕсли;
                
                Если ПараметрДанных.Параметр = Новый ПараметрКомпоновкиДанных("Организация") Тогда 
                        
                        ПараметрДанных.Использование = Истина;
                        ПараметрДанных.Значение = Отчет.Организация;
                        
                КонецЕсли;
                
                Если ПараметрДанных.Параметр = Новый ПараметрКомпоновкиДанных("ГрупповыеЗанятия") Тогда 
                        
                        ПараметрДанных.Использование = Истина;
                        ПараметрДанных.Значение = Константы.Начисление_ГрупповыеЗанятия.Получить();
                        
                КонецЕсли;
                
                Если ПараметрДанных.Параметр = Новый ПараметрКомпоновкиДанных("ИндивидуальныеЗанятия") Тогда 
                        
                        ПараметрДанных.Использование = Истина;
                        ПараметрДанных.Значение = Константы.Начисление_ИндивидуальныеЗанятия.Получить();
                        
                КонецЕсли;              
                
        КонецЦикла;
        
        Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
        
          СкомпоноватьРезультат(Отчет);
     КонецПроцедуры



выходит ошибка Несоответствие типов (параметр номер '1')
что я делаю не так? спасибо!
 
 
   Волшебник
 
Модератор
1 - 24.01.18 - 15:46
Передайте параметр правильного типа
   cw014
 
2 - 24.01.18 - 15:48
(0) В какой строке то хоть?
Отчет.Период - какой тип имеет?
   Гипервизор
 
3 - 24.01.18 - 15:49
Скорее всего у вас в параметрах НачалоПериода и КонецПериода тип не Дата, а СтандартнаяДатаНачала, потому и валится на ПараметрДанных.Значение = КонецМесяца(Отчет.Период).
   cw014
 
4 - 24.01.18 - 15:50
(3) Или СтандартныйПериод
   Nst
 
5 - 24.01.18 - 15:55
(2)ругается на  СкомпоноватьРезультат(ЭтотОбъект);
   drcrasher
 
6 - 24.01.18 - 15:57
(5) без параметра запускай. и настройки заполняй в модуле отчета, а не формы
   cw014
 
7 - 24.01.18 - 15:58
(5) Видимо потому что (цитата из СП):
Параметры:
<РежимКомпоновки> (Необязательный)
Тип: РежимКомпоновкиРезультата
   Nst
 
8 - 24.01.18 - 16:00
(7) тогда ругается просто на "скомпоновать результат"
   cw014
 
9 - 24.01.18 - 16:00
(8) А ругается то что?
   Nst
 
10 - 24.01.18 - 16:03
(9) "Невозможно осуществить вывод результата"
 
 Рекламное место пустует
   cw014
 
11 - 24.01.18 - 16:03
(10) "По причине..." ?
   cw014
 
12 - 24.01.18 - 16:03
(10) Параметры точно все заполнены?
   cw014
 
13 - 24.01.18 - 16:04
(10) Ошибок в схеме нету? СКД формируется по запросу или из объекта?
   Nst
 
14 - 24.01.18 - 16:09
(11) нет причины.просто Невозможно осуществить вывод результата
(12) параметры заполнены
ошибок нет. скд по запросу.
   cw014
 
15 - 24.01.18 - 16:12
В гугле первая строчка. Авось поможет
https://forum.infostart.ru/forum9/topic107888/
Последний коммент
   Nst
 
16 - 24.01.18 - 16:13
(15) читала.делала. спасибо!
   cw014
 
17 - 24.01.18 - 16:14
Да незачто. Всегда рад погуглить за других

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует