Вход | Регистрация

1С:Предприятие ::

Метки: 

Оповещение пользователя

Я
   fedotov_andrey
 
23.01.18 - 21:56
Хочу вывести пользователю сообщение при проведении и записи документа.

Вот таким кодом вывожу сообщение при сохранении документа без закрытия формы, как только форму закрываем, то сообщение пропадает. Соответственно если провести и закрыть, то сообщение практически моментально пропадает.

Функция СоздатьОповещение()
    
Сообщить("Тут текст оповещения");

КонецФункции


Функция ВыполнитьДействие() Экспорт
    Возврат СоздатьОповещение();
КонецФункции
 
  Рекламное место пустует
   jsmith82
 
1 - 23.01.18 - 21:57
Это не оповещение
   jsmith82
 
2 - 23.01.18 - 21:58
Гугли ПоказатьОповещениеПользователя
   fedotov_andrey
 
3 - 23.01.18 - 22:17
не соображу, пишу так и не получаю оповещение. Почему?

&НаКлиенте
Процедура ПриОткрытии() Экспорт
ПоказатьОповещениеПользователя("Внимание!",ПолучитьНавигационнуюСсылку(ЭтаФорма),"У клиента есть скидка");
КонецПроцедуры
   fedotov_andrey
 
4 - 23.01.18 - 23:14
подскажите пожалуйста как вывести
   AlexMee
 
5 - 23.01.18 - 23:15
создай подписку на событие.
   Franchiser
 
6 - 23.01.18 - 23:23
Навигационная ссылка может быть на объект БД, но не на форму
   jsmith82
 
7 - 23.01.18 - 23:40
Навигейшен линк это линк на объект базы - нажав на неё, можно открыть этот объект.
В данном случае у тебя линк это Объект.Ссылка
Но объект (документ) у тебя и так уже открыт
Так что этот параметр заполнять не обязательно
Можешь просто написать ПоказатьОповещениеПользователя("Внимание! У клиента есть скидка");


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует