Вход | Регистрация


Отложить выполнение процедуры

Отложить выполнение процедуры
Я
   nAPACEHAK
 
23.01.18 - 12:05
Добра всем

Подскажите, можно ли реализовать? Или не стоит заморачиваться?

Внешняя обработка. Запускается из планировщика виндового (типа запуск 1С с аргументами). Обработка запускается, выполняется, закрывается.

Хотят на форму галку Автовыполнение. Смысл - открывается морда обработки. Если за таймаут пользователь галку не снял - то всё как было. Если снял - то обработка не выполняется и пользователь может провести какие то допнастройки

Пока на ум только пришло еще какой нить файлик ini кинуть к обработке с настройками этой галки, что бы прочитать приоткрытии.
 
 
   drcrasher
 
1 - 23.01.18 - 12:08
значениеВФайл() + значениеИзФайла()
   drcrasher
 
2 - 23.01.18 - 12:09
но в чем глубокий смысл, если морда открылась, галка стоит, таймер ждёт. какую настройку хранить?
   Вафель
 
3 - 23.01.18 - 12:13
в 1с есть хранилище настроек
   Вафель
 
4 - 23.01.18 - 12:14
может проще отдельно открывать для настройки?
   azernot
 
5 - 23.01.18 - 12:14
Вопрос "Хотите изменить настройки"?
с таймером.
   nAPACEHAK
 
6 - 23.01.18 - 12:18
(4) ну примерно такой смысл
Если стоит галка - то пусть выполняется по расписанию с планировщика (напр. Обмен, настроили запуск ночью и пофиг)

Днем пользователь запустил эту обработку и пока не вышел таймаут может снять галку, потом может кнопки понажимать посмотреть на морде что там выгружается, в каком виде итд. обмен не происходит.
Пользователь снова галку поставил - сработал обмен
ну итд
   nAPACEHAK
 
7 - 23.01.18 - 12:21
1. Открылась морда обработки
2. пошло время
3.1 пользователь ничего не сделал - выполняем обмен
3.2 пользователь галку снял - обмена нет. 
3.2.1 пользователь вернул галку - см п.2
   drcrasher
 
8 - 23.01.18 - 12:21
(6) а не лучше для этого фоновое + справочник настроек?
   Вафель
 
9 - 23.01.18 - 12:21
Если это типовая доп обработка, то делается 2 команды: одна серверная для авто работы, и одна на открытие формы для настроек
   nAPACEHAK
 
10 - 23.01.18 - 12:23
(9) нет. самопальная. и хотят только обработку и все. что бы планировщиком прицепить к базе и она работала. базы разные. структура баз одинакова
 
 Рекламное место пустует
   Ц_У
 
11 - 23.01.18 - 12:24
(7)
1. открыть форму
2. подключить обработчик ожидания
3. время ожидания прошло - делать
4. галку потрогали - отключить обработчик ожидания
5. галку потрогали - подключить ОбОж
   azernot
 
12 - 23.01.18 - 12:25
Процедура ПриИзмененииГалки()
Если Галка = Истина ТОгда
ОбработчикВыполнения()
КонецЕсли;
КонецПроцедцры


Процедура ОбработчикВыполнения()
Пока Истина = Истина Цикл
Если Вопрос("Хотите снять галку выполнения?", РежимДиалогаВопрос.ДаНет, 120) = КодВозвратаДиалога.Да Тогда 
    Галка = Ложь;
    Прервать;
КонецЕсли;
    
СтартоватьМегаОбработкуОбмен();

КонецЦикла
КонецПроцедцры
   nAPACEHAK
 
13 - 23.01.18 - 12:39
(11) спс. получилось
(12) кстати да. тоже вариант

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует