Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Аналог WHERE, выборка по условию

Аналог WHERE, выборка по условию
Я
   Личунхо
 
23.01.18 - 07:12
Здравствуйте!
1С:Предприятие 8.3 (8.3.4.437)
Есть рабочий запрос:
**************
Процедура ВыбратьЛипкинНаСервере()
   Запрос = Новый Запрос;
       Запрос.Текст = ("ВЫБРАТЬ Наименование, Имя ИЗ Справочник.ФИО ");
       РезультатЗапроса = Запрос.Выполнить();
   ITOGO = РезультатЗапроса.Выбрать();
        Пока ITOGO.Следующий() Цикл
          Сообщить(ITOGO.Наименование+" "+
      ITOGO.Имя
      );
   КонецЦикла;
КонецПроцедуры
**************
Результат - содержание справочника, поля "Наименование" и "Имя"
Теперь нужно выбрать конкретную запись, например, где наименование "ЛИПКИН"
Дописал:

***********
Процедура ВыбратьЛипкинНаСервере()
   Запрос = Новый Запрос;
       Запрос.Текст = ("ВЫБРАТЬ Наименование, Имя ИЗ Справочник.ФИО ГДЕ Наименование = ЛИПКИН ");
   РезультатЗапроса = Запрос.Выполнить();
   ITOGO = РезультатЗапроса.Выбрать();
        Пока ITOGO.Следующий() Цикл
          Сообщить(ITOGO.Наименование+" "+
      ITOGO.Имя
      );
КонецЦикла;
КонецПроцедуры
***********

Не работает.
Сообщение:
***********
Поле не найдено "ЛИПКИН"
***********

Что не так?

Где почитать КОМПЕТЕНТНУЮ информацию по языку запросов?
 
 
   icipher
 
1 - 23.01.18 - 07:16
Запрос.Текст = ("ВЫБРАТЬ Наименование, Имя ИЗ Справочник.ФИО ГДЕ Наименование = ""ЛИПКИН""");
   Mankubus
 
2 - 23.01.18 - 07:17
   Личунхо
 
3 - 23.01.18 - 07:58
О! Спасибо  icipher !!!
Такая же ерунда, как в Delphi ))) 

Тогда ещё один вопрос, ....
Для чтения из внешнего DBF файла применяется конструкция:
*************
ФайлDBF = Новый XBase;// создаем новый объект 

    ФайлDBF.Кодировка = КодировкаXBase.OEM;
    ФайлDBF.ОткрытьФайл("C:\LPU\fio_209.dbf",,Истина)// открытие файла

    KZ =ФайлDBF.КоличествоЗаписей(); 
    Сообщить("В таблице " + KZ + " записей.");
    ФайлDBF.Первая();// устанавливает курсор на первую запись 

*************

А можно сделать выборку из ВНЕШНЕГО dbf так же, с помощью выборки типа ВЫБРАТЬ.... ГДЕ... ?
   lodger
 
4 - 23.01.18 - 08:18
(3) через XBase только построчный обход или с применением поиска НайтиПоКлючу.
   Личунхо
 
5 - 23.01.18 - 08:21
Ну а ключ это уже какое-то поле в таблице или его ещё формировать нужно?

А пример можно, или ссылку?
   Личунхо
 
6 - 23.01.18 - 08:41
   icipher
 
7 - 23.01.18 - 13:11
можно прочитать всё из базы в таблицу значений, а дальше крутить как хочешь.
   Михаил Козлов
 
8 - 23.01.18 - 13:33
(7)+ Чтение из DBF происходит быстро.
   SanGvin
 
9 - 23.01.18 - 13:36
через ADODB вроде можно

Пример работы с dbf через ADODB

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует