Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Error #: -210 и Windows 10

v7: Error #: -210 и Windows 10
Я
   Max_Prog
 
22.01.18 - 18:42
Доброго время суток!
Есть сеть магазинов разливного пива с одинаковой конфигурацией. 1С 7.7 (27 релиз) и ТиС 9.2 (доработанная) на борту . 7 магазинов под ОС Win10, остальные под Win7 (есть 1 под ХР). На 5 магазинах под Win10 выходит ошибка:
Error #: -210
Unrecognized field name
SP4062 или SP4475
Тестирование и исправление ИБ делал все Ок.
Ошибка выходит не всегда. Может при продаже (обращение к DrvFR.dll), может при обмене (обращение к ROM-Mail.dll), может еще где. Ошибка выходит до 10 раз за день. При этом жмут Ок и все вроде нормально.
В 1Cv7.DD все нашел, нашел .dbf и открыл, колонки SP4062 и SP4475 ЕСТЬ, все с одинаковыми значениями. Обновления Win10 (я отключаю чтобы с 3G свистка трафик не выходил) я сделал! Проблема не решилась.
Остальные компы работают без ошибок.
Подскажите куда копать? С прошлого года мучаюсь. Заранее благодарен.
 
 
   MWWRuza
 
1 - 22.01.18 - 19:53
Бесполезно... 10-тка, для 7.7 - зло... Не там, так в другом месте вылезет...
Попробуйте полные права, админский доступ дать. Можно поиграть с режимом совместимости. Но, как показывает практика, помогает мало. Все должно быть примерно одного времени. Когда 7.7 писали, 10-тки еще и в проекте не было... 100% помогает только даунгрейд на win7...
   Сияющий в темноте
 
2 - 22.01.18 - 20:37
Однобайтовые строки в Windows 10 не очень хорошо поддерживаются
поставить 1251 кодировку пр умолчанию и язык русский,должно немного помочь
можно попробовать поставить виртуальную машину для 32 системы,возможно чем-то спасет
   Max_Prog
 
3 - 22.01.18 - 20:55
(1) Админа для продавцов пива дать не могу, им инет отрубить не могу (Для ЕГАИС Контур нужен и т.д.)
Была проблема, на 2 компах, входа в проводник, решилась январским обновлением.
(2) Раньше ОС Win7 была. Начал с переиндексации на Русский Белорусский затем на + Текущая системная. Проблема осталась. Тестирование и исправление ИБ делал все Ок.
   Max_Prog
 
4 - 22.01.18 - 21:05
(1) На двух компах на Win10 работает без ошибок. Все перепробывал
   Max_Prog
 
5 - 22.01.18 - 21:16
(1) А вот с совместимостью еще не пробовал, буду пытать. Напишу как да что.
   mingw
 
6 - 22.01.18 - 23:27
1. ТиИ
2. Под Win10 ТиИ не пашет.
   Max_Prog
 
7 - 24.01.18 - 10:35
Большое спасибо! Ошибок больше нет!
В свойствах 1cv7l.exe совместимость с win7. Тема закрыта. (6) Все работает и пашет.
   Max_Prog
 
8 - 26.01.18 - 19:37
Тема НЕ закрыта! Error #: -210 осталась. Совместимость с ХР пак 3, тоже болт!
Попробовал Выгрузить данные..., загрузить в новую (пустую базу) на фокус компе под ХР, далее сделал ТиИ (все Ок).
Сделал Сохранить данные... со штатными масками *.DBF и т.д.
Убил в базе на Win10 все, кроме папок и *.dll.
Далее Восстановить данные... в базе под Win10, прописал ФР и т.д. Жду ошибки...
Ошибку вечером выбрасывает, редко, при продаже - обращение к DrvFR.dll (может зря на dll-ку грешу).
Пробую, как получится напишу. Если есть еще у кого мысли по этому поводу, Подскажите.
   Смотрящий
 
9 - 26.01.18 - 19:45
   Max_Prog
 
10 - 26.01.18 - 19:48
(9) Поле есть, значения все есть (0) Писал.
 
 Рекламное место пустует
   Max_Prog
 
11 - 26.01.18 - 20:28
(9) В этом и суть. Поля есть, значения есть! И Ошибка тоже есть!!!!!!!
   Max_Prog
 
12 - 29.01.18 - 03:30
(0) Ошибка 210 (Error #: -210) РЕШЕНА !!! Я думаю так много проблем и ошибок можно решить…
   Max_Prog
 
13 - 29.01.18 - 03:31
В БАЗЕ Выгрузил данные... => В базе (DB) удалил все *.DBF, *.CDX, 1CV7.DD, 1CV7.MD, 1CV7.ORD
   Max_Prog
 
14 - 29.01.18 - 03:32
Создал новую, пустую базу (фокус комп на ХР был) => В ней Загрузить данные... => Сохранить данные…*
   Max_Prog
 
15 - 29.01.18 - 03:33
Далее в старой БАЗЕ заходим в конфигуратор => кодовая страница 1251 – Русский, белорусский
Восстановить данные…* => меняем Кодовая страница + Текущая системная => Наслаждаемся !
   Max_Prog
 
16 - 29.01.18 - 03:35
Думаю не в Win10 дело! А базу по лоховски переносили. Не знаю что конкретно помогло, но думаю много вопросов так решить можно.
   Max_Prog
 
17 - 29.01.18 - 03:42
По поводу ТиИ я не знаю для чего это нужно? Создал мне какие то левые документы (при этом пугал…). Они не проведены… Я их удалил, они удалились!? В инете тоже не чего толком про ТиИ не пишут как и что это чудо правит…
   h-sp
 
18 - 29.01.18 - 03:42
(16) блажен, кто  верует. Через неделю ждем очередного крика или плача.
   Max_Prog
 
19 - 29.01.18 - 03:44
Все последовательностью делается. Ну если на программил , проведение проведенных документов.
   Max_Prog
 
20 - 29.01.18 - 03:54
(18) Win10 не моя прихоть. Меня бухгалтер в такую позу поставил. Для ЕГАИС Контур нужен, мля им так удобнее. А мне танцы с бубнами.
   Владимир1С
 
21 - 29.01.18 - 15:17
(20) Пробовал Контур без 10-и запустить? Может прокатит?
   MWWRuza
 
22 - 29.01.18 - 16:50
(17)Создал мне какие то левые документы (при этом пугал…). Они не проведены… Я их удалил, они удалились!?

Этап "Проверка логической целостности". Создаются документы, или элементы справочников, которых нет в базе, но на которые есть ссылки. Потом, когда Вы их удаляете интерактивно, удаляются и ссылки. Второй раз он их уже не создаст. Не хотите, что-ы они создавались, в настройках ТиИ, поставьте переключатель "Очищать ссылки". По умолчанию стоит "Создавать объекты".
   Max_Prog
 
23 - 02.02.18 - 16:28
(22) Спасибо! Только смысл в итоге? Тогда бы сразу ссылки удаляла... Тем более ТиИ доки создает без префикса ИБ. С неуникальными НомерДок. Зачем эти сложности?
   Max_Prog
 
24 - 02.02.18 - 16:41
(21) Там Бухи - деревня деревянная, без единого гвоздя! Им 3 кнопки показали, они не чего знать не хотят. Я заложник обстоятельств.
   Max_Prog
 
25 - 02.02.18 - 17:22
(18) Абсолютно верно... Максимум неделя, а так 3-4 дня без ошибки.
(1) Под админом работали, такая же фигня...

У них винда левая. Я Win10 Pro Лицензию сейчас ставлю, там буду думать.
   AntiBuh
 
26 - 02.02.18 - 17:23
а вот чо делать, если на скулевой такая хрень появляется?
   timurhv
 
27 - 02.02.18 - 17:40
(0) Добавьте комп-сервер, поставьте туда Win 2003 и ходите по rdp?
   Max_Prog
 
28 - 02.02.18 - 17:41
(26) Я не знаю. У меня несколько распределенных баз часть из них на Win7, одна на ХР + Офис с центральной базой на Скуле (Скуль Free для разработчиков до 5Гб).Все пашет уже давно без этой хрени. Конфигурация Одинаковая! А вот на Win10 Ошибка -210 !!!
   AntiBuh
 
29 - 02.02.18 - 17:46
я пока лечу удалением из каталогов пользователей файлов *.dbf и *.cdx
но задалбывает
   Max_Prog
 
30 - 02.02.18 - 17:50
(29) Тоже Win10? Удаление можно автоматизировать. Помогает?
   Max_Prog
 
31 - 02.02.18 - 18:04
У меня чаще всего SP4062

#========================================================
#==TABLE no 162    : Регистр ОстаткиТМЦ
# Name    |Descr                         |Type[A/S/U]|DBTableName|ReUsable  
T=RG405   |Регистр ОстаткиТМЦ            |A          |RG405      |1        
#-----Fields-------
# Name      |Descr               |Type|Length|Precision
F=PERIOD    |Period Registr      |D   |8     |0        
F=SP4062    |(P)Фирма            |C   |9     |0        
F=SP408     |(P)Номенклатура     |C   |9     |0        
F=SP418     |(P)Склад            |C   |9     |0        
F=SP3117    |(P)ЦенаПрод         |N   |16    |2        
F=SP411     |(P)Количество       |N   |16    |5        
#----Indexes------
# Name     |Descr         |Unique|Indexed fields                                              |DBName    
I=PROP     |PERIOD+PROP   |0     |PERIOD,SP4062,SP408,SP418,SP3117                            |PROP      
I=VIA408   |VIA408        |0     |PERIOD,SP408                                                |VIA408    
#
#========================================================
#==TABLE no 163    : Регистр (Дв.) ОстаткиТМЦ
# Name    |Descr                         |Type[A/S/U]|DBTableName|ReUsable  
T=RA405   |Регистр (Дв.) ОстаткиТМЦ      |A          |RA405      |1        
#-----Fields-------
# Name      |Descr               |Type|Length|Precision
F=IDDOC     |ID Document's       |C   |9     |0        
F=LINENO    |LineNo              |N   |4     |0        
F=ACTNO     |Action No           |N   |6     |0        
F=DEBKRED   |Flag Debet/Kredit   |N   |1     |0        
F=SP4062    |(P)Фирма            |C   |9     |0        
F=SP408     |(P)Номенклатура     |C   |9     |0        
F=SP418     |(P)Склад            |C   |9     |0        
F=SP3117    |(P)ЦенаПрод         |N   |16    |2        
F=SP411     |(P)Количество       |N   |16    |5        
F=SP420     |(P)Внутреннее       |N   |2     |0        
#----Indexes------
# Name     |Descr         |Unique|Indexed fields                                              |DBName    
I=IDLINE   |of IDDOC+LineN|0     |IDDOC,LINENO,ACTNO                                          |IDLINE    
#
#========================================================

В RG405.DBF и RG405.DBF колонки SP4062 ЕСТЬ!
   AntiBuh
 
32 - 02.02.18 - 18:28
(30) да
на несколько дней 
(31)  кстати то же самое поле
   Max_Prog
 
33 - 02.02.18 - 18:55
(32)Прошу! По подробней, у меня не прописаны каталоги пользователей? Если нужно пропишем... А то я сразу со всего начал. Какие файлы грохнуть нужно?
 
 
   Max_Prog
 
34 - 02.02.18 - 19:34
(32) Друг отзовись! Должно быть в пятницу чудо.?
   AntiBuh
 
35 - 05.02.18 - 13:56
(33) файлики Т(число).dbf и .cdx
   Max_Prog
 
36 - 08.02.18 - 11:51
(35) У меня нет Т(число).dbf! Или удаляете все *.dbf и *.cdx , потом загрузить данные?
   Max_Prog
 
37 - 09.02.18 - 20:09
(35) В ярлыке на запуск 1С Ставил 
В свойствах ярлыка Ярлык => Дополнительно => V Запуск от имени администратора ???
Жду вроде помогает... Пока ошибок нет.
   Max_Prog
 
38 - 05.03.18 - 12:50
(35) Большое спасибо! Прописал всем пользователям КаталогПользователя и действительно появляются Т(число).dbf и .cdx.
Прописал
Процедура глУдалитьНахВсеИЗ_КатПользователя()    
    КатПоль = КаталогПользователя();
    Если ПустаяСтрока(КатПоль) = 0 Тогда 
        ФлУд = ФС.НайтиПервыйФайл(КатПоль+"*.cdx"); 
        Если ПустаяСтрока(ФлУд) = 0 Тогда 
            Пока ПустаяСтрока(ФлУд)=0 Цикл 
                Попытка
                    ФС.УдалитьФайл(ФлУд);
                Исключение
                    Сообщить(ОписаниеОшибки());
                КонецПопытки;
                ФлУд = ФС.НайтиСледующийФайл();
            КонецЦикла;                                     
        КонецЕсли; 
        ФлУд = ФС.НайтиПервыйФайл(КатПоль+"*.dbf"); 
        Если ПустаяСтрока(ФлУд) = 0 Тогда 
            Пока ПустаяСтрока(ФлУд)=0 Цикл 
                Попытка
                    ФС.УдалитьФайл(ФлУд);
                Исключение
                    Сообщить(ОписаниеОшибки());
                КонецПопытки;
                ФлУд = ФС.НайтиСледующийФайл();
            КонецЦикла;                                     
        КонецЕсли; 
        ФлУд = ФС.НайтиПервыйФайл(КатПоль+"*.bak"); 
        Если ПустаяСтрока(ФлУд) = 0 Тогда 
            Пока ПустаяСтрока(ФлУд)=0 Цикл 
                Попытка
                    ФС.УдалитьФайл(ФлУд);
                Исключение
                    Сообщить(ОписаниеОшибки());
                КонецПопытки;
                ФлУд = ФС.НайтиСледующийФайл();
            КонецЦикла;                                     
        КонецЕсли; 
    КонецЕсли;
КонецПроцедуры

ПриначалеРаботыСистемы() 
глУдалитьНахВсеИЗ_КатПользователя()
   Max_Prog
 
39 - 05.03.18 - 12:54
Природу создания этих файлов я не понял. Уже две недели работают три компа без ошибки.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует