Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

универсальный подбор и обработка объектов

универсальный подбор и обработка объектов
Я
   DenisVich
 
22.01.18 - 17:54
Здравствуйте. Столкнулся со следующей проблемой. Обрабатываю записи в справочнике с табличной частью. Данные заполняются по нескольку раз.(Одна и та же запись повторяется в табличной части, сколько найденных объектов столько раз и вносятся в выбранную запись)
Вот код:
СписокКонтрагентов = Новый СписокЗначений;
СписокКонтрагентов.Добавить("Альянс Белгород 2 РС ООО");
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ ПЕРВЫЕ 2
|    Компьютеры.Ссылка,
|    Компьютеры.Контрагент КАК Контрагент
|ИЗ
|    Справочник.Компьютеры КАК Компьютеры
|ГДЕ
|     Компьютеры.Контрагент.Наименование В(&Контрагент)
|СГРУППИРОВАТЬ ПО
|    Компьютеры.Ссылка,
|    Компьютеры.Контрагент";
Запрос.УстановитьПараметр("Контрагент", СписокКонтрагентов);

РезультатЗапросаКомпьютеры = Запрос.Выполнить().Выбрать();
Если РезультатЗапросаКомпьютеры.Количество()>0 Тогда
    Пока РезультатЗапросаКомпьютеры.Следующий() Цикл

    Источник = РезультатЗапросаКомпьютеры.Ссылка;
    ЭлементОбработан = Ложь;

    Если Не ЭлементОбработан Тогда

           НовоеСвойство = Объект.Свойства.Добавить();
           НовоеСвойство.ВидСвойства = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Дата снятия с учета");
           НовоеСвойство.ЗначениеСвойства= НачалоГода(ТекущаяДата());
           Сообщить(СОКРЛП(РезультатЗапросаКомпьютеры.Ссылка.Контрагент)+" "+СОКРЛП(РезультатЗапросаКомпьютеры.Ссылка));
           Объект.Записать();
           ЭлементОбработан = Истина;
    КонецЕсли;

КонецЦикла;
КонецЕсли;
 
 
   DenisVich
 
1 - 22.01.18 - 17:55
Поясняю, это произвольный алгоритм!
   Darych
 
2 - 22.01.18 - 17:58
запрос в топку, СписокКонтрагентов.Добавить("Альянс Белгород 2 РС ООО") в топку
   DenisVich
 
3 - 22.01.18 - 17:58
Что в этой обработке брать в качестве источника, если не использовать выборку?
   DenisVich
 
4 - 22.01.18 - 18:00
"    Источник = ????????;
           НовоеСвойство = Объект.Свойства.Добавить();
           НовоеСвойство.ВидСвойства = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Дата снятия с учета");
           НовоеСвойство.ЗначениеСвойства= НачалоГода(ТекущаяДата());
           Сообщить(СОКРЛП(РезультатЗапросаКомпьютеры.Ссылка.Контрагент)+" "+СОКРЛП(РезультатЗапросаКомпьютеры.Ссылка));
           Объект.Записать();"
   DenisVich
 
5 - 22.01.18 - 18:03
Источник = ТекущийОбъект;
   DenisVich
 
6 - 22.01.18 - 18:03
В том так сразу, а подсказать!
   DenisVich
 
7 - 22.01.18 - 18:03
*в топку

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует