Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Загрузка экселя в вебе через табличный документ

Загрузка экселя в вебе через табличный документ
Я
   razbiralshik
 
22.01.18 - 14:30
Не хочет загружатся никак, падает на этом моменте:
ЗаписатьФайл(Новый ДвоичныеДанные(ПутьКФайлуexplore), ПутьКФайлуexploreВоВременномХранилище);
конструктор не обнаружен
не может сделать это: Новый ДвоичныеДанные(ПутьКФайлуexplore).

Подскажите, как записать файлик пользователя локальный на сервер?
Т.к. это нужно вот для этого:
Функция ПолучитьТаблицуЗначенияИзExcel(ПутьКФайлу) Экспорт 
    ТабДок = Новый ТабличныйДокумент;
    ТабДок.Прочитать(ПутьКФайлу, СпособЧтенияЗначенийТабличногоДокумента.Значение); 
    ТЗ = ПолучитьТаблицуИзТабличногоДокумента(ТабДок.Область(1,1, ТабДок.ВысотаТаблицы, ТабДок.ШиринаТаблицы));
    Возврат ТЗ
КонецФункции

Функция ПолучитьТаблицуИзТабличногоДокумента(ОбластьМакета) Экспорт
    Построитель = Новый ПостроительЗапроса;
    ИсточникДанных = Новый ОписаниеИсточникаДанных(ОбластьМакета);
    Построитель.ИсточникДанных = ИсточникДанных;
    Построитель.Выполнить();
    ТабЗначений = Построитель.Результат.Выгрузить();
    Возврат ТабЗначений;
КонецФункции
 
 
   razbiralshik
 
1 - 22.01.18 - 15:33
Никто не умеет?
   Скиурус
 
2 - 22.01.18 - 15:52
Забери файл на сервак через НачатьПомещениеФайла
   razbiralshik
 
3 - 22.01.18 - 15:55
(2) его сперва надо на сервак записать чтобы забрать оттуда
   mehfk
 
4 - 22.01.18 - 16:11
А так?
    НачатьСозданиеДвоичныхДанныхИзФайла(Новый ОписаниеОповещения("ЗавершитьСозданиеДвоичныхДанныхИзФайла", ЭтотОбъект), ПутьКФайлуexplore);


&НаКлиенте
Процедура ЗавершитьСозданиеДвоичныхДанныхИзФайла(ДвоичныеДанныеФайла, ДополнительныеПараметры) Экспорт
    
    Сообщить(ТипЗнч(ДвоичныеДанныеФайла));    
    
КонецПроцедуры
   razbiralshik
 
5 - 22.01.18 - 16:19
(4) получилось, спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует