Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

СтандартныеПодсистемы.ПодключаемыеКоманды

СтандартныеПодсистемы.ПодключаемыеКоманды
Я
   Rom_Kat
 
22.01.18 - 10:14
Добрый день, уважаемые знатоки.
Не добавляется ПодменюПечать в форме нового документа в БП  3.0 (3.0.57.17) 


В модуле формы добавил
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    // СтандартныеПодсистемы.ПодключаемыеКоманды

    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды

    
КонецПроцедуры

В менеджере 

// Заполняет список команд печати.

// 
// Параметры:

//   КомандыПечати - ТаблицаЗначений - состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати
//

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
        
    // Поручение экспедитору

    КомандаПечати = КомандыПечати.Добавить();
    КомандаПечати.Идентификатор = "ОписьДокументов";
    КомандаПечати.Представление = НСтр("ru = 'Опись вложенных документов'");
    КомандаПечати.ПроверкаПроведенияПередПечатью = Ложь;
    КомандаПечати.Порядок = 1;
            
КонецПроцедуры

но кнопка на форме так и не появилась. Где-то что-то не добавил.

Подскажите пожалуйста.
 
 
   Мыш
 
1 - 22.01.18 - 10:24
(0) ОбщийМодуль.ПодключаемыеКомандыПереопределяемый
   Мыш
 
2 - 22.01.18 - 10:26
Не, ошибся. Это для существующих.
   Мыш
 
3 - 22.01.18 - 10:27
Если форма является формой объекта, тогда:

? В параметре <ОбъектИлиТаблицаФормы> следует передавать реквизит формы типа ДанныеФормыСтруктура. Например:

    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
? В обработчике ПриЧтенииНаСервере формы следует вставить вызов по шаблону:

&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
    // СтандартныеПодсистемы.ПодключаемыеКоманды

    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, <ОбъектИлиТаблицаФормы>);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды

КонецПроцедуры
? В обработчике ПриОткрытии формы следует вставить вызов по шаблону:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    // СтандартныеПодсистемы.ПодключаемыеКоманды

    ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд(ЭтотОбъект);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды

КонецПроцедуры
? Также рекомендуется вызывать процедуры обновления видимости команд после изменения ключевых реквизитов (значения которых могут быть использованы в условиях видимости команд):

? ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд - для обновления видимости команд на клиенте (подключает обработчик ожидания Подключаемый_ОбновитьКоманды).

? ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды - для обновления видимости команд на сервере (используется в случае, если в процессе вызова уже делается серверный вызов).
   Rom_Kat
 
4 - 22.01.18 - 17:47
(3)никак

добавил еще обработчики в модуль формы
Подключаемый_ОбновитьКоманды.
Кнопка печать не появляется
   Rom_Kat
 
5 - 22.01.18 - 17:48
(3)это вы где прочитали?
   Вафель
 
6 - 22.01.18 - 17:49
а группа печати добалвена в панель?
   Мыш
 
7 - 22.01.18 - 17:54
(5) Вестимо, ИТС.
   drcrasher
 
8 - 22.01.18 - 17:59
(0) а почему не УправлениеПечатью.ПриСозданииНаСервере(ЭтотОбъект); ?
   drcrasher
 
9 - 22.01.18 - 18:00
(6) не обязательно, насколько я помню
   Rom_Kat
 
10 - 23.01.18 - 16:36
И самое главное
? Объекты конфигурации, являющиеся поставщиками команд печати, следует перечислить в процедуре ПриОпределенииОбъектовСКомандамиПечати модуля УправлениеПечатьюПереопределяемый.
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует