Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Изменение шрифта 1с 8.2 обычные формы

Изменение шрифта 1с 8.2 обычные формы
Я
   Alex_Kh_ua
 
18.01.18 - 20:34
Доброго времени суток форумчане!!! Такой вопрос от начинающего программиста 1с. Есть тема о увеличении шрифта на Инфостарте, http://catalog.mista.ru/public/153181/  и в ней есть интересное решение в комментах. А именно "В типовых можно и не добавлять регистр - для этого подходит типовой регистр "НастройкиПользователей".
Где можно добавлять свои настройки в режиме предприятия (или программно). В качестве значения - "булево" (крупный/не крупный) или "строка" (имя стиля, если не только шрифт меняем).
И пользователю редактировать удобно и изменений мало. А в коде по имени настройки получать её значение." Может кто так делал, как это реализовано, без примера еще туплю...
 
 
   Alex_Kh_ua
 
1 - 18.01.18 - 20:49
Или может просто есть понимание того как реализовано?
   Alex_Kh_ua
 
2 - 18.01.18 - 21:47
АП!
   Волшебник
 
Модератор
3 - 18.01.18 - 21:50
В статье что непонятно?
   Alex_Kh_ua
 
4 - 18.01.18 - 21:56
Не понятно, где фактически и какой код участвует при использовании данного метода... Немного узколобый на этот счет.
   Йохохо
 
5 - 18.01.18 - 22:04
(4) этот
Процедура ПередНачаломРаботыСистемы(Отказ)
    
    УправлениеПользователями.ПроверитьВозможностьРаботыПользователя(Отказ);    
    
    ГлавныйСтиль = БиблиотекаСтилей.Получить(ПолучитьНомерСтиляПользователя());//+ASG

    
КонецПроцедуры
*****
ГлавныйСтиль (MainStyle)
Использование:

Чтение и запись.
Описание:

Тип: Стиль.
Управляет стилем всего приложения, аналогично тому, как это происходит при установке стиля приложения в режиме Конфигуратор.
Может быть установлено в одно из значений коллекции стилей глобального контекста или в значение стиля по умолчанию (стиль "Авто").

Доступность:

Толстый клиент.
Примечание:
!!!
Доступно для записи до открытия главного окна приложения.
***
ЗЫ встроенный стиль имеет индекс 0 если захочется потестить правкой 1 строки
   Alex_Kh_ua
 
6 - 18.01.18 - 22:40
Так, стиль все равно придется копировать или как?
   Йохохо
 
7 - 18.01.18 - 22:50
Похоже на то
БиблиотекаСтилей (StyleLib)
Использование:

Только чтение.
Описание:

Тип: БиблиотекаСтилей.
Используется для доступа к определенным в конфигурации стилям.

Доступность:

Толстый клиент.
   Alex_Kh_ua
 
8 - 19.01.18 - 00:28
В общем то, все получилось, спасибо Вам.
На этом скрине, место добавление реквизита, способ из шапки темы https://drive.google.com/open?id=1K-syDZ5-UTqLgtwaUjyHKI8hYa6BdvXd
На этом скрине появившийся реквизит в справочнике https://drive.google.com/open?id=1L2DCCyRyCQHRzs0bSXLdim73JRm_IuVo

На этом скрине сам код процедур подключения и отключения Стиля, скопированного из основного "Основной1", шрифт в котором изменен https://drive.google.com/open?id=1kqaoS7dcLUXprUS62RI2y_Q3W2BVaQc5
   Alex_Kh_ua
 
9 - 19.01.18 - 00:31
Теперь следующий вопрос, а можно ли программно как то обойти элементы стиля и назначить размеры шрифта, есть идеи на этот счет??? Буду очень признателен за любые версии и догадки. Кстати, если не уследили, формы обычные, толстый клиент.
   Alex_Kh_ua
 
10 - 19.01.18 - 00:35
Нашел ошибку в условии своей
 
Функция ПолучитьНомерСтиляПользователя()
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    НастройкиПользователей.Значение
    |ИЗ
    |    РегистрСведений.НастройкиПользователей КАК НастройкиПользователей
    |ГДЕ
    |    НастройкиПользователей.Пользователь = &Пользователь
    |    И НастройкиПользователей.Настройка.Наименование = &Наименование";
    
    Запрос.УстановитьПараметр("Пользователь", ПараметрыСеанса.ТекущийПользователь);
    Запрос.УстановитьПараметр("Наименование", "ШрифтКрупнее");
    Результат = Запрос.Выполнить().Выбрать();
    Если Результат.Следующий() Тогда
        
        Если Результат.Значение = Истина Тогда
            Возврат 1;
        Иначе 
            Возврат 0;
        КонецЕсли;
//Не было иначе, так как могут быть пользователи совершенно без данного реквизита.

    Иначе 
        Возврат 0;
    КонецЕсли;
    
КонецФункции
 
 Рекламное место пустует
   Alex_Kh_ua
 
11 - 19.01.18 - 00:38
Теперь следующий вопрос, а можно ли программно как то обойти элементы стиля и назначить размеры шрифта, есть идеи на этот счет??? Буду очень признателен за любые версии и догадки. Кстати, если не уследили, формы обычные, толстый клиент. http://prntscr.com/i2dw8l
   Alex_Kh_ua
 
12 - 19.01.18 - 09:08
Ап!
   Йохохо
 
13 - 19.01.18 - 09:23
у стиля "приложения" похоже нет никаких методов. стиль еще можно применить к форме, мб там что то есть, посмотрите в справке, мне лень

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует