Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Чтение из файла и запись в справочник.

v7: Чтение из файла и запись в справочник.
Я
   Личунхо
 
18.01.18 - 13:26
Здравствуйте!
1С версия 77, (7.70.025).
На диске С: в папке time есть текстовый файл 1.txt.
В нём одна строка, в строке одно слово - ИВАНОВ.
Нужно, при нажатии на кнопку считать слово из файла, показать, что считывание произошло и записать в справочник "ФИО" в поле "Фамилия".
Как это сделать?
Где разместить кнопку? В документе? В проводке или можно в форме справочника?
Где разместить код, вроде:
Процедура ЧтениеТекстаИзФайла()
 Текст =СоздатьОбъект("Текст");
Текст.Открыть("C:\TIME\1.txt");
Стр = Текст.ПолучитьСтроку(1);
Текст.Показать(); 

Куда вывести переменную Стр ?
Я этот код разместил в модуле обработки.
При открытии обработки вообще ничего не происходит.

Ищу программиста 1С в Омске!
 
 
   vicof
 
1 - 18.01.18 - 13:34
"Ищу программиста 1С в Омске!"
Это тестовое задание?
   Ray Zexter
 
2 - 18.01.18 - 13:34
   MrCoffin
 
3 - 18.01.18 - 13:37
(0) Размести код в обработке. Кнопку размести на форме обработки. Вызывай код из обработчика кнопки с формы обработки. Переменную Стр можешь вывести:
Сообщить(Стр);
Можешь
Предупреждение(Стр);
При открытии ничего и не должно происходить.
Сам-то кто будешь? Что требуется от программиста?
   Личунхо
 
4 - 18.01.18 - 15:22
А как тут картинки размещать?
Ну так я разместил новую кнопку на форме обработки.
А как вызвать обработчик нажатия кнопки?
[qute]Сообщить(Стр);[/qute]
Это разместил, молчание.
От программиста требуется:
1. Личные встречи.
2. Уроки по 1С.
3. Написание кода.

   Ray Zexter, ссылка не работает.
   Личунхо
 
5 - 18.01.18 - 15:23
Я работаю в лечебном учреждении.
Есть программа в Delphi.
Хочу перевести на 1С.
   Личунхо
 
6 - 18.01.18 - 15:25
   DDwe
 
7 - 18.01.18 - 15:26
(5) Эпично! Зачем? Ну и традиционно - а вы там кто? Дворник?
   Личунхо
 
8 - 18.01.18 - 15:26
   arsik
 
9 - 18.01.18 - 15:27
(5) Соболезную омским больным
   DDwe
 
10 - 18.01.18 - 15:27
(4) А, почитать книжку по 1С? Нету сил?
 
 Рекламное место пустует
   Личунхо
 
11 - 18.01.18 - 15:27
   mehfk
 
12 - 18.01.18 - 15:28
(5)
>> Есть программа в Delphi.
>> Хочу перевести на 1С.

Для чего?
   Ёпрст
 
13 - 18.01.18 - 15:30
(11)

Процедура Выполнить()
   ЧтениеТекстаИзФайла();
КонецПроцедуры
   MrCoffin
 
14 - 18.01.18 - 15:31
(5) Да, Омск славный город и люди там достойные.
Переводи на 8 тогда.
Сам-то раньше на чем писал? Написанный код нужно запустить на исполнение. Раз уж в 7.7 то напиши в модуле формы 
Процедура ПриОткрытии()
Сообщить("Я у мамы молодец!", "!!!");
Сообщить("Миста - хороший форум. Где-то тут был учебник ""Первые шаги"". Надо его поискать.", "i");
КонецПроцедуры
   Ёпрст
 
15 - 18.01.18 - 15:31
Или в формуле кнопки (та, что на форме у тебя, пкм-свойства) напиши ЧтениеТекстаИзФайла()
   MrCoffin
 
16 - 18.01.18 - 15:32
(13) Как ты это делоешь?
   ololoraise
 
17 - 18.01.18 - 15:37
(11)

//*******************************************

Процедура Сформировать()
    Текст =СоздатьОбъект("Текст");
    Текст.Открыть("C:\TIME\1.txt");
    Стр = Текст.ПолучитьСтроку(1);
    Текст.Показать();
    Сообщить(Стр);
КонецПроцедуры
   Личунхо
 
18 - 19.01.18 - 06:19
О! Всё работает!
И в 77 и в 8.0. )))
И в кнопке и в общем модуле )))

Спасибо MrCoffin, Ёпрст, ololoraise.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует