Вход | Регистрация

1С:Предприятие ::

Метки: 

ЗУП 3.1 Междувахтовый отдых.

Я
   2S
 
16.01.18 - 12:39
Хм, знатоки, вопрос со временем "Междувахтовый отдых" с основным видом времени "Дополнительные выходные дни (оплачиваемые)" или "..неоплачиваемые"
Судя по https://buh.ru/articles/documents/45994/ было возможно в графике указывать дни междувахтового отдыха. Статья 2015 года.

Смотрим 3.1.3.274, и нифига данный механизм не работает.
Ок, смотрим код
&НаСервере
Процедура ЗаполнитьСписокВидовВремени(ИспользуемыеВидыВремени = Неопределено)

блаблабла ищем абзац с неполным временем...

    Если НеполноеРабочееВремя Тогда
        ВидыСокращенногоВремени = Новый Массив;
        ВидыСокращенногоВремени.Добавить(ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.ВидыИспользованияРабочегоВремени.СокращенноеВремяОбучающихся"));
        ВидыСокращенногоВремени.Добавить(ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.ВидыИспользованияРабочегоВремени.СокращенноеРабочееВремя"));
        ВидыСокращенногоВремени.Добавить(ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.ВидыИспользованияРабочегоВремени.РаботаВРежимеНеполногоВремени"));
        
        Запрос = Новый Запрос;
        Запрос.УстановитьПараметр("ВидыСокращенногоВремени", ВидыСокращенногоВремени);
        Запрос.Текст = 
        "ВЫБРАТЬ
        |    ВидыИспользованияРабочегоВремени.Ссылка КАК ВидВремени,
        |    ВидыИспользованияРабочегоВремени.БуквенныйКод,
        |    ВидыИспользованияРабочегоВремени.Наименование
        |ИЗ
        |    Справочник.ВидыИспользованияРабочегоВремени КАК ВидыИспользованияРабочегоВремени
        |ГДЕ
        |    ВидыИспользованияРабочегоВремени.ОсновноеВремя В(&ВидыСокращенногоВремени)";
        
        Выборка = Запрос.Выполнить().Выбрать();
    
        Пока Выборка.Следующий() Цикл
            Если ИспользуемыеВидыВремени.Найти(Выборка.ВидВремени) <> Неопределено Тогда
                Продолжить;
            КонецЕсли;
            
            СтрокаВидаВремени = СписокВидовВремени.Добавить();
            ЗаполнитьЗначенияСвойств(СтрокаВидаВремени, Выборка);
            
        КонецЦикла;    

    КонецЕсли;    

И нет того что надо..


Короче, убрали или поменяи механизм? Направьте ...
 
 
   2S
 
1 - 16.01.18 - 13:14
подниму, очень актуально
   2S
 
2 - 16.01.18 - 15:36
Добавить добавил, проблема ушла, но надеюсь ничем не чревато в дальнейшем.
        ВидыСокращенногоВремени.Добавить(ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.ВидыИспользованияРабочегоВремени.ДополнительныеВыходныеДниОплачиваемые"));
        ВидыСокращенногоВремени.Добавить(ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.ВидыИспользованияРабочегоВремени.ДополнительныеВыходныеДниНеОплачиваемые"));


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует