Вход | Регистрация

1С:Предприятие ::

Метки: 

Как убрать заголовок полей ресурса СКД

Я
   aleksejafonkin
 
16.01.18 - 12:36
Добрый день! Подскажите как убрать заголовок полей ресурса (сумма)? https://yadi.sk/i/KyFT-N1i3RVgnq
Вывожу таблицу по этому и так понятно, что на пересечении колонок и строк выводится сумма (ресурс)
 
 
   МимохожийОднако
 
1 - 16.01.18 - 12:38
Можно через шаблон после формирования удалять первые строки
   Mankubus
 
2 - 16.01.18 - 12:39
(0) можно установить заголовок равный пробелу. тогда не видно будет суммы
http://1centerprise8.blogspot.ru/2016/03/shapka-otcheta-skd.html
п.2
   МимохожийОднако
 
3 - 16.01.18 - 12:46
вот кусочек для раздербанивания
//Сформировать отчет

    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);
    
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , , Истина);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент();
    
    Результат = Новый ТабличныйДокумент;
    
    ПроцессорВывода.УстановитьДокумент(Результат);
    ПроцессорВывода.НачатьВывод();
    
    Пока Истина Цикл
        ЭлементРезультата = ПроцессорКомпоновки.Следующий();
        Если ЭлементРезультата = Неопределено Тогда
            Прервать;
        КонецЕсли;
            
        ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
    КонецЦикла;
    ПроцессорВывода.ЗакончитьВывод();
    
    
    Если БезЗаголовка Тогда
        Смещать = ТипСмещенияТабличногоДокумента.ПоВертикали;
        Область = Результат.Область("R1");
        Результат.УдалитьОбласть(Область, Смещать);
    КонецЕсли;
   aleksejafonkin
 
4 - 16.01.18 - 12:48
(3) Спасибо! Сейчас разбираться буду!


Список тем форума
Рекламное место пустует Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует