Вход | Регистрация

1С:Предприятие ::

Метки: 

ЧислоПрописью округление

↓ [Волшебник, 12.01.18 - 12:27]
Я
   Ruslan_culeiman
 
12.01.18 - 11:45
Приветсвую, в типовой ут вес брутто - 1 102, 5, а в печатную форму попадает Одна т сто три кг, как убрать округление и чтобы печатало граммы тоже. Какой нужно передать формат что то не пойму, типовой         СтрокаФормат = "т, т, т, ж, кг, кг, кг, м, " + ?(Окр(МассаТонны) = МассаТонны, "0", "3");
 
 
   shadow_sw
 
1 - 12.01.18 - 11:56
придет Волшебник, подарит словарь  :)
   Ruslan_culeiman
 
2 - 12.01.18 - 11:58
(1) не приходит волшебник, лишь бы поумничать
   hhhh
 
3 - 12.01.18 - 12:04
(2) "Волшебник" с большой буквы пишется.
   shadow_sw
 
4 - 12.01.18 - 12:04
ФормСтрока = "Л = ru_RU; ДП = Истина";
ПарПредмета="килограмм,килограмма,килограммов,м,грамм,грамма,граммов,м,3";
ПрописьЧисла = ЧислоПрописью(ИтогоМассаБрутто, ФормСтрока, ПарПредмета);

СП дорого, как обычно
   Ruslan_culeiman
 
5 - 12.01.18 - 12:09
(4) КЭП, нету инфы в СП про округление
   Ruslan_culeiman
 
6 - 12.01.18 - 12:09
(3) Поэтому и не приходит
   shadow_sw
 
7 - 12.01.18 - 12:11
(5) лейтенант, есть куча желтых книжек
   Ruslan_culeiman
 
8 - 12.01.18 - 12:13
(7) Тогда зачем форум нужен?
   shadow_sw
 
9 - 12.01.18 - 12:17
(8) удаляйся
   Zmich
 
10 - 12.01.18 - 12:18
(0).
Функция ПолучитьВесПрописью(ВыбЧисло)
    
    ФормСтрока = "Л = ru_RU; ДП = Истина";
    ПараметрыТ = "тонна, тонны, тонн, ж,,,,, 0";
    Тонны = Цел(ВыбЧисло/1000);
    Если Тонны > 0 Тогда
        ПрописьЧислаТонны = ЧислоПрописью(Тонны, ФормСтрока, ПараметрыТ) + " ";
    Иначе
        ПрописьЧислаТонны = "";
    КонецЕсли;
    КгИГр = ВыбЧисло - Тонны*1000;
    ПараметрыКгИГр = "килограмм, килограмма, килограммов, м, грамм, грамма, граммов, м, 3";
    ПрописьЧислаКгИГр = ЧислоПрописью(КгИГр, ФормСтрока, ПараметрыКгИГр);
    Если ПрописьЧислаТонны <> "" Тогда
        ПрописьЧислаКгИГр = НРег(ПрописьЧислаКгИГр);
    КонецЕсли;    
    Возврат ПрописьЧислаТонны + ПрописьЧислаКгИГр;
    
КонецФункции
 
 Рекламное место пустует
   Ruslan_culeiman
 
11 - 12.01.18 - 12:26
(9) раз ты не можешь ответить я сам отвечу, форум нужен для того чтобы люди делились опытом, может кто сталкивался с такой же задачей и может помочь либо направить в нужную сторону.
п.с. Надо вопрос прочитать, потом умничать
   Ruslan_culeiman
 
12 - 12.01.18 - 12:26
(10) Спасибо большое
   Волшебник
 
Модератор
13 - 12.01.18 - 12:28
(8) Форум создан для того, чтобы дарить людям радость общения.
http://www.forum.mista.ru/about.php

Ваш Кэп.
   shadow_sw
 
14 - 12.01.18 - 12:35
(2)вот и пришел он - Волшебник :) (13)


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует