Вход | Регистрация


Как не показывать список выбора при автоподборе?

Как не показывать список выбора при автоподборе?
Я
   RomaH
 
12.01.18 - 11:43
Но только именно в этом элементе?
УФ
 
 
   RomaH
 
1 - 12.01.18 - 11:48
https://www.dropbox.com/s/4zsspppjuwo0csy/2018-01-12_11h43_17.png?dl=0

т.е. что бы вот этого списка не было

Автоподбор стандартнфяОбработка в ложь поставить

а при окончании - уже стандартно давать?
   RomaH
 
2 - 12.01.18 - 13:49
а как теперь убрать "Нет в списке"?
https://www.dropbox.com/s/zckt1onh2zu66y1/2018-01-12_13h47_45.png?dl=0
   RomaH
 
3 - 12.01.18 - 14:06
т.е. по сути - надо отключить автоподбор, а вот окончание ввода текста оставить
   RomaH
 
4 - 12.01.18 - 14:15
та что ж такое-то?

Процедура УслугиУслугаАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)
    Если Ожидание > 0 Тогда
        СтандартнаяОбработка = Ложь;
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура УслугиУслугаИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
    СтандартнаяОбработка =  Ложь;
КонецПроцедуры


теперь "Введите строку для поиска"

https://www.dropbox.com/s/m1uxjabek3ca9ma/2018-01-12_14h12_44.png?dl=0
   DrZombi
 
5 - 12.01.18 - 14:33
Кидай на яндекс, гугл забанен, судя потому, что ты один пишешь, то у многих :)
   DrZombi
 
6 - 12.01.18 - 14:37
(4) Если вы так хотите избавиться отсписка на УФ или видеть свой список, то надо начать с менеджера справочника. Там есть метод "ОбработкаПолученияДанныхВыбора".
Как с ним работать и как туда передавать данные отбора из формы?
Через элемент формы, параметр "Список выбора" СписокВыбора, ChoiceList
Задаешь туда нужное значение и в менеджере справочника можешь получить эти значения.
А уж как там обработаешь от тебя зависит.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует