Вход | Регистрация

1С:Предприятие ::

Метки: 

Запись в табличную часть документа из внешней обработки

Я
   FR95
 
11.01.18 - 18:13
Как из формы внешней обработки обратиться к табличной части документа и записать в определенную ячейку строки значение?
Данный код не работает (если можно, прошу исправить).
&НаСервере
Функция ПолучитьДокумент()
    Возврат Документы.КВП_РегистрацияОплаты;
КонецФункции

&НаКлиенте
Процедура Ок(Команда)
    ДеревоРасшифровкаПлатежа = ПолучитьТЧ();    
        

    ДокументРО = ПолучитьДокумент();
    ТабЧастьРО = ДокументРО.РасшифровкаПлатежа.Выгрузить();
    Для Каждого Стр Из ТабЧастьРО Цикл
         ОбойтиДеревоЗначений(Стр);
    КонецЦикла;


КонецПроцедуры

&НаКлиенте
Процедура ОбойтиДеревоЗначений(Элемент)
    ПодчиненныйЭлемент=Элемент.ПолучитьЭлементы();
    Для Каждого Строка из ПодчиненныйЭлемент Цикл
    Строка.Сумма = 100;
        ОбойтиДеревоЗначений(Строка);
    КонецЦикла;
КонецПроцедуры
 
  Рекламное место пустует
   МимохожийОднако
 
1 - 11.01.18 - 18:18
   vicof
 
2 - 11.01.18 - 19:19
1. Понять взаимодействие клиента и сервера, и знать, какие команды можно на клиенте и сервере выполнять, какие нельзя.
2. Понять разницу между объектами формы и объектами метаданных.
3. Сделать свою хотелку
   breezee
 
3 - 11.01.18 - 19:20
(0) Как вы думаете, какой тип будет у переменной "ДокументРО"?
   vicof
 
4 - 11.01.18 - 19:22
Код выбросить на помойку


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует