Вход | Регистрация

1С:Предприятие ::

Метки: 

Поле объекта не обнаружено

Я
   Сергей Д
 
09.01.18 - 15:56
Добрый день
Вернулся из SAP-а в 1С и тут же столкнулся с проблемой (может забыл чего). Есть процедура сохранения образа из хранилища:
&НаКлиенте
Процедура СохранитьЛист(Команда)
    ТекущаяСтрока=Элементы.Листы.ТекущаяСтрока;
    Если ТекущаяСтрока<>Неопределено Тогда
        Диалог=новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
        Диалог.Заголовок="Укажите имя файла";
        Диалог.МножественныйВыбор=Ложь;
        Диалог.ПолноеИмяФайла=ТекущаяСтрока.ИмяФайла;
        Если Диалог.Выбрать() Тогда
            (сохраняем)
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
Запускаю на Win7 - работает. На Win10 - ошибка "Поле объекта не обнаружено ТекущаяСтрока.ИмяФайла" (в отладке значения полей ТекущаяСтрока не показываются).
Конфигурация одна и та же, файловая база (собственно, просто перенес файл с одной машины на другую), версия 1С 8.3.6.2390, отладка идет в тонком клиенте.
Почему так?
 
 
   Rico_1C
 
1 - 09.01.18 - 16:10
Наверно нужно спозиционироваться на ней?!..
   Rico_1C
 
2 - 09.01.18 - 16:12
Может .ТекущиеДанные?!..
   polosov
 
3 - 09.01.18 - 16:22
(0) Платформу обнови
   Сергей Д
 
4 - 09.01.18 - 16:32
(1) Строка на экране выделена.
(2) Так и сделал... но вопрос почему где-то видит, а где-то нет
   hhhh
 
5 - 09.01.18 - 16:36
(4) ну все пишут ТекущиеДанные, поэтому вам надо быть в тренде, а не использовать левые команды.
   МимохожийОднако
 
6 - 09.01.18 - 16:40
(4) Платформу обнови
   ВРедная
 
7 - 09.01.18 - 16:54
(4) Текущая строка в отладчике - число?
   Сергей Д
 
8 - 09.01.18 - 16:57
(7) СправочникСсылка. Но под Вин10 отладчик не показывает реквизиты.
   КнОпка
 
9 - 09.01.18 - 16:57
Платформа должна быть не меньше 8.3.10
   КнОпка
 
10 - 09.01.18 - 16:57
на win10
 
 Рекламное место пустует
   Мандалай
 
11 - 09.01.18 - 17:29
Не на сервер ли надо передать управление?
   Мандалай
 
12 - 09.01.18 - 17:31
Каша правда получается :) 
Листы это что? Объект метаданных?
   polosov
 
13 - 09.01.18 - 17:35
(12) П Л А Т Ф О Р М У    О Б Н О В И
   Darych
 
14 - 09.01.18 - 17:35
(12) по коду как бы видно что эл формы - таблица или ДС


Список тем форума
Рекламное место пустует Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует