Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Запрет на работы конфигурации в 64 разрядной Windows

Запрет на работы конфигурации в 64 разрядной Windows
Я
   Sam1C
 
07.01.18 - 14:47
Всех с праздником! В файле обновления Бухгалтерии  одного франча в общем модуле КонтрольВерсииПлатформы появился замечательный код:
...
Это64Платформа = СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86_64;
Если Это64Платформа Тогда
        ВерсияПодходит = Ложь;    
        НужноПредупреждение = Истина;
        НужноПрекратитьРаботу = Истина;
        ТекстРаботаБудетПрекращена = Символы.ПС + "Работа программы будет прекращена.";
        ТекстЭто64Платформа = " НЕ 64-bit !!!";
    КонецЕсли;
...
Ну и соответственно, если Винда 64 разрядная, с предупреждением:"Для работы с конфигурацией требуется версия платформы 1С:Предприятие 8.3.10  НЕ 64-bit !!!
"  завершает работу 1С.
Может я чего не знаю конечно, но по моему какой-то бред, для чего это может быть?
 
 
   Lama12
 
1 - 07.01.18 - 14:50
(0) Может они COM библиотеки 32х разрядные используют. Вместо того что б переписать библиотеки, вставили такую заглушку.
   Sam1C
 
2 - 07.01.18 - 14:52
(1) Да ни думаю, так как вставили именно в последний релиз свой, в прошлом месяце такого кода не было.
   jsmith82
 
3 - 07.01.18 - 14:54
Скажи точную конфу
   AlvlSpb
 
4 - 07.01.18 - 14:54
(0) Бред конечно. Попробуй заблокировать этот код и проверить работу на 64 битной винде. Если что-то замутили, то должно вылезьти
   Sam1C
 
5 - 07.01.18 - 14:56
А вообще СистемнаяИнформация.ТипПлатформы возвращает на какой ОС и её разряд крутиться 1С? или разрядность исполняемых файлов 1С (1cv8.exe и т.п.)
   Sam1C
 
6 - 07.01.18 - 14:58
(4) можно и так, но жаль времени делать копию снимать с поддержки. Уже лучше завтра позвоню на этот франч. Пока мне кажется, что это глупая ошибка
   Sam1C
 
7 - 07.01.18 - 15:01
(3) Конфа на основе Бухгалтерия 2.0
   Lama12
 
8 - 07.01.18 - 15:05
(6) Так конфа еще и на поддержке? Тогда точно какие ни будь штрихкоды или qr-коды на внешней компоненте. Или работа с торговым оборудованием. Из-за них и ограничение.
   Sam1C
 
9 - 07.01.18 - 15:10
(8) Сколько лет Бухгалтерия 2.0? 10 лет не меньше. У этого франча под 1000 клиентов. Что все работают на внешних компонентах... Нет конечно. И только сейчас, надо было включить в релиз эту проверку. Да и грамотно это делать не посредственно если это работа происходит, а не на старте системы выкидывать пользователей.
   Sam1C
 
10 - 07.01.18 - 15:21
(4) Сделал все таки тест, любопытство замучило. Убрал проверку эту все норм работает.
 
 Рекламное место пустует
   Aleksey
 
11 - 07.01.18 - 15:21
(8) Походу отраслевая со своим ключом и модуль защиты не работает на 64-х разрядной винде
   Aleksey
 
12 - 07.01.18 - 15:22
(10) Доп.ключ защиты/dll есть? Может 64-х разрядная не запускает защиту и позволяет без ограничения работать, вот и вставили такую проверку
   Sam1C
 
13 - 07.01.18 - 15:23
(11) Нету ни каких ключей, пару модулей закрыты стандартными средствами 1С
   jsmith82
 
14 - 07.01.18 - 15:25
Код 1сный или отраслевого поставщика.
   Sam1C
 
15 - 07.01.18 - 15:26
(14) Взята за основу Бух.2.0 и код на 80-90 % 1С-ный
   jsmith82
 
16 - 07.01.18 - 15:28
А БП 2.0 официально 64 бит поддерживает?
   Dmitry1c
 
17 - 07.01.18 - 15:28
(15) блин, ну не будет у вас отраслевой функционал работать, а вы будете визжать во франч и звонить, "почему не работает мы бабки заплатили"

а так хотя бы понятно сделано, что программа хочет
а вы по сути сейчас все испортили
   jsmith82
 
18 - 07.01.18 - 15:28
Рег. отчетность не вся на 64 бит пашет так-то
   Sam1C
 
19 - 07.01.18 - 15:30
(16) При чем тут конфигурации 1С до разрядности ОС???
   Sam1C
 
20 - 07.01.18 - 15:31
Вы не поверите, но даже конфигурации на 1С7.7 отлично работают на 64 битных системах....
   jsmith82
 
21 - 07.01.18 - 15:31
(19) Написали же, что ВК
В т.ч. для рег. очтетности
   Dmitry1c
 
22 - 07.01.18 - 15:31
(19) не сразу понял

это просто косяк разработчика. проверка видимо должна была быть на платформу, а не на разрядность винды
   jsmith82
 
23 - 07.01.18 - 15:33
(22) +1
   Sam1C
 
24 - 07.01.18 - 15:34
Лично я пока уверен, что тут дело будет в Бритве Хэнлона:"Никогда не приписывайте злому умыслу то, что вполне можно объяснить глупостью". Что это косяк франча
   Sam1C
 
25 - 07.01.18 - 15:37
(21) Ну даже, если что-то работает на ВК это не повод не запускать программу. Да и я уже не помню когда видел установленные у клиента x86 системы. В основном только x64
   Sam1C
 
26 - 07.01.18 - 15:38
с таким успехом можно сделать проверку на Windows 95, если версия выше то не пускать)
   Sam1C
 
27 - 07.01.18 - 15:44
(22) Там есть проверка и на платформу и всегда была, но в последний релиз добавили это новшества
   Woldemar177
 
28 - 07.01.18 - 15:44
(0)//для чего это может быть?

Драйвера например для ФР онлайн ККТ работают на 32 .
Вот для такого случая и конфа.
   jsmith82
 
29 - 07.01.18 - 15:45
(28) (22)
   Sam1C
 
30 - 07.01.18 - 15:45
(27) Публикую весь код:
   Sam1C
 
31 - 07.01.18 - 15:45
Процедура ПроверитьВерсиюПлатформы() Экспорт

    
    СистемнаяИнформация = Новый СистемнаяИнформация;
    ТекущаяВерсия = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СистемнаяИнформация.ВерсияПриложения, ".");
    РекомендуемаяВерсия = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(РекомендуемаяВерсияПлатформы(), ".");
    НужноПредупреждение = Истина;
    НужноПрекратитьРаботу = Ложь;
    Это64Платформа =СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86_64;
    ТекстРаботаБудетПрекращена = "";
    ТекстЭто64Платформа = "";
    
    Для Счетчик = РекомендуемаяВерсия.Количество() + 1 По ТекущаяВерсия.Количество() Цикл
        РекомендуемаяВерсия.Добавить("0");
    КонецЦикла;
    
    ВерсияПодходит = Истина;
    Для Счетчик = 0 По ТекущаяВерсия.ВГраница() Цикл
        Если Число(ТекущаяВерсия[Счетчик]) < ?(ПустаяСтрока(РекомендуемаяВерсия[Счетчик]), 0, Число(РекомендуемаяВерсия[Счетчик])) Тогда
            ВерсияПодходит = Ложь;
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    Если ВерсияПодходит И ТекущаяВерсия[2] > РекомендуемаяВерсия[2] Тогда
        ВерсияПодходит = Ложь;    
        НужноПредупреждение = Истина;
        НужноПрекратитьРаботу = Истина;
        ТекстРаботаБудетПрекращена = Символы.ПС + "Работа программы будет прекращена.";
    КонецЕсли;
    
    Если Это64Платформа Тогда
        ВерсияПодходит = Ложь;    
        НужноПредупреждение = Истина;
        НужноПрекратитьРаботу = Истина;
        ТекстРаботаБудетПрекращена = Символы.ПС + "Работа программы будет прекращена.";
        ТекстЭто64Платформа = " НЕ 64-bit !!!";
    КонецЕсли;
    
    Если ВерсияПодходит Тогда
        Возврат;
    КонецЕсли;
    
    Текст = "Для работы с конфигурацией требуется версия платформы 1С:Предприятие " +
        РекомендуемаяВерсияПлатформы() + " " + ТекстЭто64Платформа +
        Символы.ПС + "Используемая сейчас версия - " + СистемнаяИнформация.ВерсияПриложения + ?(Это64Платформа, " 64-bit !!!", "") + "." +
        ТекстРаботаБудетПрекращена +
        Символы.ПС +
        Символы.ПС + "Для получения новой версии платформы 1С:Предприятие воспользуйтесь диском Информационно-технологического сопровождения (ИТС) " +
        "или разделом сайта фирмы ""1С"" для пользователей: http://users.v8.1c.ru"; +
        Символы.ПС +
        Символы.ПС + "Если Вы не являетесь подписчиком диска ИТС, Вам необходимо оформить подписку.";    
    
    Если НужноПредупреждение Тогда
        Предупреждение(Текст);    
    Иначе
        Сообщить(Текст);    
    КонецЕсли;    
        
    Если НужноПрекратитьРаботу Тогда     
        ПрекратитьРаботуСистемы();
    КонецЕсли;    
            
КонецПроцедуры
   jsmith82
 
32 - 07.01.18 - 15:47
А это точно тип винды, а не 1с?
   Sam1C
 
33 - 07.01.18 - 15:48
(32) Ну я в (5) уточнял это.
 
 
   Sam1C
 
34 - 07.01.18 - 15:50
(33) Но судя по синтаксису помощнику это именно тип Винды, а не 1С:
ТипПлатформы (PlatformType)
Windows_x86_64 (Windows_x86_64)
Описание:

64-битная Windows.
--------------------------------------------------------------------------------

     Методическая информация
   jsmith82
 
35 - 07.01.18 - 15:52
(34) Я щас протестировал
Это тип платформы
   jsmith82
 
36 - 07.01.18 - 15:53
На виндовс сервер 2012 64-бит 32-битный тонкий клиент выдаёт тип платформы Windows x86
   Sam1C
 
37 - 07.01.18 - 15:53
(28) Даже такие ситуации не повод закрывать работу с программой в целом. Можно сделать отдельно клиентскую машину хоть под Win3.1 на которой будет отчетность на ВК и т.п.
   Sam1C
 
38 - 07.01.18 - 15:55
(36) Как определяете что тонкий клиент именно 32-х разрядный?
   jsmith82
 
39 - 07.01.18 - 15:57
А 64-битный тонкий клиент выдаёт Windows x86-64
   jsmith82
 
40 - 07.01.18 - 15:57
(38) В диспетчере задач смотрю
   jsmith82
 
41 - 07.01.18 - 16:01
Ну правильно, 32-битные проги же исполняются в виртуальной среде
   Sam1C
 
42 - 07.01.18 - 16:07
(41) Да тоже проверил если 1cv8 (32 бита) в 64 битной винде возвращает Windows x86. Т.е. разрядность исполняемых файлов. Но тогда вообще не понятна это проверка в конфигурации. От этого она еще бредовей становится
   jsmith82
 
43 - 07.01.18 - 16:13
64-битный клиент не так давно появился
   jsmith82
 
44 - 07.01.18 - 16:13
Надо код в типовой двойке посмотреть
   Sam1C
 
45 - 07.01.18 - 16:14
(42) Чем отличается 1cv8 (32 бита) от 1cv8 (64 бита) -тем что 1cv8 (64 бита) может использовать больше ОЗУ, но не может работать на x86. А 1cv8 (32 бита) в свою очередь совместим с ОС x64.
   Sam1C
 
46 - 07.01.18 - 16:15
(44) Если есть у кого последний релиз Бух.2.0 может глянуть если такой код в общем модуле. Может это не от франча идет, а и с самой 1С
   Sam1C
 
47 - 07.01.18 - 16:19
(46) Хоть чем может быть не совместим с точки зрения работы конфы 1cv8 (64 бита) с 1cv8 (32 бита). Еще можно как-то понять обратную не совместимость.
   art commander
 
48 - 07.01.18 - 16:28
(0) В 64 битной нет возможности распечатывать регламентированную отчетность. Ее, конечно, сейчас мало кто печатает, в основном передают в электронном виде. Но, я считаю, запасной вариант должен быть. Так что все правильно ребята сделали.
   art commander
 
49 - 07.01.18 - 17:01
(48) + видимо, в этом франче просто устали подвозить валерьянку бухгалтерам, пытающимся распечатать какую-нибудь декларацию по налогу на прибыль.
 
 Рекламное место пустует
   breezee
 
50 - 07.01.18 - 17:25
(49) + Видимо в этом франче бьют за комментарии в коде)
   Sam1C
 
51 - 08.01.18 - 07:22
(48) Во-первых: Правильно ребята делают, когда блокируется определенный функционал, а не вся программа. Типа "Нельзя запустить рег. отчетность так как...".
Во-вторых: Опытным путем доказано, что "СистемнаяИнформация.ТипПлатформы" - возвращает не разрядность ОС, а разрядность самой 1С. Так что теории об внешних компонентах и т. п. рассыпаются. Так как 1С будет 32-х битная, а ОС 64-битная при такой ситуации все запустится.
Тут все намного хитрее или глупея.
   patya
 
52 - 08.01.18 - 08:38
(51) Как же тебе хочется, чтобы франч неправ был...
"Ну вот ведь! А вот! Нет, вы только посмотрите!"
   Sam1C
 
53 - 08.01.18 - 08:42
(52) нет, совершенно пофиг на франч. мучает только вопрос "Для чего?" покоя не дает как заноза.
   Sam1C
 
54 - 08.01.18 - 08:45
(53) Поэтому и на форуме, может кто наведет на мысль
   DES
 
55 - 08.01.18 - 08:51
Может быть используют IE, с ним могут быть такие проблемы. Недавно сам мутил подобный код.
   AlexRu2015
 
56 - 08.01.18 - 09:22
(51) Как раз не рассыпается а подтверждается. У нас в обычной типовой рознице на 64 битной 1С не работают драйвера ККМ. Мы всем кто с ними работает устанавливаем 32бит клиента. При этом винда часто 64 бита.  Некоторые на сервере терминалов работают.
   DexterMorgan
 
57 - 08.01.18 - 09:30
Все не читал, задать вопрос (0) франчу уже было?
   Sam1C
 
58 - 08.01.18 - 09:51
(57) выходной был, сегодня вопрос будет задан
   art commander
 
59 - 08.01.18 - 10:02
(51) Чего хитрее, глупее? Рег. отчетность не печатается в 64-битной 1С. В 32-битной 1С на 64-битной ОС рег.отчетность печатается. Блокирование всей системы - правильное решение. Представь - у тебя сроки. Ты в полной уверености, что все в порядке. Система же работает. Пытаешься напечатать отчет - облом. Времени уже нет. Штраф. Правда здорово?
   NorthWind
 
60 - 08.01.18 - 10:44
(59) Человек дело говорит. Разумнее (и не сильно сложнее) было бы просто при старте дать сообщение, что функции такие-то и такие-то на данной платформе будут недоступны.
   Sam1C
 
61 - 08.01.18 - 10:48
Позвонил во франч. переключили на сис. админа их, который пошел уточнять у программистов и сказал, что какие-то ком-объекты не работают. На вопрос какие именно и почему нужно было рубить с плеча пошел опять уточнять и сказал, что перезвонят
   Sam1C
 
62 - 08.01.18 - 10:56
тут еще момент на одном сервере висит УТ 11, для которой наверняка 64 битный клиент лучше и куча бухгалтерий. Вопрос на одном сервере вместе можно установить 64 битного и 32-битного клиента?
   Sam1C
 
63 - 08.01.18 - 10:58
Ответ от франча: "Мы 64 битного клиента не тестировали, поэтому нам проще его отрубить, чтобы клиенты не звонили с жалобами на ошибки"!
   bodri
 
64 - 08.01.18 - 11:53
(64) хороший ответ
   bodri
 
65 - 08.01.18 - 11:53
(64) к (63)
   art commander
 
66 - 08.01.18 - 12:00
(60) Ага, а потом объяснять заказчику, почему он попал на штраф.
   Сияющий Асинхраль
 
67 - 08.01.18 - 12:05
(63) Правильный ответ. Не можешь отвечать за предоставленный функционал - не предоставляй его...
   jsmith82
 
68 - 08.01.18 - 12:22
(62) Да
   Sam1C
 
69 - 08.01.18 - 12:28
(68) спс
   DrZombi
 
70 - 08.01.18 - 12:52
(66) 1С всегда плевал на массы, так что вся эта проверка от лукавого. Обычно 1С вообще не заботило, что кто-то что-то не сдал из-за свой жадности на собственного программиста :)
   DrZombi
 
71 - 08.01.18 - 12:54
(63) Ага, и рубануть с плеча, а не с регламентных, выводя при этом внятное сообщение, что дескать не может что-то там печататься :)

Узнай об этом, бухи бы уже весь мозг программисту выели, но добились бы печати по вынем 64 :)
   nordbox
 
72 - 08.01.18 - 13:07
(63) Шикарно ))) просто супер
   NorthWind
 
73 - 08.01.18 - 14:46
(66) с каких это пор фирма-разработчик отвечает за штрафы и недополученную прибыль? Никогда такого не было. Не нравится - не юзай, могут вернуть деньги за копию. На этом их ответственность кончается, все остальное исключительно на пользователе.
   dmpl
 
74 - 08.01.18 - 18:01
(59) Для ларька может и подходит логика, но для нормального бизнеса штрафы могут быть меньше убытков за 1 час простоя.
   NorthWind
 
75 - 08.01.18 - 18:13
(71) интересно, что именно там под 64 битами не живет... Приходит в голову только печать 2D кодов на декларациях, там Aztec, кажется, или какой-то подобный код ФНС использует.
   mistеr
 
76 - 08.01.18 - 18:59
(67) Прикол в том, что проверку вставили только недавно. Что с (63) не очень вяжется.
   nordbox
 
77 - 08.01.18 - 19:54
(76)>>Прикол в том, что проверку вставили только недавно.
Один из них врет
Либо франча лишили франча и он пытается остаточное бабло срубить по другому, или свои билиОтики прицепили рукотворные
Либо что то тут не то говорит (0)
   Sam1C
 
78 - 09.01.18 - 09:35
(77) В смысле не то говорит??? Вышел новый релиз от франча декабря 2017, где была вставлена эта проверка, в ноябрьском не было этого. Очень удивился этому, на форуме задал вопрос, кто с таким может сталкивался. Выложен код на форуме и ответ от франча.
   Sam1C
 
79 - 09.01.18 - 09:43
(76) По мне с таким ответом франча все вяжется. Какой-нибудь клиент наткнулся на древний Ком-объект вылетели ошибки и вместо того чтобы разобрать ситуацию решили просто рубануть 64- битного клиента.
На попытки уточнения какие именно ком-объекты или с каким функционалам связаны, ответили "какие-то". Чем бодаться решили проще поставить дополнительно 32-х битного клиента.
   DrZombi
 
80 - 09.01.18 - 09:46
(79) смени франчайзи :)
   MrStomak
 
81 - 09.01.18 - 10:10
(0) Тебе сложно х32 1с запускать? Бухгалтерия 2.0 упирается в доступную процессу память? О чем вообще разговор?

По-моему, всё очевидно. Франч добавил функциональность, завязал часть её на ВК (для защиты или для других целей - неважно), посыпались жалобы, что "у нас перестало работать", они выяснили, что проблема в х64 клиенте и поставили проверку.

Почему так пригорает то?
   ИТ директор
 
82 - 09.01.18 - 10:22
франч маст дай
   Asmody
 
83 - 09.01.18 - 10:43
Там 32bit ВК, которая койны майнит.
   Starhan
 
84 - 09.01.18 - 10:55
(0) эдо вродь (из-за крипто про ) не работает если 64 битная версия.
   dmpl
 
85 - 09.01.18 - 11:08
(81) Посмотри как делает 1С при работе на старой платформе. Что мешало франчу сделать так же?
   Dmitrii
 
86 - 09.01.18 - 11:36
(79) Это у тебя есть куча времени сидеть трындеть на форумах, "разбирать суитации и выяснять какие ком-объекты с каким функционалом связаны".
У франча, занимающегося разработкой, как правило, такого ресурса нет.
При первом или втором обращениях от клиентов с проблемой её пытаются решить (если есть кому). Если обращений становится много по различным ком-объектам (у каждого клиента свои погремушки), то принимается решение, описанное в (63). И это, ИМХО, правильно. Даже если сама проблема не связана с конкретной конфигурацией. Тут на форуме уже было предостаточно веток о проблемах 64-хбитного клиента. Как правило, проще действительно поставить 32-битку.
Хотя я бы лично на месте франча поступил бы гибче, отделавшись каким-нибудь информационным письмом о возможных проблемах и инструкцией хелпдескерам - что говорить клиентам.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует