Вход | Регистрация

1С:Предприятие ::

Метки: 

Поле объекта не обнаружено (Объект) ДанныеФормы = Форма.Объект;

Я
   zoro-z
 
03.01.18 - 14:09
Пытаюсь открыть форму не сохраненного документа, выскакивает ошибка.
Раньше работало.
Бухгалтерия 3.1 

&НаКлиенте
Процедура СоздатьДокументТовары()
    Форма = ПолучитьФорму("Документ.ВводНачальныхОстатков.ФормаОбъекта");
    ДанныеФормы = Форма.Объект;
    ЗаполнитьДокументНаСервере(ДанныеФормы);
    КопироватьДанныеФормы(ДанныеФормы, Форма.Объект);
    Форма.Открыть();
КонецПроцедуры

&НаСервере
Функция ЗаполнитьДокументНаСервере(ДанныеФормы);

    Док = ДанныеФормыВЗначение(ДанныеФормы, Тип("ДокументОбъект.ВводНачальныхОстатков"));
    Док.РазделУчета = Объект.РазделУчета;
    //Для каждого НоваяСтрока Из Объект.ТабличнаяЧасть Цикл

    //    //СтрДок = Док.Товары.Добавить();

    //    //СтрДок.Количество = Стр.Количество;

    //    //СтрДок.Номенклатура = Стр.Номенклатура;

    //    НоваяСтрока = Док.НоменклатураНаСкладе.Добавить();

    //    //НоваяСтрока.НомерСтрокиТЧ  = НомСт;

    //    НоваяСтрока.СчетУчета = ПланыСчетов.Хозрасчетный.ТоварыНаСкладах;

    //    НоваяСтрока.Номенклатура = НоваяСтрока.Номенклатура;

    //    

    //КонецЦикла;

    
    ЗначениеВДанныеФормы(Док,ДанныеФормы);

КонецФункции
 
 
   Рэдрик Шухарт
 
1 - 03.01.18 - 14:14
Поставь точку останова на 
ДанныеФормы = Форма.Объект;

И в табло удивись что у тебя там в ДанныеФормы
   zoro-z
 
2 - 03.01.18 - 14:34
Всем спасибо, проблему нашел. Не указал вид учета.

    ЗначенияЗаполнения = Новый Структура();
    ЗначенияЗаполнения.Вставить("РазделУчета", Объект.РазделУчета);
    Форма = ОткрытьФорму("Документ.ВводНачальныхОстатков.ФормаОбъекта", Новый Структура("ЗначенияЗаполнения", ЗначенияЗаполнения));
    ДанныеФормы = Форма.Объект;


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует