Вход | Регистрация

1С:Предприятие ::

Метки: 

ошибка создания менеджера объектов слк

Я
   craxx
 
03.01.18 - 08:06
1С: Управление МФО и КПК.
При запуске возникает ошибка менеджера лицензий: Ошибка при вызове конструктора (Двоичные данные). Каталог не обнаружен. Путем отладки выяснилось, что объект МенеджерЛицензий.МенеджерОбъектов после запуска МенеджерЛицензий пустой, точнее "ошибка чтения значения"

// Создание объекта 

    МенеджерЛицензий = Новый("AddIn.Licence.LicenceExtension20");
    
    // Запуск

    ПараметрыСвязи = БНФОЛицензирование.ПолучитьПараметрыСвязиССерверомЛицензирования();
    МенеджерЛицензий.ОкноУстановкиСвязи = Ложь;
    МенеджерЛицензий.ПараметрыСвязи = ?(ЗначениеЗаполнено(ПараметрыСвязи), ПараметрыСвязи, "host=localhost;port=9099");
    Если НЕ МенеджерЛицензий.Запуск(БНФОЛицензирование.Серия(), БНФОЛицензирование.ТолькоНаличиеКлюча()) Тогда
        ВызватьИсключение МенеджерЛицензий.ПолучитьОписаниеОшибки();
    КонецЕсли;
    
    Защита = Неопределено;
    // Обход ошибки обычного приложения

    Если ТекущийРежимЗапуска() <> РежимЗапускаКлиентскогоПриложения.ОбычноеПриложение Тогда
        Попытка
            Защита = Новый ("ОписаниеЗащитыОтОпасныхДействий");
            Защита.ПредупреждатьОбОпасныхДействиях = Ложь;
        Исключение
            // Исключение возможно на предыдущих версиях платформы без механизма

            // защиты от опасных действий

            Инфо = ИнформацияОбОшибке();
            Текст = "Ошибка создания менеджера объектов СЛК с защитой от опасных действий.
            |
            |" + Инфо.Описание;
            ЗаписьЖурналаРегистрации("Лицензирование.СозданиеМенеджераОбъектов", УровеньЖурналаРегистрации.Ошибка,,, Текст);
        КонецПопытки;
    КонецЕсли;
    
    // Создание менеджера объектов

    Попытка
        
        Если Защита = Неопределено Тогда
            // Предыдущие версии платформы без механизма защиты

            МенеджерОбъектов = ВнешниеОбработки.Создать(МенеджерЛицензий.МенеджерОбъектов, БезопасныйРежим());
        Иначе
            МенеджерОбъектов = ВнешниеОбработки.Создать(
                ВнешниеОбработки.Подключить(
                    ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(МенеджерЛицензий.МенеджерОбъектов)), , БезопасныйРежим(), Защита));
        КонецЕсли;
                
        // Настройка менеджера объектов

        
        МенеджерОбъектов.УстановитьМенеджерЛицензий(МенеджерЛицензий, Защита);
    Исключение
        ВызватьИсключение "Ошибка создания менеджера объектов СЛК: " + ОписаниеОшибки();
    КонецПопытки;

Где копать?
 
  Рекламное место пустует
   craxx
 
1 - 03.01.18 - 09:22
короче решилось перезагрузкой сервера. Проблема ушла. Не знаю что было.


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует