Вход | Регистрация


Программное добавление кнопки

Программное добавление кнопки
Я
   Sem0709
 
30.12.17 - 18:53
Всех с наступающим!

Открываю обработку, в событии перед открытием обработки открываю форму списка регистра предварительно добавив на неё кнопку, закрываю обработку. Форма регситра открывается, кнопка добавляется, но почему-то неактивна. Доступность = истина делал.

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    
    ФормаРС = РегистрыСведений.ЕГАИС_РеализованныеАкцизныеМарки.ПолучитьФормуСписка("ФормаСписка");
    
    КоманднаяПанель = ФормаРС.ЭлементыФормы.ДействияФормы;
    КоманднаяПанель.Кнопки.Добавить("КоличествоЗаписей", ТипКнопкиКоманднойПанели.Действие,, Новый Действие("ПосчитатьЗаписи"));
    
    Если ФормаРС.Открыта() Тогда
        ФормаРС.Активизировать();
    Иначе
        ФормаРС.Открыть();
    КонецЕсли; 
    
КонецПроцедуры

Процедура ПриОткрытии()
    
    ЭтаФорма.Закрыть();
    
КонецПроцедуры

Процедура ПосчитатьЗаписи()
    
    Сообщить("Тест пройден");
    
КонецПроцедуры
 
 
   mehfk
 
1 - 30.12.17 - 19:08
Не получится назначить в кнопке из сторонней формы действие из текущей формы.
   Sem0709
 
2 - 30.12.17 - 19:16
Ааа, если бы процедура в открываемой форме была... ясно, обойдусь как нить.

Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует