Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

1с передача текста запроса в http-service, возврат рузультат в json?

1с передача текста запроса в http-service, возврат рузультат в json?
Я
   milofaq
 
29.12.17 - 14:15
ривет, нашел в инте такой http сервис под 1с. Робочий.

Функция mainGet(Запрос)
  Ответ = Новый HTTPСервисОтвет(200);
  Если НРЕГ(Запрос.ПараметрыЗапроса.Получить("action")) = "getusers" Тогда
    Ответ.УстановитьТелоИзСтроки(ВернутьСписокПользователей());
  КонецЕсли;
  Возврат Ответ;
КонецФункции
Функция ВернутьСписокПользователей()
  Запрос = Новый Запрос;
  Запрос.Текст =
  "ВЫБРАТЬ
  |    Пользователи.Ссылка
  |ИЗ
  |    Справочник.Пользователи КАК Пользователи";
  Выборка = Запрос.Выполнить().Выбрать();
  ОтветМассив = Новый Массив;
  Пока Выборка.Следующий() Цикл
    ОтветМассив.Добавить(Новый Структура("name,id",Выборка.Ссылка.Наименование,""+Выборка.Ссылка.УникальныйИдентификатор()));
  КонецЦикла;
  
  Ответ = Новый ЗаписьJSON;
  Ответ.УстановитьСтроку();
  ЗаписатьJSON(Ответ,ОтветМассив);// сериализует ОтветМассив в формат JSON

  Возврат Ответ.Закрыть();
КонецФункции

Но нужно модифицирвать так, чтоб текст лобого!!! запроса я передавал в параметре запроса, а он мне б возвращал результат в json (ето какби консоль запросов через rest)
Сам не програмист 1с, только java/c#
 
 
   Вафель
 
1 - 29.12.17 - 14:16
делай только через put
   sapphire
 
2 - 29.12.17 - 14:40
(1) GET
   xxTANATORxx
 
3 - 29.12.17 - 14:43
(0)ниразу не безопасен такой сервис
   sapphire
 
4 - 29.12.17 - 15:23
(3) кладем базу по http :)
   Lexey_
 
5 - 29.12.17 - 15:29
(0) используй
http://v8.1c.ru/o7/201312rest/
   Вафель
 
6 - 29.12.17 - 15:30
(3) можно логин-пароль спрашивать
   milofaq
 
7 - 29.12.17 - 16:33
put ето да(на фронтенде jquery поможет) , но как модифичитровать код 1с чтоб он принимал строку запроса, и возвражал строку ответв в формате json

по безопасности все разрулит iptables и file2ban (не тема вопроса) (3) 

rest встроений не подходит (я не 1с програмист) строить модель метаданих -> куди ссилаютса поля типа ссилка ето ваще не вариант.

Вот есть примерно то что нужно(SOAP) принимает строку запроса
и возвращает таблицу  http://sikuda.ru/archives/22
но мне нужен json а не таблица
   Вафель
 
8 - 29.12.17 - 16:57
Запрос.Текст = ЗапросНТТР.ПараметрыЗапроса.Получить("QueryrText")
   Неверный Параметр И
 
9 - 29.12.17 - 17:15
(0) Не зря у вас там 1С запретили, ох не зря.
   Неверный Параметр И
 
10 - 29.12.17 - 17:19
Сколько там у явистов в Кияве оклад? Ну ок, 71000 гривень и золотой ключик ваш, т-щ "не 1с программист".
 
 Рекламное место пустует
   milofaq
 
11 - 29.12.17 - 17:30
не запретили, только некоторих диллерских фирм.
а все укр консалтинговие 1с фирми(интегратори) работают в штатном режиме.

правда єсть прблема , большой одток прогеров c 1c в java/.net
1 час работи 1с програмиста 25$

java/.net 
jun 300-1000 $
mid  1000-2300 $
sen 2300-3800 $
   Лефмихалыч
 
12 - 29.12.17 - 21:07
(0) ты уже придумал, как ты будешь преобразовывать на стороне 1С в json результат произвольного запроса? Ведь он может быть любым. Более того, переданный запрос может быть пакетным и тогда надо несколько таблиц в json заворачивать.
   Лефмихалыч
 
13 - 29.12.17 - 21:08
(11) прикольно сравнивать стоимость часа и стоимость месяца. Результаты ошеломительные получаются
   Юрий Лазаренко
 
14 - 29.12.17 - 22:03
(13) Стоимость часа и месяца сравнивать нельзя.
   Неверный Параметр И
 
15 - 29.12.17 - 22:09
А вот интресно, каково это - жить рядом со стеной с Мордором и просить тамошних жителей о помощи?
http://ipic.su/img/img7/fs/milofaq.1514574216.png
   Лефмихалыч
 
16 - 29.12.17 - 22:39
(14) это в РФ нельзя, а на Украине, видимо, можно
   Лефмихалыч
 
17 - 29.12.17 - 22:40
+ (16) там у них свобода, там всё можно. ЭТо у нас тут... эх...
   Адинэснег
 
18 - 30.12.17 - 08:57
рузультат
ривет
инте
Робочий
лобого
ето
какби
java/c# ... ну ну, джавист куев, передающий текст запроса get'ом
 начни с русского
   Адинэснег
 
19 - 30.12.17 - 09:04
(11)>> mid  1000-2300 $

https://hh.ua/search/vacancy?text=Middle+Java+Developer&area=5
1700-3500 в месяц

украинские мидлы работают 2-3 часа в месяц, красавцы
   milofaq
 
20 - 30.12.17 - 12:03
до Неверный - ти наверное придумал что "линии разграничения" ето линия граници укр-рос :) будь внемателен.
ну вот по 1с нечево не сказал зато вопрос развернул "а че там у хохлов".

до Адинэснег по рус. плохо говорю и ужасно пишу потому что никогда его не изучал (зап укр). Но не ви***сь  спришиваую на рус. как умею

В РФ такиеже есть хорошие и плохие люди как в укр. и в других странах не тема разговора.

3500 в месяц. почему ето 2-3 часа в месац. 3500$/26дней=135$ в день, ну или 135$/8часов = 17$в час.

просто сколько в месац 1с синйор зараб. я не знаю.   но знаю сколько за час берут. вот и на нес приблизит. пример по ЗП

до Лефмихалыч вот как то на soap-e ето решили http://catalog.mista.ru/public/167093/
   Лефмихалыч
 
21 - 30.12.17 - 13:42
(20) >вот как то на soap-e ето решили
ответь на вопрос: что должно в жсоне быть там, где запрос вернет ссылочный тип? Как только ответишь, так тут же бери код из приведенной тобой же ссылки и бери и делай:
https://i.imgur.com/PLull1G.png

От форума-то ты чего ждешь?

По поводу ЗП тебя макают за то, что ты сравнил $25 в час у одинэсника _без уточнения, что то за спец, с $300-$3800 в месяц у трех разных специалистов
   Kigo_Kigo
 
22 - 30.12.17 - 13:53
ТС вот скачай и переделай как тебе надо
https://yadi.sk/i/V43GIczU3R7JLk
   milofaq
 
24 - 30.12.17 - 13:58
спасибо за помощь и лояльность. когда буду иметь на 100% рабочий код - поидлюся.

интерактивные отчеты директору на мобилу это всегда повод для премии, или повышения зарплаты
   Юрий Лазаренко
 
25 - 30.12.17 - 14:32
(24) Интерактивные отчеты лучше не так делать. Не надо отправлять текст запроса, надо отправлять тип требуемого отчета и его параметры. А в обратку можно сразу готовый html кидать, это же отчеты, их не так часто будут юзать, чтобы надо было заморачиваться на производительности. Результат выполнения запроса конвертнуть в html - это три строчки кода.
   Лефмихалыч
 
26 - 30.12.17 - 16:06
(25) +100500
вообще, со своими запросами в чужую базу лазить - глупость и быдлокод
   milofaq
 
27 - 01.01.18 - 03:10
(25) их надо часто юзать, каждий день на iphon-e .
Результат в html - я више уже делился ссилкой http://sikuda.ru/archives/22 ето не совсем подходит.
Я з json-a смогу диаграмки построить итд....

(26) в том то и сахар не випаришивать аутсорс компанию каждих пару дней доделать/переделать запрос за 25$ в час.
База не чужая , я штатний единствениий ІТ-шник.
   craxx
 
28 - 01.01.18 - 10:32
(27) Позови программиста 1С. Вот прикинь тебе аппендицит будет окулист удалять, под предлогом того что он единственный врач в больнице
   MrStomak
 
29 - 01.01.18 - 11:49
(27)
Буква "ы" у вас законодательно запрещена?
   Неверный Параметр И
 
30 - 01.01.18 - 12:43
(27) мой милый западэнец, ты от форума-то что хочешь?
Чтобы тебе сэкономили 25$ в час и написали за тебя? Чтобы тебя научили языку 1С?

Если верить гугле, то ты пасешься в русскоязычном сегменте с 2009 года. Восемь лет. И за эти восемь лет ты не удосужился научиться грамматике и орфографии языка, на котором просишь помощи. Спасибо тебе за подобное отношение.

Впрочем, тебе уже даже картинкой в (21) ответ нарисовали.
   craxx
 
31 - 01.01.18 - 13:01
(29) декоммунизирована
   NorthWind
 
32 - 02.01.18 - 16:14
(29) ее просто нет в украинском алфавите и на клавах соответственно тоже.
   Неверный Параметр И
 
33 - 02.01.18 - 17:07
(32) И как же они на 1С пишут-то? На английском?
 
 
   Юрий Лазаренко
 
34 - 02.01.18 - 18:57
(27) Для 1С "часто" - это 200-300 запросов в секунду. А ваши 20 отчетов в день для нее это семечки.
И неважно, html вам нужен или json, не надо передавать текст запроса в параметрах. Кстати, 1С может и диаграммы формировать, и возвращать их в виде svg. Это уже входит в те самые 3 строчки кода.
   Юрий Лазаренко
 
35 - 02.01.18 - 18:58
(33) Там автоподстановка помогает.
   Юрий Лазаренко
 
50 - 03.01.18 - 10:42
(49) Давай я тебя забаню за флуд.
   NorthWind
 
51 - 04.01.18 - 10:46
(33) или так, или подстановкой пользуются. Чисто на украинской раскладке не получится без ошибок. Если без Й и Ё обойтись еще можно, то без Ы и Э уже сложнее.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует