Вход | Регистрация

1С:Предприятие ::

Метки: 

Как сделать в запросе отбор по всем пустым значениям

Я
   Ivan_495
 
29.12.17 - 13:51
Как сделать в запросе отбор по всем пустым значениям ВидыСубконтоХозрасчетные? как правильно написать?

где
Субконто1 в(ЗНАЧЕНИЕ(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПустаяСсылка))
 
  Рекламное место пустует
   Ivan_495
 
1 - 29.12.17 - 13:52
где
Субконто1 в(ЗНАЧЕНИЕ(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПустаяСсылка))
это строчка из запроса
   Nuobu
 
2 - 29.12.17 - 13:54
Собрать запрос.
   hhhh
 
3 - 29.12.17 - 14:48
(1) вот это

где
Субконто1 в(ЗНАЧЕНИЕ(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПустаяСсылка)) 

выкиньте, это предновогодний бред. Всё остальное можно.
   Ivan_495
 
4 - 29.12.17 - 16:19
(2) сейчас собираю пустые значения всех типов субконто в цикле, думал можно оптимизировать

Функция ПолучитьСписокПустыхСубконто(ВидыСубконто)Экспорт
    
сзПустыеСубконто = Новый СписокЗначений;
    
    ВыборкаСубконто = ВидыСубконто.Выбрать();
    
    Пока ВыборкаСубконто.Следующий() Цикл
        ТекЗначение = Неопределено;
        Для каждого ТекущийТип Из выборкаСубконто.ТипЗначения.Типы() Цикл
            Если ТекущийТип = Тип("Строка") Тогда
                ТекЗначение = "";
            ИначеЕсли ТекущийТип = Тип("Число") Тогда
                ТекЗначение = 0;
            ИначеЕсли ТекущийТип = Тип("Дата") Тогда
                ТекЗначение = '00010101';
            Иначе
                ТекЗначение = Новый(ТекущийТип);
            КонецЕсли;
        КонецЦикла; 
        сзПустыеСубконто.Добавить(ТекЗначение);
        сзПустыеСубконто.Добавить(выборкаСубконто.ТипЗначения.ПривестиЗначение());

    КонецЦикла;
    сзПустыеСубконто.Добавить(Неопределено);
    Возврат сзПустыеСубконто; 

    
КонецФункции 


Запрос.УстановитьПараметр("ПустоеСубконто",    ПолучитьСписокПустыхСубконто(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные));
   Вафель
 
5 - 29.12.17 - 17:04
субконто1 в (&Массив)

Массив.Добавить(Неопредлено);
Массив.Добавить(ПустаяДата);
Массив.Добавить(ПустаяСтрока);
...
Массив.Добавить(ПустаяСсылкаСпр1);
...
   Вафель
 
6 - 29.12.17 - 17:05
Хотя даты и строки не бывают в качестве субконто
   breezee
 
7 - 29.12.17 - 18:00
Когда уже в запрос прикрутят "ЗначениеЗаполнено()"
   youalex
 
8 - 29.12.17 - 21:12
(7) лучше binary как литерал
   Armando
 
9 - 29.12.17 - 22:40
Если на производительность пофиг, то можно сделать

ГДЕ Субконто1.Ссылка ЕСТЬ NULL
   h-sp
 
10 - 30.12.17 - 00:38
(4) пишите

где
Субконто1 = Неопределено

в типовых сделано при записи, чтобы пустых ссылок не было
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует