Вход | Регистрация


Проблема с передачей реквизитов в форму нового объекта

Проблема с передачей реквизитов в форму нового объекта
Я
   Блондинка_
 
28.12.17 - 14:39
Добрый день! Я наверное что-то неправильно делаю по логике клиент/сервер, но запуталась совсем не получается.
Нестандартная конфа на УФ, из заказа открывается форма создания нового контрагента. При открытии формы из заказа передаю параметры Имя и телефон. Далее при создании на серевере Объект.Имя = Имя и Объект.Телефон = телефон. Но на форме ничего не отображается(( хотя элементы.Телефон.ТекстРедактирования - там все есть
 
 
   Timon1405
 
1 - 28.12.17 - 14:43
код открытия формы и процедуру ПриСозданииНаСервере покажете?
   Блондинка_
 
2 - 28.12.17 - 14:49
Это в документе заказ
Структура("ТипГосНомера, ГосНомер, ТекущийРодитель, Клиент,Наименование,Телефон",АвтомобильТипГосНомера, СтрЗАменить(АвтомобильГосНомер, " ", ""), ГруппаКлиентов, Объект.Клиент,ИмяКлиента,ТелефонКлиента);
        ФормаКлиента = ПолучитьФорму("Справочник.Контрагенты.Форма.ФормаЭлементаКлиентБыстрыйВвод", СтруктураПараметров, ЭтаФорма);
        ФормаКлиента.ОткрытьМодально();
        
Это при создании на серевере в форме клиента

    Если Параметры.Свойство("ГосНомер") Тогда        
         АвтомобильГосНомер=Параметры.ГосНомер;
    КонецЕсли;
    
    Если (Параметры.Свойство("ТекущийРодитель")) И (НЕ ЗначениеЗаполнено(Объект.Ссылка)) Тогда// это новый, тогда заполним родителя

        Объект.Родитель = Параметры.ТекущийРодитель; 
        ГруппаКлиентов = Параметры.ТекущийРодитель;
        Элементы.Родитель.Видимость = Ложь;
    КонецЕсли;                                          
    
    Если Параметры.Свойство("Клиент") Тогда
        ВладелецАвтомобиля = Параметры.Клиент;
    КонецЕсли;
    
    Если Параметры.Свойство("Телефон") Тогда
        Объект.Телефон  = Параметры.Телефон;
    КонецЕсли;
    
    Если Параметры.Свойство("Наименование") Тогда
        Объект.Наименование  = Параметры.Наименование;
    КонецЕсли;
   Darych
 
3 - 28.12.17 - 14:58
"Это в документе заказ 
Структура("ТипГосНомера, Го..."
СтруктураПараметров = Структура("ТипГосНомера, Го... ??
   Timon1405
 
4 - 28.12.17 - 15:13
(2) используйте ОткрытьФорму()
http://catalog.mista.ru/public/236382/
   LienXo
 
5 - 28.12.17 - 16:08
Если имена анологичны параметрам почему не используете 
Заполнять из значений? Не надо будет 

Если Параметры.Свойство("Телефон") Тогда         Объект.Телефон  = Параметры.Телефон;     
КонецЕсли;

На форме точно отображается элемент Телефон связанный с реквизитом Объект.Телефон?
   ribuh
 
6 - 28.12.17 - 16:51
Возможно не совпадают типы...отладчик чётко покажет косяк...
   LeoKeyn
 
7 - 28.12.17 - 17:36
(2) ПриСоздании НаКлиенте попробуй.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует