Вход | Регистрация

1С:Предприятие ::

Метки: 

Не передаются параметры формы

Я
   Dmitri446
 
26.12.17 - 16:03
&НаКлиенте
Процедура МояПроцедура()
ЗначенияЗаполнения = Новый Структура();
ЗначенияЗаполнения.Вставить("Поле",Объект.Поле1)
ПараметрыФормы = Новый Структура("ЗначенияЗаполнения", ЗначенияЗаполнения);
ОткрытьФорму(Форма,ПараметрыФормы);
КонецПроцедуры


на строке "ОткрытьФорму" Выдает ошибку: Несоответствие типов параметр номер 2
 
  Рекламное место пустует
   Dmitri446
 
1 - 26.12.17 - 16:06
Вот полный код


&НаКлиенте
Процедура МояПроцедура()
Форма = ПолучитьФорму("Справочник.Журнал.Форма.ФормаЭлемента",);
ЗначенияЗаполнения = Новый Структура();
ЗначенияЗаполнения.Вставить("Поле",Объект.Поле1)
ПараметрыФормы = Новый Структура("ЗначенияЗаполнения", ЗначенияЗаполнения);
ОткрытьФорму(Форма,ПараметрыФормы);
КонецПроцедуры
   НеБорисНуралиев
 
2 - 26.12.17 - 16:24
Читайте синтаксис-помощник внимательнее.
Вариант синтаксиса: По форме

Синтаксис:

ОткрытьФорму(<Форма>, <Окно>)
Параметры:

<Форма> (обязательный)

Тип: Форма; УправляемаяФорма.
Форма или управляемая форма. В режиме тонкого и веб-клиентов только управляемая форма. 
<Окно> (необязательный)

Тип: ОкноКлиентскогоПриложения. 
Окно приложения, в котором будет открыта форма.
Применимо только для управляемой формы. Окном может быть только основное окно приложения или вспомогательное окно формы.
   Dmitri446
 
3 - 26.12.17 - 16:25
(2) Так там есть и другой вариант где второй параметр это структура. как мне его использовать?
   Lexey_
 
4 - 26.12.17 - 16:25
(3) ОткрытьФорму(<ИмяФормы>, <Параметры>....)
   Dmitri446
 
5 - 26.12.17 - 16:27
(4) А в моем коде что не так?
   НеБорисНуралиев
 
6 - 26.12.17 - 16:27
(3) ОткрытьФорму("Справочник.Журнал.Форма.ФормаЭлемента",ПараметрыФормы);
   Dmitri446
 
7 - 26.12.17 - 16:27
Даже если сделать так:
ОткрытьФорму(Форма,ПараметрыФормы, Владелец);

Один фиг та же ошибка
   Lexey_
 
8 - 26.12.17 - 16:27
(5) первый параметр
   silent person
 
9 - 26.12.17 - 16:28
&НаКлиенте

Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

 

СсылкаНаПоставщика = ПолучитьПоставщикаНаСервере();

ЭлементыОтбора = Новый Структура("Поставщик", СсылкаНаПоставщика);

ПараметрыФормы = Новый Структура("ЗначенияЗаполнения", ЭлементыОтбора);

ОткрытьФорму("Документ.Накладная.ФормаОбъекта", ПараметрыФормы);

 

КонецПроцедуры
   ejikbeznojek
 
10 - 26.12.17 - 16:31
(0) Это вы попытались применить смесь 2х вариантов этой команды

Вариант синтаксиса: По названию
Синтаксис:
ОткрытьФорму(<ИмяФормы>, <Параметры>,

и

Вариант синтаксиса: По форме
Синтаксис:
ОткрытьФорму(<Форма>, <Окно>)
 
  Рекламное место пустует
   ejikbeznojek
 
11 - 26.12.17 - 16:32
(10) + соотвественно 1С по первому параметру решила, что это вариант синтаксиса "по форме" и ждала во 2м параметре окно, а не структуру
   Dmitri446
 
12 - 26.12.17 - 16:33
Понял, всем спасибо!


Список тем форума
 
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует