Вход | Регистрация

1С:Предприятие ::

Метки: 

Поле объекта не доступно для записи.

Я
   AlexMee
 
26.12.17 - 11:07
Процедура КнопкаВыполнитьНажатие(Кнопка)
    Регистр = РегистрыСведений.СвойстваПозицииШтатногоРасписания.СоздатьНаборЗаписей();
    Регистр.Прочитать();
    Для Каждого Запись из Регистр Цикл
        //а = Запись.ПолучитьОбъект();

        Если Запись.Период <= Дата("20171116") Тогда
    Запись.УсловияТруда.Наименование = Справочники.УсловияТруда.НайтиПоКоду(000000001);
Иначе
    Запись.УсловияТруда.Наименование = Справочники.УсловияТруда.НайтиПоКоду(000000002);
КонецЕсли;
КонецЦикла;
    Регистр.Записать(Ложь);
КонецПроцедуры
 
 
   AlexMee
 
1 - 26.12.17 - 11:07
как записать??
   RomaH
 
2 - 26.12.17 - 11:08
Запись.УсловияТруда - ссылка
   RomaH
 
3 - 26.12.17 - 11:08
получить объект сначала
   AlexMee
 
4 - 26.12.17 - 11:09
(2) ссылка на справочник "условия труда"
   RomaH
 
5 - 26.12.17 - 11:09
Запись.УсловияТруда.Наименование = Справочники.УсловияТруда.НайтиПоКоду(000000002);

Ты строке в ссылке присваиваешь ссылку
все попутал
   RomaH
 
6 - 26.12.17 - 11:09
(4) я понимаю
   RomaH
 
7 - 26.12.17 - 11:09
должен быть объект
   RomaH
 
8 - 26.12.17 - 11:09
но "Наименование" - это строка
   RomaH
 
9 - 26.12.17 - 11:10
Запись.УсловияТруда= Справочники.УсловияТруда.НайтиПоКоду(000000001)

вот так
   RomaH
 
10 - 26.12.17 - 11:11
(0) но с такими знаниями ты полез в ЗУП 3.0 ?
 
 Рекламное место пустует
   AlexMee
 
11 - 26.12.17 - 11:12
(9) "Б" бро
"Б" Благодарность)
   RomaH
 
12 - 26.12.17 - 11:12
Справочники.УсловияТруда.НайтиПоКоду(000000001);
запрос в цикле
вынеси определение переменной за цикл


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует