Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1С.Мобильное приложение. Встроенные покупки

1С.Мобильное приложение. Встроенные покупки
Я
   soleg78
 
22.12.17 - 19:10
Добрый день
Интересует вопрос работы встроенных покупок в Мобильном приложении 1С 
Разработку провожу на платформе 8.3.10.2580, мобильную платформу использую 8.3.10.51
Создал чистою конфигурацию. Назначение использования: Мобильное приложение
Установил только одно требуемое разрешение «Встроенные покупки»
В Google Play Console – Все приложения – [Мое приложение] – Настройки страницы приложения – Контент для продажи
Создал  контент для продажи с идентификатором «1qaz2wsx3edc4rfv5tgb6yhn7ujm» (придумал от фонаря)
Создал форму, в ней прописал команду
&НаКлиенте
Процедура Команда1(Команда)
    #Если МобильноеПриложениеКлиент Тогда

          ОбработчикЗакрытия = Новый ОписаниеОповещения("ОбработкаЗакрытиПокупки", ЭтаФорма);
        Идентификатор = "1qaz2wsx3edc4rfv5tgb6yhn7ujm";
        ВстроеннаяПокупка =Идентификатор;
        ВП = ВстроенныеПокупки;
        Если ВП.ПоддерживаютсяПокупки() Тогда 
            ОплатаПроизведена =ВП.НачатьПриобретение(ОбработчикЗакрытия,ВстроеннаяПокупка);
Сообщить(ОплатаПроизведена);
        КонецЕсли;
    #КонецЕсли

КонецПроцедуры


&НаКлиенте
Процедура ОбработкаЗакрытиПокупки(СервисВстроенныхПокупок,Успешно,Квитанция,Дополнительно) Экспорт 
    
КонецПроцедуры

Загрузил в Google Play
Установил  в мобильном устройстве Lenovo TB-8703X (версия android 6.0.1).

Нажимаю на кнопку привязанную к Команда1
Выскакивает вот такое окно https://drive.google.com/open?id=1UxBhd_6-dZxfSsCa_kesDsB1UslWgBix
Нажимаю «Ок» и віскакивает следующее окно https://drive.google.com/open?id=1Gmi9_jEfXNU9Ad99mZtD9lrRhvQMZzaG
На других мобильных устройтвах тоже пробывал, результат везде одинаковый, единственно немного бывают отличаются "иероглифы" которые приведены на скрине выше

И нигде ничего не происходит. Подскжите что я делаю неправильно, информации кроме вот этой http://v8.1c.ru/o7/201511adv/index.htm никакой в нет
Заранее брагодарен.
 
 
   Cyberhawk
 
1 - 22.12.17 - 21:01
Научишься вставлять картинки - поговорим
   soleg78
 
2 - 26.12.17 - 10:40
(1)Выскакивает вот такое окно http://soft.org.ua/1c/Error1.png
Нажимаю «Ок» и віскакивает следующее окно http://soft.org.ua/1c/Error2.png
   Cyberhawk
 
3 - 26.12.17 - 20:15
(2) Так тебе предлагают завершить клиентский сеанс, а у тебя модальное окошко открыто
   Cyberhawk
 
4 - 26.12.17 - 20:16
Кури, как нужно разрабатывать формы для нового подхода при завершении работы приложения

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует