Вход | Регистрация

1С:Предприятие ::

Метки: 

Изображение в динамическом списке, отображается очень мелко, как исправить?

Я
   ЕщеОдинПрограммист
 
21.12.17 - 18:42
Добавил отображение картинки в динамический список, согласно инструкции: http://catalog.mista.ru/public/81374/. Картинка отображается, но мелко, словно иконка - маленький квадратик слева в колонке, а картинка у меня большая. Пробовал менять значение свойства РазмерКартинки - не влияет. Как сделать, что бы картинка отображалась в реальном размере?
 
  Рекламное место пустует
   ЕщеОдинПрограммист
 
1 - 22.12.17 - 16:51
Ап, неужели никто не выводил "Поле картинки" в динамический список по навигационным ссылкам?
   nordbox
 
2 - 22.12.17 - 17:04
(1) Дык а реальный размер картинки какой?
   nordbox
 
3 - 22.12.17 - 17:04
там наверняка есть что то типа Растягивать или что то подобное
   ildary
 
4 - 22.12.17 - 17:10
(0) Не надо никаких подробностей, ни скриншотов, ни номеров версий 1С и конфигурации, форумчане обожают гадание и телепатию.
   nordbox
 
5 - 22.12.17 - 17:11
(4) ты чего его пытаешь? тебе telepat.dll не выдали что ли?
   LeoKeyn
 
6 - 22.12.17 - 17:17
(0) Возможно формат или размер картинки не подходящий, вот она и искажается.
   Мыш
 
7 - 22.12.17 - 17:17
(6) Я уже протелепатировал. У автора 1С 7.7
   Fragster
 
8 - 22.12.17 - 17:22
это будет тооооооормозить
   ЕщеОдинПрограммист
 
9 - 22.12.17 - 18:16
(2) я же написал, большая, пусть будет 200х200, а выводится всегда словно она иконка 16х16 прилепленная слева от надписи.(3) я же написал, свойство есть, но его изменение на реальный/растягивать и тп, ничего не меняет.
(4) версия 8.3.2580, конфа на основе УТ 10.3, самописные вставки и приделки УФ.
(6) пробовал bmp,png,jpg,gif. Размер больше не становится, хотя в деталях 16х16 там что-то меняется немножко от смены формата.
(7) В 1С77 динамических списков пока еще нет.
(8) это зависит от многих параметров, после будет видно, пока не работает из-за более ранних этапов.
   ЕщеОдинПрограммист
 
10 - 22.12.17 - 18:17
(4) криво указал версию платформы, правильно 8.3.10.2580
 
 
   Fragster
 
11 - 22.12.17 - 18:22
высоту строки увелич
   ЕщеОдинПрограммист
 
12 - 22.12.17 - 18:53
(11) да помогло. Криво работает. Работает если указать свойство "Высота" у колонки с картинкой, причем нужно обязательно указать 2 или более, и тогда оно не искажает картинку, даже если картинка больше ячейки. А если указать 1 или 0, тогда всегда искажает, даже если картинка заведомо влезает в ячейку.
   breezee
 
13 - 22.12.17 - 21:18
(0) Это не унструкция, это обработка без инструкции? Я понимаю, когда на ИС всякие загрузки и выгрузки для бухов заливают, чтобы они их покупали, ну тут же явно на погромистов расчет, могли бы ужекод со скринами выложить, чет обидно стало(
   ЕщеОдинПрограммист
 
14 - 22.12.17 - 21:55
(13) да там по сути сама суть не сложна.
Суть добавления картинок в управляемых сложней.
Если картинка непосредственно в том же списке, что и основная таблица для динамического списка, то в той таблице нужно еще сделать реквизит, куда сохранять навигационную ссылку. Вот мой код по этой теме:

Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    о = ТекущийОбъект;
    
    Если НЕ ЗначениеЗаполнено(о.НавигационнаяСсылка) Тогда
        Если о.ЭтоНовый() Тогда
            ссы = Справочники[о.Метаданные().Имя].ПолучитьСсылку();
            о.УстановитьСсылкуНового(ссы);
        Иначе
            ссы = о.Ссылка;
        КонецЕсли;
        о.НавигационнаяСсылка = ПолучитьНавигационнуюСсылку(ссы, "ХранилищеКартинки");
    КонецЕсли;
    
    Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) Тогда
        карт = новый Картинка(ПолучитьИзВременногоХранилища(СсылкаНаКартинку));
        о.ХранилищеКартинки = новый ХранилищеЗначения(карт);
    КонецЕсли;
    
КонецПроцедуры

(и почему на этом форуме не используют LORCODE?)

Я картинки прилепляю к другим динамическим спискам, таким образом:
    |ВЫБРАТЬ
    |    т.Ссылка КАК Ссылка,
    |    т.Проведен КАК Проведен,
    |    т.Номер КАК Номер,
    |    т.Дата КАК Дата,
    |    т.СостояниеЗаявки,
    |    тКарт.НавигационнаяСсылка как Картинка
    |ИЗ
    |    Документ.ВнутреннийЗаказ КАК т
    |    левое соединение Справочник.Картинки как тКарт
    |    по т.СостояниеЗаявки = тКарт.ИдентификационноеЗначение

т.е. Справочник.Картинки это универсальное хранилище картинок для состояний заказов или других документов, что бы были покрупней и понаглядней иконок. В таблицу на форме добавив колонку Картинка, нужно выбрать "Поле картинки". А дальше описанный выше вопрос.
   breezee
 
15 - 22.12.17 - 21:59
(14) Спасибо! Единственное что не понял - на УФ нет обработки вывода строк, как мне там в цикле по строкам пройтись и кортинку из хранилища вывести в список?
   ЕщеОдинПрограммист
 
16 - 25.12.17 - 17:27
(15) сама картинка, которая хранится в хранилище значения, в динамический список не загружается, и даже в запросе не участвует. Ее система сама подхватывает по навигационной ссылке, которая в виде строки кодирует ссылку на запись и реквизит в базе, где хранится эта картинка.
   ЕщеОдинПрограммист
 
17 - 25.12.17 - 17:33
(15) достаточное условие для вывода на форму картинки это у поля вид "Поле картинки" и путь к данным у поля указывает на реквизит строкового типа, который хранит навигационную ссылку (навигационная ссылка это строка).


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует