Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: контроль введения данных в справочнике

v7: контроль введения данных в справочнике
Я
   newmarsel
 
21.12.17 - 12:22
Всем привет. Создателю Рахмят за форум и в частности за уроки 1с.... в долеком 2003 денег заработал.
мат часть это хорошо и верно, по этому сори.
Соль: куда нажать что б элемент справочника не записывался пока пользователь не введет инф. в строку? 
//Процедура ПриЗаписи()

//    
//    //проверка заполненности обязательных реквизитов.

//    Если глПриЗаписиЭлемента("ИИН") = 0 Тогда
//        СтатусВозврата(0);

//        Возврат;
//    КонецЕсли;

//КонецПроцедуры 
делаю так не рабит - вариантов много по пробывал тоже не получилось... 
7.7 кф самописная.
 
 
   newmarsel
 
1 - 21.12.17 - 12:27
(0) Процедура ПередЗаписью()
    Если ПустоеЗначение(ИИН)=0 Тогда
        Предупреждение("Заполните реквизит ИИН");
        СтатусВозврата(1);
      КонецЕсли;
КонецПроцедуры


так же не рабит
   dicwork
 
2 - 21.12.17 - 12:31
Процедура ПриЗаписи()
    Если ПустоеЗначение(ИИН)= 1 Тогда
        Предупреждение("Заполните реквизит ИИН");
        СтатусВозврата(0);
      КонецЕсли;
КонецПроцедуры

По-моему так
   newmarsel
 
3 - 21.12.17 - 12:38
dicwork - Рахмят бро, рабит!, щас подумаю че не верно делал.
   Kigo_Kigo
 
4 - 21.12.17 - 13:16
(2) Потому что без формекса Процедуры ПередЗаписью()  в 7.7 нет
А СтатусВозврата(0) - зря заремарил, именно он отменяет действие предопределенной процедуры ПриЗаписи()
   newmarsel
 
5 - 21.12.17 - 13:23
ок, FormEx.dll спасибо - пояснили.... устроился на работу а тут 7.7 надо конфигурировать, как раз и научусь... нет опыта в программировании и не все определения понима.... поясните пожалуйста Заремарил
   Chameleon1980
 
6 - 21.12.17 - 16:23
Закомментил (в комментарии отправил)

слышал, например, про такое, как Rem в пакетниках (например в bat - файлах) ?
   DDwe
 
7 - 21.12.17 - 16:43
(5) "устроился на работу а тут 7.7 надо конфигурировать" 
"нет опыта в программировании " "как раз и научусь.."

Жесть.
   vova1122
 
8 - 21.12.17 - 17:11
(7) думаю что "нет опыта в программировании" <> "не умею программировать". Может чел. на восьмерке  учился, но еще не программировал в реальных конфигурациях
   DDwe
 
9 - 21.12.17 - 17:24
(8) Ага и код никогда не комментил )))
   vova1122
 
10 - 21.12.17 - 17:41
(9) так коментил а не ремил..... Всему есть обяснение
 
 Рекламное место пустует
   Злопчинский
 
11 - 22.12.17 - 04:50
Заремить знаю
Заремарить не знаю
   Chameleon1980
 
12 - 22.12.17 - 09:05
(11) Может от "Ремарка" Сергей :)
   VladZ
 
13 - 22.12.17 - 09:07
(0) "вариантов много по пробывал тоже не получилось".  Ты это... С магией завязывай... Тут нужно понимать, что делаешь.
   Злопчинский
 
14 - 22.12.17 - 16:51
(13) "а то как ё...!"
   trdm
 
15 - 22.12.17 - 17:22
(5) Кем устроился? Слесарем?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует