Вход | Регистрация

1С:Предприятие ::

Метки: 

Как в модуле объекта получить реквизит формы ?

Я
   r1000
 
19.12.17 - 18:12
Есть отчет с использованием СКД.
В ПриКомпоновкеРезультата() перехватываю стандартный вывод и делаю свой, с использованием внешних данных. В целом стандартная задача.
Но. На форму отчета положил реквизит СписокЗначений. Как теперь в ПриКомпоновкеРезультата() взять этот список значений ? Т.е. получается мне на сервере, во время формирования нужен этот список значений. с УФ только начинаю работать.
 
 
   r1000
 
1 - 19.12.17 - 18:16
Т.е. сразу после того как пользователь жмет на стандартную кнопку "Сформировать", нужно список значений передать на сервер и использовать в формировании этого отчета. Как ?
   FIXXXL
 
2 - 19.12.17 - 18:17
(1) в реквизит объекта засунь
   xxTANATORxx
 
3 - 19.12.17 - 18:17
сделай реквизитом объекта
   FIXXXL
 
4 - 19.12.17 - 18:18
или сделай параметром СКД, потом отроешь в недрах компоновки
   dianamestnaya
 
5 - 19.12.17 - 21:18
реквизит и компановка, вот два слова и другого не дано
   Tatitutu
 
6 - 19.12.17 - 23:17
в модуле формы


Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    ОбПередОткрытием(Отказ, ЭтаФорма);  
КонецПроцедуры


в модуле объекта:


Перем ТекущаяФорма;
Перем ТЭ;

Процедура ОбПередОткрытием(Отказ, Форма) Экспорт
    
ТекущаяФорма = Форма;
ТЭ = ТекущаяФорма.ЭлементыФормы;
    
КонецПроцедуры
   France
 
7 - 19.12.17 - 23:33
(0) а сделать тип для реквизита "что то там типа компановщик настроек"??..
   Franchiser
 
8 - 19.12.17 - 23:57
У компоновщика есть дополнительныесвойства , можно туда
   SleepyHead
 
9 - 20.12.17 - 05:54
перехвати вот это событие формы и устанавливай значение в структуру "Дополнительные свойства", примерно так:

&НаСервере
Процедура ПриЗагрузкеВариантаНаСервере(Настройки)
    Отчет.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("КлючВарианта", КлючТекущегоВарианта);
    Отчет.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("ПредставлениеВарианта ", ПредставлениеТекущегоВарианта );
КонецПроцедуры


далее в модуле объекта, в ПриКомпоновкеРезультата, эти значения доступны примерно так:

НастройкиСКД = КомпоновщикНастроек.ПолучитьНастройки();
КлючВарианта = КомпоновщикНастроек.Настройки.ДополнительныеСвойства.КлючВарианта;
   FIXXXL
 
10 - 20.12.17 - 09:29
(5) чей та не дано?
заводишь Параметр в Схеме, прям вот руками, выводишь его на форму, потом ищешь в КомпоновщикНастроек.ПолучитьНастройки().ПараметрыДанных.Элементы
 
 Рекламное место пустует
   FIXXXL
 
11 - 20.12.17 - 09:31
(10) + единственная тонкость: не надо лОжить на форму реквизит, надо сделать именно через Параметры Схемы


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует