Вход | Регистрация


1С:Предприятие ::

Метки: 

Модуль формы не заходит в функцию

Я
   LeoKeyn
 
19.12.17 - 12:32
Всем здравствуйте. Помогите, пожалуйста. Не могу понять. После нажатия кнопки на клиенте, программа нагло игнорирует функцию, в которую должна хотябы зайти, а она просто проскакивает мимо нее и идет в завершение.

&НаСервере
Функция Команда1НаСервере()
    ФизЛицо = Объект.СсылкаНаОбъект.ФизическоеЛицо;
    //Адрес = Справочники.ФизическиеЛица.СоздатьНаборЗаписей();

    //Адрес.Отбор.Тип.Установить(Перечисления.ТипыКонтактнойИнформации.Адрес);

    //Адрес.Отбор.Вид.Установить(Справочники.ВидыКонтактнойИнформации.ЮрАдресФизЛица);

    //Адрес.Отбор.Объект.Установить(Справочники.ФизическиеЛица.НайтиПоНаименованию(ФизЛицо));

    //Адрес.Прочитать();

    //Если НЕ Адрес.Количество() = 0 Тогда

    //АдресПостоянный = Адрес[0].Представление;

    //КонецЕсли;

    //Адрес = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();

    //Адрес.Отбор.Тип.Установить(Перечисления.ТипыКонтактнойИнформации.Адрес);

    //Адрес.Отбор.Вид.Установить(Справочники.ВидыКонтактнойИнформации.ФактАдресФизЛица);

    //Адрес.Отбор.Объект.Установить(Справочники.ФизическиеЛица.НайтиПоНаименованию(ФизЛицо));

    //Адрес.Прочитать();

    //Если Адрес.Количество() = 0 Тогда

    //    АдресФактический = АдресПостоянный;

    //Иначе

    //    АдресФактический = Адрес[0].Представление;

    //КонецЕсли;

    Для каждого Строка из ФизЛицо.КонтактнаяИнформация Цикл
        
        Если Строка.Тип = Перечисления.ТипыКонтактнойИнформации.Адрес И Строка.Вид = Справочники.ВидыКонтактнойИнформации.ЮрАдресОрганизации Тогда
            Адрес = Строка.Представление;
        КонецЕсли;
        
        
    КонецЦикла;

КонецФункции

&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры
 
  Рекламное место пустует
   LeoKeyn
 
1 - 19.12.17 - 12:35
(0) Это в компиляции происходит
   LeoKeyn
 
2 - 19.12.17 - 12:39
Ни кто не в курсе из-за чего такое может быть?
   Cyberhawk
 
3 - 19.12.17 - 12:40
Покажи видео
   НЕА123
 
4 - 19.12.17 - 12:43
(1)
кто такая - Компиляция?
   Lexey_
 
5 - 19.12.17 - 12:43
(2) отладка не включена на сервере
   LeoKeyn
 
6 - 19.12.17 - 12:45
(5) Другая кнопка тут же работает

&НаСервере
Функция СформироватьНаСервере()
    Об = РеквизитФормыВЗначение("Объект");
    Результат = Об.Печать();    
    ЗначениеВРеквизитФормы(Об, "Объект"); 
    Возврат Результат;
КонецФункции

&НаКлиенте
Процедура Сформировать(Команда)
    СформироватьНаСервере();
КонецПроцедуры
   LeoKeyn
 
7 - 19.12.17 - 12:46
(4) Отладка
   Ненавижу 1С
 
8 - 19.12.17 - 12:46
в первом случае контекст на клиента не возвращается
   LeoKeyn
 
9 - 19.12.17 - 12:47
(8) так дело не в том, что она что то не возвращает, а вообще на сервер не идет, тупо пропускает. Может я что то не так понимаю?
   Cyberhawk
 
10 - 19.12.17 - 12:48
Продуй кэш
 
  Рекламное место пустует
   LeoKeyn
 
11 - 19.12.17 - 12:50
(10) Клиент-сервер база, не совсем знаю как)
   LeoKeyn
 
12 - 19.12.17 - 12:53
вообще идей нет почему, пересоздал уже кнопку, та же фигня :-)
   lodger
 
13 - 19.12.17 - 12:57
(12) удали папку локального кэша 1с на своем компе для начала.
искать по адресу %appdata% , так пиши. заходишь в эхплорер и пишешь такой адрес. в папках AppData\Local\1C и AppData\Roaming\1C
   LeoKeyn
 
14 - 19.12.17 - 13:00
(13) Локальный почистил
   Ненавижу 1С
 
15 - 19.12.17 - 13:02
(9) как решил что не заходит?
   LeoKeyn
 
16 - 19.12.17 - 13:14
   LeoKeyn
 
17 - 19.12.17 - 13:14
(15) смотрю отладчиком. Заходит в процедуру нажатие, по f11 иду дальше, а в сервер не проваливается
   МимохожийОднако
 
18 - 19.12.17 - 13:23
(17) У агента 1С должен быть ключ -debug. Проверь наличие ключа. При отсутствии обратись к администратору сервера.
   LeoKeyn
 
19 - 19.12.17 - 13:25
(18) Я все это делаю во внешней обработке и под сервером имею ввиду функцию на сервере)
   МимохожийОднако
 
20 - 19.12.17 - 13:26
(19) и я про то же. Отладка на сервере должна быть включена. У тебя не включена. ИМХО."Товарищ не понимает..."
   hhhh
 
21 - 19.12.17 - 13:26
(19) а что значит выражение в (1) ?
   Ненавижу 1С
 
22 - 19.12.17 - 13:28
но утверждаешь в (6) что заходит?
   LeoKeyn
 
23 - 19.12.17 - 13:29
(22) да (6) работает и заходит
   LeoKeyn
 
24 - 19.12.17 - 13:30
(21) в отладке*
   Адинэснег
 
25 - 19.12.17 - 13:30
"C:\Program Files\1cv8\8.3.10.2252\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo" -debug

где C:\Program Files\1cv8\8.3.10.2252\bin\ragent.exe - путь до рагента
   Адинэснег
 
26 - 19.12.17 - 13:31
скажи админу что путь к запуску службы поправил
   LeoKeyn
 
27 - 19.12.17 - 13:32
(26) а причем тут это? разве в этом случае не все бы не работало? почему только одна кнопка?
   MRAK
 
28 - 19.12.17 - 13:35
Сохрани обработку с другим именем файла
   1Садовник
 
29 - 19.12.17 - 13:39
(28) и имя обработки тоже измени попробуй
   Denshu
 
30 - 19.12.17 - 13:44
Перезапусти конфигуратор, после того как перезапустишь в конфигураторе нажми Отладка ->  начало отладки -> толстый клиент(управляемое приложение) : начать отладку
   Numerus Mikhail
 
31 - 19.12.17 - 14:07
перезапусти 1с!
   Cyberhawk
 
32 - 19.12.17 - 14:31
1С:Перезагрузка
   LeoKeyn
 
33 - 19.12.17 - 16:55
Разобрался, спасибо всем
 
  Рекламное место пустует
   Numerus Mikhail
 
34 - 19.12.17 - 16:56
(33) Обычно еще принято говорить в чем была проблема и как решилась



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует