Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Разделить лист А3 на 2 при выводе табличного документа

Разделить лист А3 на 2 при выводе табличного документа
Я
   MistaEr
 
18.12.17 - 12:55
Здравствуйте!

Нужно вывести табличный документ в формат А3, чтоб потом сложить и получилась как книга.

Пишу такой вывод
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    
    ТабДокБольшой = Новый ТабличныйДокумент;
    ТабДокБольшой.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    ТабДокБольшой.РазмерСтраницы = "A3";
    
    ТабДок = Новый ТабличныйДокумент;
    ТабДок.Очистить();
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    ТабДок.РазмерСтраницы = "A4";
    ТабДок.Вывести(ОбластьШапкаТаблицы);

    Выборка = Результат.Выбрать();
    ПервыйХод = Истина;
    а = 1;
    Пока Выборка.Следующий() Цикл
        
        ОбластьДетальныхЗаписей.Параметры.Заполнить(Выборка);
        Если ТабДок.ПроверитьВывод(ОбластьДетальныхЗаписей) Тогда
            ТабДок.Вывести(ОбластьДетальныхЗаписей);
        Иначе
            Если а = 1 Тогда
                Если ПервыйХод Тогда
                    ПервыйХод = Ложь;
                Иначе
                    ТабДокБольшой.ВывестиГоризонтальныйРазделительСтраниц();
                КонецЕсли;
                ТабДокБольшой.Вывести(ТабДок);
                а = 2;
            Иначе
                ТабДокБольшой.Присоединить(ТабДок);
                а = 1;
            КонецЕсли;
            
            ТабДок.Очистить();
            ТабДок.Вывести(ОбластьШапкаТаблицы);
        КонецЕсли;
        
    КонецЦикла;
    
    ТабДокБольшой.Показать();

Не присоединяет
 
 
   MistaEr
 
1 - 18.12.17 - 13:11
Понимаю, задача не интересная)
   Леха Дум
 
2 - 18.12.17 - 13:46
А что в итоге получается?
   MistaEr
 
3 - 18.12.17 - 13:52
(2) Просто выводит ниже, вместо того чтоб присоединить справа
   Скиурус
 
4 - 18.12.17 - 14:23
Твой код, если ТабДок не влазит на А4, выводит его без изменений (не влазящий) На А3 два раза. Очевидно, нужно ТабДок разбивать.
   Скиурус
 
5 - 18.12.17 - 14:27
(4) а не, это я не доглядел. Попробуй завести три табДока, в промежуточный сохраняй две страницы методом Присоединить, а в результирующий выводи уже соединенные страницы.
   Леха Дум
 
6 - 18.12.17 - 14:40
А что в отладчике происходит? Есть как минимум одно место, из-за которого у тебя всегда идет вывод - ТабДок.ПроверитьВывод(ОбластьДетальныхЗаписей)
   MistaEr
 
7 - 18.12.17 - 15:07
(6) Конечно есть, даже Присоединить есть
   MistaEr
 
8 - 18.12.17 - 15:18
(5) Добавил ТабДокПромежуточный, вывожу там просто ТабДок - ВысотаТаблицы = 72, Присоединяю - становится 144

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует