Вход | Регистрация

1С:Предприятие ::

Метки: 

КД 2, как перенести константы?

Я
   vde69
 
18.12.17 - 11:29
сделал ПКО по "КонстантыНабор", выгружает вроде без ошибок, а при загрузки пишет


Ошибка при загрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(6045)}: Ошибка записи объекта
    ТипОбъекта             =  Константы набор
    Объект                 =  КонстантыНабор
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (Записать): Нарушение прав доступа! - 'Запрещено изменение значение условного разделения по разделителю 'ОбластьДанныхВспомогательныеДанные''
    ПозицияМодуля          =  Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(6038)
    КодСообщения           =  26
 
 
   Fragster
 
1 - 18.12.17 - 11:34
тебе же русским языком написали
   vde69
 
2 - 18.12.17 - 11:35
(1) может я еще не проснулся, но я нифига не понял из сообщения.... чего мне сделать надо?
   breezee
 
3 - 18.12.17 - 11:36
(2) Посмотреть права
   MaxS
 
4 - 18.12.17 - 11:37
Не выгружать все константы. Некоторые из них служебные.
   vde69
 
5 - 18.12.17 - 11:38
(4) это я понимаю, вопрос как определить...
   GANR
 
6 - 18.12.17 - 11:45
(5) 100% ответ не даст тут никто - боюсь, придется просто убирать из выгружаемых данных константы по одной, пока перенос не взлетит.
   Fragster
 
7 - 18.12.17 - 11:52
в журнале регистрации базы, куда данные грузятся, нет ничего?
   GANR
 
8 - 18.12.17 - 12:05
(0) Это что же у Вас там за мучительный перенос такой?
   vde69
 
Модератор
9 - 18.12.17 - 12:07
(7) ничего...

короче есть у меня мысль, что проблема не в константах а в ПользователяхИБ, точнее в их отсутствии, при переносе не создаются они

проверил эту мысль - она не влияет...
   GANR
 
10 - 18.12.17 - 12:08
Ну константы ОбластьДанныхВспомогательныеДанные и ОбластьДанныхОсновныеДанные явно надо убирать из выгрузки - это разделители. Если их убрать, то что дальше?
 
 Рекламное место пустует
   vde69
 
Модератор
11 - 18.12.17 - 12:08
(8) обрезку ЗУП делаю с НГ, штатного ничего нет...
   GANR
 
12 - 18.12.17 - 12:10
(11) Жесть! Там же средний заработок и не пойми что!
   GANR
 
13 - 18.12.17 - 12:16
И еще вопрос: база разделенная или неразделенная?
   vde69
 
14 - 18.12.17 - 12:22
убрал константы 

ИспользоватьРазделениеПоОбластямДанных
НеИспользоватьРазделениеПоОбластямДанных

ошибка осталась...

(13) не разделеная
(12) я это знаю, но у меня выхода нет, в базе куча не типовых документов а надо привести к типовой, вот и делаю...
   GANR
 
15 - 18.12.17 - 12:52
(14) Хм... В БСП есть код, который при определенных условиях прям ВызватьИсключение "Нарушение прав доступа". Может попытаться найти его глоб. поиском и поставить туда точки останова? Тогда выяснится что именно не нравится.
   GANR
 
16 - 18.12.17 - 12:59
(3) Очень вероятно, что дело в (15). Права у ТС явно Полные
   vde69
 
Модератор
17 - 18.12.17 - 14:41
короче дело в том, что записывается полный набор констант а не те которые переносятся....

Решение выложу чуть попозже
   vde69
 
18 - 18.12.17 - 14:44
в ПКО КонстантыНабор в событии "ПослеЗагрузки"

Если Объект <> Неопределено Тогда
    мСписокИсключений = Новый Массив();
    мСписокИсключений.Добавить("ИспользоватьРазделениеПоОбластямДанных");
    мСписокИсключений.Добавить("РаботаВМедицинскомУчреждении");
    мСписокИсключений.Добавить("УдалитьКонтекстРаботыЭД");
    

    Для каждого эл из Метаданные.Константы Цикл
        Попытка
            Если мСписокИсключений.Найти(эл.имя) = Неопределено Тогда
                Константы[эл.имя].Установить(Объект[эл.имя]);
            КонецЕсли;
        Исключение
            Сообщить("ошибка установки значения константы - " + эл.имя);
        КонецПопытки
    КонецЦикла;
    
    Отказ = Истина;
КонецЕсли;
   GANR
 
19 - 19.12.17 - 10:06
(18) Вот! Буду теперь помнить про эту особенность.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует