Вход | Регистрация

1С:Предприятие ::

Метки: 

Перетаскивание строк по дереву

Я
   Юзер123
 
18.12.17 - 09:31
Добрый день. нашел много примеров, но нигде понятно не описано.  Как реализваться перетаскивание строки дерева из группы в группу.


в свойствах дерева на форме поставил 2 галки разрешитьНачалоПеретаскивания,  и РазрешитьПеретаскивание.

в обработчике событий указал для НачалаПеретаскивания Стандартная обработка = истина. (мне нужно перетаскивание).  

Дальше приНачалеПеретаскивания  возник ступор) . .  Есть примеры для обычных форм?
спасибо.
 
 
   Юзер123
 
1 - 18.12.17 - 09:46
Дерево 1. ! таб часть в форме документа. перетаскивание  в пределах формы.
   FIXXXL
 
2 - 18.12.17 - 09:51
(0) а чего надо то? или не работает перетаскивание?
   Юзер123
 
3 - 18.12.17 - 09:53
Не работает. (2)
   Юзер123
 
4 - 18.12.17 - 10:12
Процедура ДеревоПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
    
    СтандартнаяОбработка = Ложь;
    

КонецПроцедуры

Процедура ДеревоНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, Выполнение)
    
    ПараметрыПеретаскивания.Действие = ДействиеПеретаскивания.Перемещение;
    ПараметрыПеретаскивания.ДопустимыеДействия = ДопустимыеДействияПеретаскивания.Перемещение;

КонецПроцедуры
   Юзер123
 
5 - 18.12.17 - 10:13
Процедура ДеревоПеретаскивание(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
    
    СтандартнаяОбработка = Ложь;
    

    
    НоваяДолжность = Строка.Должность;
    НовыйРазряд = Строка.Разряд;
    
    

        СтрокаТЧ.Должность = НоваяДолжность;
        СтрокаТЧ.Разряд = НовыйРазряд;
    
КонецПроцедуры


Создает но не там где надо.  Надо родителя теперь строки указатьвидимо)
   Юзер123
 
6 - 18.12.17 - 10:13
СтрокаТЧ =  Дерево.Строки.Добавить();
   Vaflya
 
7 - 18.12.17 - 10:17
если ничего не писать не работает?
   Юзер123
 
8 - 18.12.17 - 10:18
(7) нет
   Юзер123
 
9 - 18.12.17 - 10:18
Где не писать? вообще ничего не писать?
   Юзер123
 
10 - 18.12.17 - 10:22
Если ничего не писать то  при попытке перетащить круг перечеркнутый. не дает тащить ничего(
 
 Рекламное место пустует
   Юзер123
 
11 - 18.12.17 - 10:43
Процедура ДеревоПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
    
    СтандартнаяОбработка = ЛОЖЬ;
    

КонецПроцедуры


Процедура ДеревоНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, Выполнение)
    
    ПараметрыПеретаскивания.Действие = ДействиеПеретаскивания.Перемещение;
    ПараметрыПеретаскивания.ДопустимыеДействия = ДопустимыеДействияПеретаскивания.Перемещение;

КонецПроцедуры

Процедура ДеревоПеретаскивание(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
    
    СтандартнаяОбработка = ЛОЖЬ;
    
    //Если Строка.Уровень() = 1

     Если  ТипЗнч(ПараметрыПеретаскивания.Значение) <> Тип("СтрокаДереваЗначений") Тогда
        ПараметрыПеретаскивания.Действие = ДействиеПеретаскивания.Отмена;
        Возврат;
    КонецЕсли;
    
    НоваяДолжность = ЭлементыФормы.Дерево.ТекущаяСтрока.Должность;
    НовыйРазряд = ЭлементыФормы.Дерево.ТекущаяСтрока.Разряд;
    
    
    СтрокаТЧ =  Строка.Родитель.Строки.Добавить();
    
    
        СтрокаТЧ.Должность = НоваяДолжность;
        СтрокаТЧ.Разряд = НовыйРазряд;

        
КонецПроцедуры


Вот такая шляпа получилась. создает строку где надо.  как источник удалить?)
   Юзер123
 
12 - 18.12.17 - 10:53
Ап.

Дерево.Строки.Удалить(ПараметрыПеретаскивания.Значение);

не катит
   Юзер123
 
13 - 18.12.17 - 11:01
ПараметрыПеретаскивания.Значение.Родитель.Строки.Удалить(ПараметрыПеретаскивания.Значение);



может пригодиться кому..
   Юзер123
 
14 - 18.12.17 - 16:58
Новый вопрос.

А как переносить  группу дерева со всеми элементами???


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует