Вход | Регистрация

1С:Предприятие ::

Метки: 

как программно установить тип субконто

Я
   falselight
 
16.12.17 - 07:51
Программно делаю движени по регистру бухгалтерии.
Но у плана видов характеристик нет предопределенных видов субконто
у плана счетов 3 субконто.
 
  Рекламное место пустует
   Mankubus
 
1 - 16.12.17 - 07:54
(0) смотри процедуру БухгалтерскийУчет.УстановитьСубконто()
   falselight
 
2 - 16.12.17 - 07:56
(1) Я сотрю, но как это применить не догоняю (
   falselight
 
3 - 16.12.17 - 07:56
(1) Там так

// Процедура устанавливает субконто на счете. Если такое субконто на счете

// отсутствует, то ничего не делается.
//

// Параметры:
//        Счет - Счет, к которому относится субконто

//      Субконто - набор субконто
//        Номер или имя устанавливаемого субконто

//      Значение субконто - значение устанавливаемого субконто
//

Процедура УстановитьСубконто(Счет, Субконто, ИмяСубконто, ЗначениеСубконто, Сообщать = Ложь, Заголовок = "", ВидыСубконтоСчета = Неопределено) Экспорт

    Если Счет = Неопределено ИЛИ Счет.Пустая() Тогда
        Возврат;
    КонецЕсли;

    Если ВидыСубконтоСчета = Неопределено Тогда
         ВидыСубконтоСчета = Счет.ВидыСубконто;
    КонецЕсли; 
    
    Если ТипЗнч(ИмяСубконто) = Тип("Число") Тогда

        Если ИмяСубконто > ВидыСубконтоСчета.Количество() Тогда
            Возврат;
        КонецЕсли;

        ВидСубк = ВидыСубконтоСчета[ИмяСубконто - 1].ВидСубконто;

    Иначе

        ВидСубк = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные[ИмяСубконто];

        Если ВидыСубконтоСчета.Найти(ВидСубк) = Неопределено Тогда
            Если Сообщать тогда
                ОбщегоНазначения.СообщитьОбОшибке("Вид субконто <" + ВидСубк + "> для счета """+Счет.Код +" ("+Счет.Наименование+")"" не определен.",, Заголовок );
            КонецЕсли;
            Возврат;
        КонецЕсли;

    КонецЕсли;

    Если ВидСубк.ТипЗначения.СодержитТип(ТипЗнч(ЗначениеСубконто)) Тогда
        Субконто.Вставить(ВидСубк, ЗначениеСубконто);

    ИначеЕсли Сообщать тогда
        ОбщегоНазначения.СообщитьОбОшибке("Неверное значение """ + ЗначениеСубконто + """ для вида субконто <" + ВидСубк + ">",, Заголовок);

    КонецЕсли;

КонецПроцедуры// УстановитьСубконто()
   falselight
 
4 - 16.12.17 - 07:57
(1) Мне вот нужно

Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

    // Данный фрагмент построен конструктором.

    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!


    // регистр ОСНОВНОЙ 

    Движения.ОСНОВНОЙ.Записывать = Истина;
    Движения.ОСНОВНОЙ.Очистить();
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        Движение                         = Движения.ОСНОВНОЙ.Добавить();
        Движение.НаправлениеДеятельности = НаправлениеДеятельности;
        Движение.Валюта                  = Валюта;
        Движение.Период                  = Дата;
        Движение.СчетДт                  = ТекСтрокаТовары.СчетУчета;
        //




как сейчас задать тип субконто склады и установить значение склада?
   DDwe
 
5 - 16.12.17 - 08:01
(2) " Я сотрю, но как это применить не догоняю (", ты по жизни не догоняешь )))
   falselight
 
6 - 16.12.17 - 08:02
//1-й вариант. Установить значение субконто

        НовЗапись.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СтатьиЗатрат] = Справочники.СтатьиЗатрат.НайтиПоНаименованию("Текущий ремонт");

        //2-й вариант. Установить значение субконто

        НовЗапись.СубконтоДт.Вставить(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СтатьиЗатрат, Справочники.СтатьиЗатрат.НайтиПоНаименованию("Текущий ремонт"));        



тут задается тим субконто статьи затрат, статьи затрат я так понимаю предопределенные, а если у меня нет предопределенных, как тогда?
   DDwe
 
7 - 16.12.17 - 08:04
(6) Тебе все говорят, что это не твое. Успокойся уже.
   falselight
 
8 - 16.12.17 - 08:05
вот это у меня идет с ошибкой:

        Движение.СубконтоДт.Вставить(ПланыВидовХарактеристик.ВидыСубконто.Склады, ТекСтрокаТовары.Склад);
   falselight
 
9 - 16.12.17 - 08:05
как правильно будет в (8)
   Mankubus
 
10 - 16.12.17 - 08:05
(4)
БухгалтерскийУчет.УстановитьСубконто(Движение.СчетДт,Движение.СубконтоДт,1,Склад)
 
  Рекламное место пустует
   Mankubus
 
11 - 16.12.17 - 08:06
(10) это если склад первое субконто
   falselight
 
12 - 16.12.17 - 08:08
(11) Так не заданы предопределенные виды субконто вообще
   Mankubus
 
13 - 16.12.17 - 09:18
(12) и что дальше?
   DDwe
 
14 - 16.12.17 - 09:21
(13) Дальше он сдулся и ждет готовый код. Посмотри его темы, он уже всем надоел. ))
   h-sp
 
15 - 16.12.17 - 09:27
(8)

Движение.СубконтоДт.Вставить(ПланыВидовХарактеристик.ВидыСубконто.НайтиПоНаименованию("ХреньСНаименованием"));


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует