Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

как записать вывод сообщений в строку

как записать вывод сообщений в строку
Я
   na1kk
 
15.12.17 - 17:37
Сейчас выводит вот так http://prntscr.com/hnwthu, а нужно в строку КОнтрагент - ООО Ромашка в строке 2,3,4.

Код:

Для Каждого Элемент из Соответствие Цикл
 Сообщить("Контрагент - " + Элемент.Ключ + " в строке - ");     
             
Для Каждого Строка Из Элемент.Значение Цикл
                 
 Сообщить(Строка);
                 
КонецЦикла;
 КонецЦикла;
 
 
   LeoKeyn
 
1 - 15.12.17 - 17:39
(0)
    
            
Для Каждого Строка Из Элемент.Значение Цикл
 Сообщить("Контрагент - " + Элемент.Ключ + " в строке - " + Строка);               

                 
КонецЦикла;
 КонецЦикла;
   LeoKeyn
 
2 - 15.12.17 - 17:41
(0) или
СтокаСбор = "Контрагент - " + Элемент.Ключ + " в строке - ";     
             
Для Каждого Строка Из Элемент.Значение Цикл
                 
 СтрокаСбор = СтрокаСбор + ", " + Строка;
                 
КонецЦикла;
Сообщить(СтрокаСбор);
 КонецЦикла;
   na1kk
 
3 - 15.12.17 - 17:41
(1) не. получилось не то.

http://prntscr.com/hnwwqb
   xxTANATORxx
 
4 - 15.12.17 - 17:41
уже пятница вечер
[1с]
Для Каждого Элемент из Соответствие Цикл
   Строка = "";
Для Каждого Строка Из Элемент.Значение Цикл
                
Сообщить(Строка);
                
КонецЦикла;

Сообщить("Контрагент - " + Элемент.Ключ + " в строке - " + строка);    

КонецЦикла;[/1с]
   LeoKeyn
 
5 - 15.12.17 - 17:42
(4) Или так)
   na1kk
 
6 - 15.12.17 - 17:43
(4) тоже не то выходит.
   na1kk
 
7 - 15.12.17 - 17:43
   xxTANATORxx
 
8 - 15.12.17 - 17:43
(4)не читайте
Для Каждого Элемент из Соответствие Цикл 
   СтрокаДоп = "";
   Для Каждого Строка Из Элемент.Значение Цикл
                 
    СтрокаДоп = СтрокаДоп + ", " + Строка;
                 
   КонецЦикла;

 Сообщить("Контрагент - " + Элемент.Ключ + " в строке - " + СтрокаДоп);     

КонецЦикла;
   na1kk
 
9 - 15.12.17 - 17:44
(2) вообще до сообщить не доходит
   na1kk
 
10 - 15.12.17 - 17:45
(8) о! то что нужно! спасибо огромное!
 
 Рекламное место пустует
   LeoKeyn
 
11 - 15.12.17 - 17:47
(8) А как же догадаться?))) Хотя ты прав я бы бесился)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует