Вход | Регистрация


ЗУП 3.1 Не обновляется отображение данных при изменении документа внешней обработкой

ЗУП 3.1 Не обновляется отображение данных при изменении документа внешней обработкой
Я
   klimbna
 
15.12.17 - 11:11
Для заполнения документа из внешней обработки с типом команды: ЗаполнениеФормы
Используется Процедура:

&НаСервере
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения, ПараметрыКоманды) Экспорт
ВидВремениПусто = ОбщегоНазначенияКлиентСервер.ПредопределенныйЭлемент("Справочник.ВидыИспользованияРабочегоВремени.ПУСТАЯССЫЛКА");
Для каждого  СтрокаТЗ из ПараметрыКоманды.ЭтаФорма.Объект.ДанныеОВремени Цикл
        Для НомерДня = 1 По 30 Цикл 
            СтрокаТЗ["Часов"+НомерДня]=0;            СтрокаТЗ["ВидВремени"+НомерДня]=ВидВремениПусто;     
        КонецЦикла;    
    КонецЦикла;     
ПараметрыКоманды.ЭтаФорма.Модифицированность=Истина;     
    Сообщить("ОК");        
КонецПроцедуры

Данные обрабатываются – но на форме у пользователя остаются.
Если после обработки на форме нажать записать(или програмно отдать команду на записть)
ПараметрыКоманды.ЭтаФорма.Записать();
То данные запишутся и обновиться отображение (таблица станет пустой).
Но другого способа (без сохранения)  я не нашел.
p.s. Конфа ЗУП 3.1 платформа 8.3.10.2561 в тонком клиенте, но так же себя ведет управляемая форма на толстом клиенте и на толстом клиенте (обычное приложение).
p.p.s Подобна обработка в конфигурации Бухгалтерия 3.0 работает отлично
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует