Вход | Регистрация

1С:Предприятие ::

Метки: 

Ошибка: Пропущен символ "" (двойная кавычка)

↓ [Волшебник, 15.12.17 - 10:12]
Я
   Dasha2398
 
15.12.17 - 10:02
Помогите пожалуйста. Не могу найти ошибок.
Процедура ОбработкаПроведения(Отказ, Режим)

Движения.ОстаткиМатериалов.Записывать = Истина; Движения.СтоимостьМатериалов.Записывать = Истина; Движения.Продажи.Записывать = Истина;

//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


// Данный фрагмент построен конструктором.


// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!


Запрос = Новый Запрос; Запрос.Текст =

"ВЫБРАТЬ

| ОказаниеУслугиПереченьНоменклатуры.Номенклатура,

| ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры,

| СУММА(ОказаниеУслугиПереченьНоменклатуры.Количество) КАК

КоличествоВДокументе,

| СУММА(ОказаниеУслугиПереченьНоменклатуры.Сумма) КАК СуммаВДокументе,

| МАКСИМУМ(ОказаниеУслугиПереченьНоменклатуры.Стоимость) КАК Стоимость

|ИЗ

| Документ.ОказаниеУслуги.ПереченьНоменклатуры КАК ОказаниеУслугиПереченьНоменклатуры

|ГДЕ

| ОказаниеУслугиПереченьНоменклатуры.Ссылка = &Ссылка

|

|СГРУППИРОВАТЬ ПО

| ОказаниеУслугиПереченьНоменклатуры.Номенклатура,

| ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры";

Запрос.УстановитьПараметр("Ссылка", Ссылка);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Если ВыборкаДетальныеЗаписи.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда

// регистр ОстаткиМатериалов Расход


Движение = Движения.ОстаткиМатериалов.Добавить(); Движение.ВидДвижения = ВидДвиженияНакопления.Расход; Движение.Период = Дата;

Движение.Материал = ВыборкаДетальныеЗаписи.Номенклатура; Движение.Склад = Склад;

Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;

// регистр СтоимостьМатериалов Расход


Движение = Движения.СтоимостьМатериалов.Добавить(); Движение.ВидДвижения = ВидДвиженияНакопления.Расход; Движение.Период = Дата;

Движение.Материал = ВыборкаДетальныеЗаписи.Номенклатура;

Движение.Стоимость = ВыборкаДетальныеЗаписи.КоличествоВДокументе*ВыборкаДетальныеЗаписи.Стоимость;

КонецЕсли;

// Регистр Продажи


Движение = Движения.Продажи.Добавить(); Движение.Период = Дата;

Движение.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;

Движение.Клиент = Клиент; Движение.Мастер = Мастер;

Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;

Движение.Выручка = ВыборкаДетальныеЗаписи.СуммаВДокументе;

Движение.Стоимость = ВыборкаДетальныеЗаписи.Стоимость * ВыборкаДетальныеЗаписи.КоличествоВДокументе;

КонецЦикла;

КонецПроцедуры
 
  Рекламное место пустует
   Numerus Mikhail
 
1 - 15.12.17 - 10:05
На какую строчку ругается? Точный текст ошибки скопируй и скинь
   Dasha2398
 
2 - 15.12.17 - 10:07
На строчку: | СУММА(ОказаниеУслугиПереченьНоменклатуры.Количество) КАК



Ошибка инициализации модуля: Документ.ОказаниеУслуги.МодульОбъекта
по причине:
{Документ.ОказаниеУслуги.МодульОбъекта(20,59)}: Пропущен символ '"' (двойная кавычка)
| СУММА(ОказаниеУслугиПереченьНоменклатуры.Количество) КАК<<?>>
{Документ.ОказаниеУслуги.МодульОбъекта(20,59)}: Ожидается символ ';'
| СУММА(ОказаниеУслугиПереченьНоменклатуры.Количество) КАК<<?>>
{Документ.ОказаниеУслуги.МодульОбъекта(22,21)}: Неопознанный оператор
КоличествоВДокументе<<?>>,
   НЕА123
 
3 - 15.12.17 - 10:08
предполагаю, не хватает | перед
КоличествоВДокументе,
   Numerus Mikhail
 
4 - 15.12.17 - 10:08
(2) поставь палку перед количествовдокументе или сделай это одной строкой с предыдущей
   drcrasher
 
5 - 15.12.17 - 10:08
(0) КоличествоВДокументе подтяни к предыдущей строке
   nordbox
 
6 - 15.12.17 - 10:10
в одну строчку сделай
   Dasha2398
 
7 - 15.12.17 - 10:11
Спасибо большое) помогло)
   Адинэснег
 
8 - 15.12.17 - 10:12
(0)правым кликом, Конструтор запросов
шаманишь в к онструкторе, жмешь ок
а он уже в модуль перенесет твои и кавычки, и переносы строк как надо
   Darych
 
9 - 15.12.17 - 10:26
| ОказаниеУслугиПереченьНоменклатуры.Номенклатура.ВидНоменклатуры";


Список тем форума
Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует