Вход | Регистрация


УФ. СКД. Расшифровка

УФ. СКД. Расшифровка
Я
   nAPACEHAK
 
13.12.17 - 16:41
Добра всем
Помогите плз. чот с вызовом сервера на УФ совсем запутался
Отчет на СКД. Как получить значение полей в строке, из которой вызывается расшифровка?
т.е., например, строка
Контрагент - Город
при вызове расшифровки на контрагенте хочу получить все значения в этой строке, т.е. и контрагента и город (в параметры документа)

Вот тут запутался :( 

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка, ДополнительныеПараметры)
        Перем ВыбранноеДействие;
    Перем ПараметрыВыбранногоДействия;
    
    СтандартнаяОбработка = Ложь;
    
    ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных (ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных (Отчет));
    
    ДоступныеДействия = Новый Массив;
    ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
    //ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Отфильтровать);

    //ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Расшифровать);

    
    ДополнительныеДействия = Новый СписокЗначений;
    ДополнительныеДействия.Добавить("УстановитьРелиз", "Установить новый релиз");
    ОбработкаРасшифровки.ПоказатьВыборДействия(Новый ОписаниеОповещения("РезультатОбработкаРасшифровкиЗавершение", ЭтотОбъект, Новый Структура("ВыбранноеДействие, ПараметрыВыбранногоДействия, Расшифровка", ВыбранноеДействие, ПараметрыВыбранногоДействия, Расшифровка)), Расшифровка, ДоступныеДействия, ДополнительныеДействия);


КонецПроцедуры

&НаКлиенте
Процедура РезультатОбработкаРасшифровкиЗавершение( ВыбранноеДействие,  ПараметрыВыбранногоДействия, ДополнительныеПараметры1) Экспорт
    
    Расшифровка = ДополнительныеПараметры1.Расшифровка;
    
    
    Если ПараметрыВыбранногоДействия <> Неопределено Тогда
        Если ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
            ПоказатьЗначение(Новый ОписаниеОповещения("РезультатОбработкаРасшифровкиЗавершение", ЭтотОбъект), ПараметрыВыбранногоДействия);
        КонецЕсли; 
    Иначе
        Если ВыбранноеДействие = "УстановитьРелиз" Тогда
            Сообщить ("Установка");    
            //НовДок = СоздатьДокументРелизНаСервере ();

            ДокПараметры = Новый Структура("Конфигурация", ); 
            ДокФорма = ПолучитьФорму("Документ.ИзменениеРелизаКонфигурации.ФормаОбъекта");
            
            //////////Поле =  ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля ()[0];

            ////////Поле = ПолучитьПолеНаСервере (ДанныеРасшифровки, Расшифровка);

            ////////Сообщить("Поле: " + Поле.Поле + ", значение: " + Поле.Значение);

            
            
            ДокФорма.Открыть ();
            
        КонецЕсли; 
    КонецЕсли;

КонецПроцедуры

---
в ДанныеРасшифровки - тип "строка"
не могу вкурить как на сервере данныерасшифровки получить (((
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует