Вход | Регистрация


Help! Конфигуратор выдает ошибку: что Ожидается ключевое слово "КонецПроцедуры"

Help! Конфигуратор выдает ошибку: что Ожидается ключевое слово "КонецПроцедуры"
Я
   Dasha2398
 
13.12.17 - 13:15
Ожидается ключевое слово "КонецПроцедуры". Помогите пожалуйста понять, в чем ошибка?

Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

    // Данный фрагмент построен конструктором.

    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!


    // регистр ОстаткиМатериалов Приход

    Процедура ОбработкаПроведения(Отказ, Режим)
    Движения.ОстаткиМатериалов.Записывать = Истина;
    Движения.СтоимостьМатериалов.Записывать = Истина;

    Для Каждого ТекСтрокаМатериалы Из Материалы Цикл

        //регистр ОстаткиМатериалов Приход

       Движение = Движения.ОстаткиМатериалов.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
     Движение.Материал = ТекСтрокаМатериалы.Материал;
    Движение.Склад=Склад;
    Движение.Количество = ТекСтрокаМатериалы.Количество:

      //регистр СтоимостьМатериалов Приход

       Движение = Движения.СтоимостьМатериалов.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Материал = ТекСтрокаМатериалы.Материал;
     Движение.Стоимость=ТекСтрокаМатериалы.Сумма;
КонецЦикла;
КонецПроцедуры;
        //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
 
 
   Fish
 
1 - 13.12.17 - 13:15
(0) В точке с запятой :))
   Amra
 
2 - 13.12.17 - 13:16
Процедура ОбработкаПроведения(Отказ, Режим)
    

    Процедура ОбработкаПроведения(Отказ, Режим)

Тему можно закрывать
   HEKPOH
 
3 - 13.12.17 - 13:16
два объявления процедуры
   Fish
 
4 - 13.12.17 - 13:17
+(1) Ну и (2) и (3).
   Табуретко
 
5 - 13.12.17 - 13:18
(0) с днем рождения Даша!
   Fish
 
6 - 13.12.17 - 13:19
(5) У неё 23-го марта :))
   Dasha2398
 
7 - 13.12.17 - 13:22
Всем спасибо большое) Помогло)
   Serg_1960
 
8 - 13.12.17 - 13:28
Это ещё не всё :) В строке "Движение.Количество = ТекСтрокаМатериалы.Количество:" - вместо двоеточия нужна точка с запятой.

С днём рождения, Даша!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует