Вход | Регистрация


1С:Предприятие ::

Метки: 

ЗУП3: изменение таб.№ после перехода из ЗУП2.5

Я
   dft2014
 
13.12.17 - 13:03
После переноса данных из ЗУП2.5 в ЗУП3, у всех сотрудников таб.№ заполнен так: д000000063, д000000064 и т.д.

Сейчас, при создании нового сотрудника, табельный номер начинает новую нумерацию с ПР00-00001. Я посмотрела, у организации установлен префикс ПР, его я могу убрать (критично ли это?). Но вот как в ЗУП3 сделать так, чтобы нумерация табельных номеров продолжилась с д000000065?
 
 
   dft2014
 
1 - 13.12.17 - 13:06
+(0) Нашла в ЗУП3 подписку на событие УстановитьПрефиксИБИОрганизацииКодуСправочникаЗарплатаКадрыБазовая:
Источник - СправочникОбъект.Сотрудники
Событие - ПриУстановкеНовогоКода
Обработчик - ПрефиксацияОбъектовСобытия.УстановитьПрефиксИнформационнойБазыИОрганизации

Но здесь он только префикс ставит, а сама нумерация откуда берется?
   dft2014
 
2 - 13.12.17 - 13:15
Процедура УстановитьПрефиксИнформационнойБазыИОрганизации(Источник, СтандартнаяОбработка, Префикс) Экспорт
    
    УстановитьПрефикс(Источник, Префикс, Истина, Истина);
    
КонецПроцедуры



Процедура УстановитьПрефикс(Источник, Префикс, УстановитьПрефиксИнформационнойБазы, УстановитьПрефиксОрганизации)
    
    ПрефиксИнформационнойБазы = "";
    ПрефиксОрганизации        = "";
    
    Если УстановитьПрефиксИнформационнойБазы Тогда
        
        ПриОпределенииПрефиксаИнформационнойБазы(ПрефиксИнформационнойБазы);
        
        ДополнитьСтрокуНулямиСлева(ПрефиксИнформационнойБазы, 2);
    КонецЕсли;
    
    Если УстановитьПрефиксОрганизации Тогда
        
        Если РеквизитОрганизацияДоступен(Источник) Тогда
            
            ПриОпределенииПрефиксаОрганизации(
                Источник[ИмяРеквизитаОрганизация(Источник.Метаданные())], ПрефиксОрганизации);
            // Если задана пустая ссылка на организацию.

            Если ПрефиксОрганизации = Ложь Тогда
                
                ПрефиксОрганизации = "";
                
            КонецЕсли;
            
        КонецЕсли;
        
        ДополнитьСтрокуНулямиСлева(ПрефиксОрганизации, 2);
    КонецЕсли;
    
    ШаблонПрефикса = "[ОР][ИБ]-[Префикс]";
    ШаблонПрефикса = СтрЗаменить(ШаблонПрефикса, "[ОР]", ПрефиксОрганизации);
    ШаблонПрефикса = СтрЗаменить(ШаблонПрефикса, "[ИБ]", ПрефиксИнформационнойБазы);
    ШаблонПрефикса = СтрЗаменить(ШаблонПрефикса, "[Префикс]", Префикс);
    
    Префикс = ШаблонПрефикса;
    
КонецПроцедуры
   Aradel3d
 
3 - 13.12.17 - 13:16
Руками вбейте номер, потом создайте нового.
   dft2014
 
4 - 13.12.17 - 13:17
Типовой код из (2) возвращает "ПР00", а откуда идет заполнение "00001", что в итоге создает ПР00-00001?
   Naumov
 
5 - 13.12.17 - 13:18
0001 создает платформа, с использованием сформированного префикса.

У тебя либо префикс у организации указан, либо префикс Узла обмена.
   M_Flint
 
6 - 13.12.17 - 13:18
Нет табельного с таким префиксом, вот и возвращает 00001.
   dft2014
 
7 - 13.12.17 - 13:19
(3) Пробовала у нового сотрудника вручную установить таб.№д000000065, затем создаю еще олного нового сотрудника и у него таб.№ПР00-00001
   Aradel3d
 
8 - 13.12.17 - 13:20
У ПР номер 1, а у 000000 - 65
   dft2014
 
9 - 13.12.17 - 13:21
(5) Префикс указан в настройках организации. Я могу его убрать, но тогда нумерация начинается с 0000-00001
   dft2014
 
10 - 13.12.17 - 13:21
(8) И как быть?
 
  Рекламное место пустует
   Aradel3d
 
11 - 13.12.17 - 13:22
(10) вбить номер для ПР
   M_Flint
 
12 - 13.12.17 - 13:22
Я в своей базе просто добавила префикс к табельным номерам. В приказах печатается без префикса.
   dft2014
 
13 - 13.12.17 - 13:25
(11) Не поняла...
(12) Дело не только в префиксе, а в том, что сама нумерация и без префикса начинается с 1, а должна с 65
   Aradel3d
 
14 - 13.12.17 - 13:28
(13) Исправляете номер у последнего проблемного на свой ПР000000777, далее будет для ПР ПР000000778 и т.п. автоматически.
   hhhh
 
15 - 13.12.17 - 13:28
(13) вбейте вручную ей номер ПР00-00064, а дальше она сама пойдет
   Aradel3d
 
16 - 13.12.17 - 13:30
Надо было фотку просить сперва, там написано СПБ.
   dft2014
 
17 - 13.12.17 - 13:39
(15) Вбейте вручную номер ПР00-00064. Теперь нумерация у следующих новых сотрудников стала идти почти правильно: ПР00-00064 и т.д.
Но мне надо, чтобы вместо ПР00-00064 было д000000064 !!!
   Aradel3d
 
18 - 13.12.17 - 13:40
Фотку показать теперь надобно. Тогда скажу)
   Джо-джо
 
19 - 13.12.17 - 13:43
   dft2014
 
20 - 13.12.17 - 13:45
(18) Разобралась! Всем СПАСИБО!!!
   SadrArt
 
21 - 13.12.17 - 13:53
вроде как д000...  - это договорники ГПХ



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует