Вход | Регистрация

1С:Предприятие ::

Метки: 

помогите найти ошибку

Я
   kofanovka
 
09.12.17 - 14:28
Процедура Печать для формирования печатной формы документа(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать для формирования печатной формы  документа)

    Макет = Документы.ОказаниеУслуг.ПолучитьМакет("Печать для формирования печатной формы  документа");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ОказаниеУслуг.Дата,
    |    ОказаниеУслуг.Клиент,
    |    ОказаниеУслуг.Мастер,
    |    ОказаниеУслуг.Номер,
    |    ОказаниеУслуг.Склад,
    |    ОказаниеУслуг.ПереченьНоменклатуры.(
    |        НомерСтроки,
    |        Номенклатура,
    |        Колличество,
    |        Цена,
    |        Сумма
    |    )
    |ИЗ
    |    Документ.ОказаниеУслуг КАК ОказаниеУслуг
    |ГДЕ
    |    ОказаниеУслуг.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьПереченьНоменклатурыШапка = Макет.ПолучитьОбласть("ПереченьНоменклатурыШапка");
    ОбластьПереченьНоменклатуры = Макет.ПолучитьОбласть("ПереченьНоменклатуры");
    ОбластьИтог=Макет.ПолучитьОбласть("Всего");
    ТабДок.Очистить();

    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;

        ТабДок.Вывести(ОбластьЗаголовок);

        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());

        ТабДок.Вывести(ОбластьПереченьНоменклатурыШапка);
        ВыборкаПереченьНоменклатуры = Выборка.ПереченьНоменклатуры.Выбрать();
        СуммаИтог=0;
        Пока ВыборкаПереченьНоменклатуры.Следующий() Цикл
            ОбластьПереченьНоменклатуры.Параметры.Заполнить(ВыборкаПереченьНоменклатуры);
            ТабДок.Вывести(ОбластьПереченьНоменклатуры, ВыборкаПереченьНоменклатуры.Уровень());
            СуммаИтог=СуммаИтог+ВыборкаПереченьНоменклатуры.Сумма;
        КонецЦикла;
        ОбластьИтог.Параметры.ВсегоПоДокументу=СуммаИтог;
        ТабДок.Вывести(Областьитог);

        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;

    //}}

КонецПроцедуры











{Документ.ОказаниеУслуг.МодульМенеджера(2,17)}: Ожидается символ '('
Процедура Печать<<?>> для формирования печатной формы документа(ТабДок, Ссылка) Экспорт (Проверка: Сервер)
{Документ.ОказаниеУслуг.МодульМенеджера(2,35)}: Ожидается символ '='
Процедура Печать для формирования <<?>>печатной формы документа(ТабДок, Ссылка) Экспорт (Проверка: Сервер)
 
 
   Остап Сулейманович
 
1 - 09.12.17 - 14:30
(0) ПолучитьМакет("Печать для формирования печатной формы  документа")
У вас действительно макет вот так называется : "Печать для формирования печатной формы  документа"?
   Остап Сулейманович
 
2 - 09.12.17 - 14:32
Сорри. Не досмотрел.
Процедура тоже на полном серьезе имеет имя :

"Печать для формирования печатной формы документа"

???

Я даже затрудняюсь сказать где же ошибка...
   DDwe
 
3 - 09.12.17 - 15:22
(0) Ты там кто на работе? Или это не работа?
   youalex
 
4 - 09.12.17 - 15:25
Колличество -  тоже интересно. Сразу ассоциации - море,Солнце,Италия.
   kofanovka
 
5 - 09.12.17 - 15:29
я студент, и поняла что очень глупый))))) дело и правда оказалось в имени. Спасибо)
   Сияющий в темноте
 
6 - 09.12.17 - 17:15
(5)главное-учиться и не повторять своих ошибок
тогда и заработать больше чем тарелку супа


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует