Вход | Регистрация

1С:Предприятие ::

Метки: 

Поместить элементы данные в хранилище перед записью УФ

Я
   breezee
 
08.12.17 - 20:05
Добрый вечер! Подскажите, пожалуйста:
1)Есть справочник, у справочника есть 2 реквизита с типом хранилище значений
2)Перед записью записываю данные из формы в хранилище
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    
    ГруппаРабочихЦентров = Новый ХранилищеЗначения(ГруппаРабочихЦентровСписок);
           
    Дерево = РеквизитФормыВЗначениеСервер("РеквизитыТехКарт"); 
    
    НастройкиДляТаблицИКолонок = Новый ХранилищеЗначения(Дерево);
    
    УстановитьДанныеВХранилищеСервер(ГруппаРабочихЦентров, НастройкиДляТаблицИКолонок);
    
КонецПроцедуры

&НаСервере
Процедура УстановитьДанныеВХранилищеСервер(ГруппаРабочихЦентров, НастройкиДляТаблицИКолонок)
    
    СправОбъект = РеквизитФормыВЗначение("Объект");
    
    СправОбъект.ГруппаРабочихЦентров         = ГруппаРабочихЦентров;
    СправОбъект.НастройкиДляТаблицИКолонок     = НастройкиДляТаблицИКолонок;

КонецПроцедуры

&НаСервере
Функция РеквизитФормыВЗначениеСервер(ИмяРеквизита)
    Возврат РеквизитФормыВЗначение(ИмяРеквизита);
КонецФункции    

3)При открытии читаю данные Дерево = РеквизитФормыВЗначениеСервер("Объект").НастройкиДляТаблицИКолонок.Получить();

4)Получается значение "Неопределено" при чтении
Вопрос: Почему получается "Неопределено", хотя я в перед записью смотрел в отладке, что хранилище в реквизиты попадает
 
  Рекламное место пустует
   Cyberhawk
 
1 - 08.12.17 - 20:17
Лениво трассировать твой код через форум
   breezee
 
2 - 08.12.17 - 20:28
Вопрос закрыт, забыл объект в форму вернуть...
   breezee
 
3 - 08.12.17 - 20:42
Не закрыт, вернул о форму даные, в ссылку они не записываются, фигня какая-то
   breezee
 
4 - 08.12.17 - 20:43
И если в конце этой процедуры
&НаСервере
Процедура УстановитьДанныеВХранилищеСервер(ГруппаРабочихЦентров, НастройкиДляТаблицИКолонок)
    
    СправОбъект = РеквизитФормыВЗначение("Объект");
    
    СправОбъект.ГруппаРабочихЦентров         = ГруппаРабочихЦентров;
    СправОбъект.НастройкиДляТаблицИКолонок     = НастройкиДляТаблицИКолонок;

    ЗначениеВРеквизитФормы(СправОбъект, "Объект");
    
КонецПроцедуры

вычисляю РеквизитФормыВЗначение("Объект").НастройкиДляТаблицИКолонок.Получить()
у меня тоже неопределено получается
   breezee
 
5 - 08.12.17 - 21:02
Каким-то образом переес все в ПередЗаписьюНаСервере 
и заработало


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует