Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вывод пиктограммы в журналах документов

Вывод пиктограммы  в журналах документов
Я
   Aldnepr
 
08.12.17 - 14:26
Возможно ли в 8 выводить свою пиктограмму на список доков (или журнал доков)при присвоении реквизиту значение булево, например ВыводитьПиктограмму= Истина;
 
 
   DrShad
 
1 - 08.12.17 - 14:27
возможно
   Aldnepr
 
2 - 08.12.17 - 14:27
(1) подскажите как. в 7 просто было, тут не могу найти(
   DrShad
 
3 - 08.12.17 - 14:29
картинка строк смотри
   Aldnepr
 
4 - 08.12.17 - 14:41
(3) КартинКи строк нашел в оформлении, но как задать функцию,
чтобы она выводилась в 7 у меня так было
Функция ВывестиПиктограмму()
    Кл=0;
    Если (Число(ТекущийДокумент.Выбран())>0) Тогда
        Если (ТекущийДокумент.Вид()="РасходнаяНакладная")или(ТекущийДокумент.Вид()="ЧекККМ") Тогда
            Если ТекущийДокумент.Запрет=Перечисление.ДаНет.Да Тогда
                Кл=1;
            Иначе
                Кл=0;
            КонецЕсли;
        Иначе
            Кл=0;
        КонецЕсли;
    Иначе
        Кл=0;
    КонецЕсли;      
    Возврат Кл;
КонецФункции
   DrShad
 
5 - 08.12.17 - 14:44
смотри в типовых
   Aldnepr
 
6 - 08.12.17 - 14:47
(5) не видел там пиктограмм, только флажки выводятся при необходимости
   ixijixi
 
7 - 08.12.17 - 14:51
В палитре свойств ищи КартинкаСтрок
   Aldnepr
 
8 - 08.12.17 - 15:12
(7) Да нашел ее, но как выводить при условии не могу догнать(
   perester
 
9 - 08.12.17 - 15:19
Там есть что-то типа связанные данные или тип того, смотря от его значения и выводится нужная иконка, 0 (ложь), первая картинаа, 1 (истина) вторая картинка, если больше значений надо то там в данных проставляется число
   Lexey_
 
10 - 08.12.17 - 15:26
 
 Рекламное место пустует
   SergTheGreat
 
11 - 08.12.17 - 17:02
Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    Для каждого ОС Из ОформленияСтрок Цикл
        Если ТВОЕУСЛОВИЕ = Истина Тогда
            ОС.Ячейки.ПЕРВАЯКОЛОНКА.УстановитьКартинку(ТВОЯКАРТИНКА);
        Иначе
            // пустая картинка

            ОС.Ячейки.ПЕРВАЯКОЛОНКА.УстановитьКартинку(Новый Картинка);
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует